topicänderung: amavisd-new scannt und erkennt kein spam

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-10 14:33

Hallo,

folgende konfiguration:
Suse 9.0
postfix 2.0.15
cyrus
procmail

bringt auf meinem Server in meinen Logfiles folgender Fehler:

Dec 10 13:49:48 intern01 postfix/pipe[2342]: 60677153655: to=<aixspace@aixspace.dyndns.org>, orig_to=<fgorzelanczyk@aixspace.dyndns.org>, relay=procmail, delay=2385, status=deferred (temporary failure)

der fehler tritt dann auf wenn ich in der main.cf den Wert mailbox_transport = procmail und nicht mailbox_transport = cyrus setze.
das blöde ist das die mail zwar ankommt aber die mail auch gleichzeitig in der mailq hängt. :-(

ich möchte deswegen procmail benutzen weil ich noch spamassassin einsetze und dann erst an cyrus ausliefern will.

kennt jemand die problematik und hat ne lösung ?

gruss gonzo_ac
Last edited by gonzo_ac on 2003-12-13 15:41, edited 1 time in total.

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by captaincrunch » 2003-12-10 14:46

Wie wär's denn mit amavisd-new?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-11 00:43

ok, danke erst mal für den tipp. mit amavisd scheint es zu funktionieren.
bin zwar nicht ganz so zu frieden als wie wenn es mit procmail laufen würde :-)

gruss gonzo_ac

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by captaincrunch » 2003-12-11 09:07

bin zwar nicht ganz so zu frieden als wie wenn es mit procmail laufen würde
Wieso das? amavisd ist die wesentlich flexiblere Lösung, in die du auch problemlos einen oder mehrere Virenscanner einbringen kannst.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-13 13:58

okok überedet! :-)

amavisd-new ist eingerichtet und scannt auch fein nach viren aber spam kommt durch als wenn es kein spam wäre :-(

hab ich irgenwo ne einstellung übersehen ???
in der amavisd.conf sind die einstellungen bezüglich SA :

Code: Select all

$sa_local_tests_only = 0;   # (default: false)
#$sa_auto_whitelist = 1;    # turn on AWL (default: false)

$sa_mail_body_size_limit = 64*1024;  # don't waste time on SA if mail is larger
                            # (less than 1% of spam is > 64k)
                            # default: undef, no limitations

# default values, can be overridden by more specific lookups, e.g. SQL
$sa_tag_level_deflt  = 3.0; # add spam info headers if at, or above that level
$sa_tag2_level_deflt = 5.0;
$sa_kill_level_deflt = $sa_tag2_level_deflt; # triggers spam evasive actions
                            # at or above that level: bounce/reject/drop,
                            # quarantine, and adding mail address extension
#
# The $sa_tag_level_deflt, $sa_tag2_level_deflt and $sa_kill_level_deflt
# may also be hashrefs to hash lookup tables, to make static per-recipient
# settings possible without having to resort to SQL or LDAP lookups.

# a quick reference:
#   tag_level  controls adding the X-Spam-Status and X-Spam-Level headers,
#   tag2_level controls adding 'X-Spam-Flag: YES', and editing Subject,
#   kill_level controls 'evasive actions' (reject, quarantine, extensions);
# it only makes sense to maintain the relationship:
# tag_level <= tag2_level <= kill_level

# string to prepend to Subject header field when message exceeds tag2 level
#$sa_spam_subject_tag = '***SPAM*** ';  # (defaults to undef, disables)
                             # (only seen when spam is not to be rejected
                             # and recipient is in local_domains*)

#$sa_spam_modifies_subj = 1; # may be a ref to a lookup table, default is true

# Example: modify Subject for all local recipients except user@example.com
#$sa_spam_modifies_subj = [qw( !user@example.com . )];

gruss gonzo

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-13 15:55

Code: Select all

# @bypass_spam_checks_acl  = qw( . );  # uncomment to DISABLE anti-spam code
dies muss SO aussehen. Mach mal amavisd-new debug, da siehst Du, was geladen wird

gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-13 16:14

hi die zeile die du mir genannt hast ist einkommentiert.

wenn ich amavisd starte dann kommt

Code: Select all

Dec 13 16:03:27 intern01 amavis[21672]: Perl version               5.008001
Dec 13 16:03:27 intern01 amavis[21672]: Module Amavis::Conf        1.15
Dec 13 16:03:27 intern01 amavis[21672]: Module Archive::Tar        0.23
Dec 13 16:03:27 intern01 amavis[21672]: Module Archive::Zip        1.05
Dec 13 16:03:28 intern01 amavis[21672]: Module Compress::Zlib      1.16
Dec 13 16:03:28 intern01 amavis[21672]: Module Convert::TNEF       0.17
Dec 13 16:03:28 intern01 amavis[21672]: Module Convert::UUlib      0.31
Dec 13 16:03:28 intern01 amavis[21672]: Module MIME::Entity        5.404
Dec 13 16:03:28 intern01 amavis[21672]: Module MIME::Parser        5.406
Dec 13 16:03:28 intern01 amavis[21672]: Module MIME::Tools         5.411
Dec 13 16:03:28 intern01 amavis[21672]: Module Mail::Header        1.58
Dec 13 16:03:28 intern01 amavis[21672]: Module Mail::Internet      1.58
Dec 13 16:03:28 intern01 amavis[21672]: Module Mail::SpamAssassin  2.60
Dec 13 16:03:28 intern01 amavis[21672]: Module Net::Cmd            2.24
Dec 13 16:03:28 intern01 amavis[21672]: Module Net::DNS            0.38
Dec 13 16:03:28 intern01 amavis[21672]: Module Net::SMTP           2.26
Dec 13 16:03:28 intern01 amavis[21672]: Module Net::Server         0.85
Dec 13 16:03:28 intern01 amavis[21672]: Module Time::HiRes         1.51
Dec 13 16:03:28 intern01 amavis[21672]: Module Unix::Syslog        0.98
Dec 13 16:03:28 intern01 amavis[21672]: Found myself: /usr/sbin/amavisd -c /etc/amavisd.conf
Dec 13 16:03:28 intern01 amavis[21672]: Lookup::SQL code       NOT loaded
Dec 13 16:03:28 intern01 amavis[21672]: Lookup::LDAP code      NOT loaded
Dec 13 16:03:28 intern01 amavis[21672]: AMCL-in protocol code  loaded
Dec 13 16:03:28 intern01 amavis[21672]: SMTP-in protocol code  loaded
Dec 13 16:03:28 intern01 amavis[21672]: ANTI-VIRUS code        loaded
Dec 13 16:03:28 intern01 amavis[21672]: ANTI-SPAM  code        loaded
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Process Backgrounded
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: 2003/12/13-16:03:28 Amavis (type Net::Server::PreForkSimple) starting! pid(21673)
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Binding to UNIX socket file /var/spool/amavis/amavisd.sock using SOCK_STREAM
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Binding to TCP port 10024 on host 127.0.0.1
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Setting gid to "101 101"
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Setting uid to "65"
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Couldn't POSIX::setuid to "65" [Illegal seek]
Dec 13 16:03:28 intern01 amavis[21673]: Found $file       at /usr/bin/file
Dec 13 16:03:28 intern01 amavis[21673]: Found $arc        at /usr/bin/arc
Dec 13 16:03:28 intern01 amavis[21673]: Found $gzip       at /usr/bin/gzip
Dec 13 16:03:28 intern01 amavis[21673]: Found $bzip2      at /usr/bin/bzip2
Dec 13 16:03:28 intern01 amavis[21673]: No $lzop,         not using it
Dec 13 16:03:28 intern01 amavis[21673]: Found $lha        at /usr/bin/lha
Dec 13 16:03:28 intern01 amavis[21673]: Found $unarj      at /usr/bin/unarj
Dec 13 16:03:28 intern01 amavis[21673]: Found $uncompress at /usr/bin/uncompress
Dec 13 16:03:28 intern01 amavis[21673]: No $unfreeze,     not using it
Dec 13 16:03:28 intern01 amavis[21673]: Found $unrar      at /usr/bin/unrar
Dec 13 16:03:28 intern01 amavis[21673]: Found $zoo        at /usr/bin/zoo
Dec 13 16:03:28 intern01 amavis[21673]: Found $cpio       at /usr/bin/cpio
Dec 13 16:03:28 intern01 amavis[21673]: Found primary av scanner H+BEDV AntiVir or CentralCommand Vexira Antivirus at /usr/bin/antivir
Dec 13 16:03:28 intern01 amavis[21673]: SpamControl: initializing Mail::SpamAssassin
Dec 13 16:03:29 intern01 amavis[21673]: SpamControl: done
so wie ich das sehe ist alles klar
aber alles was spam ist kommt durch :-)

ich kanns deswegen so genau sagen da ich mails von meinem t-online-postfach abrufe mit fetchmail abrufen und dann an eine 2te email auf nem anderen server schicke und die da locker als spam erkannt werden.

gruss gonzo

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-13 17:18

dann wirds wohl an SA liegen und nicht an Amavisd. Mach mal spamassassin -D --lint und poste mal die Ausgabe.

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-13 22:42

poste bitte mal ein Link auf deine amavisd.conf

Es gibt ein paar Optionen, die SA deaktivieren..

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-13 23:26

das ist wohl nicht nötig. Die Zeile:

Code: Select all

Dec 13 16:03:28 intern01 amavis[21672]: ANTI-SPAM  code        loaded
sagt doch, dass es geladen wird

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-13 23:30

falls local_domains nicht gesetzt ist, bringt der Code aber auch nichts ;)

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-13 23:43

ja, wirklich? :roll:

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-13 23:47

AFAIK werden nur Mails an eine lokale Domain getaggt..

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-14 00:08

ja, sicher. Aber dazu ist IMHO nicht nötig, sie auch einzutragen.

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-14 00:12

wie soll amavisd es dann wissen?

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-14 00:18

gethostname? Ich weiss nicht. :oops:

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-14 00:25

nope, ein Mailserver kann ja mehrere Domains handeln ohne selber der Domain im DNS anzugehören..

Aus der Conf:
# local_domains* lookup tables are used in deciding whether a recipient
# is local or not, or in other words, if the message is outgoing or not.
# This affects inserting spam-related headers for local recipients,
# limiting recipient virus notifications (if enabled) to local recipients,
# in deciding if address extension may be appended, and in SQL lookups
# for non-fqdn addresses. Set it up correctly if you need features
# that rely on this setting (or just leave empty otherwise).

adjustman
Posts: 1132
Joined: 2003-03-26 23:29
Location: SA

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by adjustman » 2003-12-14 00:38

Du hast Recht :oops:

gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-14 14:58

ok sorry das es so lange gedauert hat.

hier meine ausgabe con spamassassin -D -lint

Code: Select all

debug: Score set 0 chosen.
debug: running in taint mode? yes
debug: Running in taint mode, removing unsafe env vars, and resetting PATH
debug: PATH included '/sbin', keeping.
debug: PATH included '/usr/sbin', keeping.
debug: PATH included '/usr/local/sbin', keeping.
debug: PATH included '/root/bin', keeping.
debug: PATH included '/usr/local/bin', keeping.
debug: PATH included '/usr/bin', keeping.
debug: PATH included '/usr/X11R6/bin', keeping.
debug: PATH included '/bin', keeping.
debug: PATH included '/usr/games', keeping.
debug: PATH included '/opt/gnome/bin', keeping.
debug: Final PATH set to: /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin
debug: ignore: using a test message to lint rules
debug: using "/usr/share/spamassassin" for default rules dir
debug: using "/etc/mail/spamassassin" for site rules dir
debug: using "/root/.spamassassin" for user state dir
debug: using "/root/.spamassassin" for user state dir
Created user preferences file: /root/.spamassassin/user_prefs
debug: using "/root/.spamassassin/user_prefs" for user prefs file
debug: using "/root/.spamassassin" for user state dir
debug: bayes: no dbs present, cannot scan: /root/.spamassassin/bayes_toks
debug: Score set 1 chosen.
debug: Initialising learner
debug: bayes: Not available for scanning, only 0 spam(s) in Bayes DB < 200
debug: bayes: 28415 untie-ing
debug: bayes: 28415 untie-ing db_toks
debug: is Net::DNS::Resolver available? yes
debug: trying (3) yahoo.de...
debug: looking up MX for 'yahoo.de'
debug: MX for 'yahoo.de' exists? 1
debug: MX lookup of yahoo.de succeeded => Dns available (set dns_available to hardcode)
debug: is DNS available? 1
debug: all '*From' addrs: ignore@compiling.spamassassin.taint.org
debug: running header regexp tests; score so far=0
debug: running body-text per-line regexp tests; score so far=1.27
debug: Razor2 is not available
debug: running raw-body-text per-line regexp tests; score so far=1.27
debug: running uri tests; score so far=1.27
debug: uri tests: Done uriRE
debug: running full-text regexp tests; score so far=1.27
debug: Current PATH is: /sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome/bin
debug: Pyzor is not available: pyzor not found
debug: Razor2 is not available
debug: DCCifd is not available: no r/w dccifd socket found.
debug: DCC is not available: no executable dccproc found.

und meine amavisd.conf findet ihr hier

gruss gonzo

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-14 15:03

setze
$sa_debug = 1;

und starte amavisd auf der Konsole

Dann schicke GTUBE-Testmail und poste das Ergebnis bitte..

gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-14 15:10

öhm wie meinen ? :?:

was meinst du mit GTUBE-Testmail schicken ?????

*ahnungslosguck*

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-14 15:33


gonzo_ac
Posts: 92
Joined: 2003-06-17 18:43

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by gonzo_ac » 2003-12-14 15:47

ok danke.
wenn ich mir also gtube zuschicke dann kommt

Code: Select all

Yes, hits=1000.2 tag1=3.0 tag2=5.0 kill=5.0 tests=GTUBE, RCVD_IN_NJABL, RCVD_IN_SORBS
demnach wird also gescannt und erkannt. :-)

aber das subject wird nicht mit ***SPAM*** erweitert

gruss gonzo

torstenk
Posts: 42
Joined: 2003-03-29 16:03
Location: Leverkusen

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by torstenk » 2003-12-14 15:57

gonzo_ac wrote:hi die zeile die du mir genannt hast ist einkommentiert.

wenn ich amavisd starte dann kommt

Code: Select all

Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Setting gid to "101 101"
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Setting uid to "65"
Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Couldn't POSIX::setuid to "65" [Illegal seek]
gruss gonzo
Also ich habe diese Zeile nicht in meinem Log

Code: Select all

Dec 13 16:03:28 intern01 amavis[21673]: Net::Server: Couldn't POSIX::setuid to "65" [Illegal seek]
Was bedeutet denn das ??

jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: topicänderung: amavisd-new scannt und erkennt kein spam

Post by jtb » 2003-12-14 17:38

gonzo_ac wrote:ok danke.
wenn ich mir also gtube zuschicke dann kommt

Code: Select all

Yes, hits=1000.2 tag1=3.0 tag2=5.0 kill=5.0 tests=GTUBE, RCVD_IN_NJABL, RCVD_IN_SORBS
demnach wird also gescannt und erkannt. :-)

aber das subject wird nicht mit ***SPAM*** erweitert
dein Empfänger ist nicht in local_domains?