MySQL connecten nicht mehr ...

MySQL, PostgreSQL, SQLite
marry
Posts: 27
Joined: 2003-06-20 17:01

MySQL connecten nicht mehr ...

Post by marry » 2003-12-05 11:20

Hallo,

habe eine Update auf PHP 4.3.3 gemacht (mit dem RPMs für SuSe 8.1, was auch installiert ist). Zudem habe ich Webmin installiert.

Nun .. es läuft alles soweit, nur alle MySQL Datenbanken sind nicht mehr erreichbar (werden aber im Webmin angezeigt, sind also noch da).

Folgende Fehlermeldung kommt:

Code: Select all

Warning: mysql_connect(): Access denied for user: 'web9@localhost' (Using password: NO) 
Jemand ne Idee?

Neu starten tec. hat nichts gebracht ...

darkspirit
Posts: 553
Joined: 2002-10-05 16:39
Location: D'dorf

Re: MySQL connecten nicht mehr ...

Post by darkspirit » 2003-12-05 11:26

Das liegt wohl weniger am PHP-Update. Sind die Zugangsdaten denn korrekt? Ist wirklich kein Passwort für web9 gesetzt?

marry
Posts: 27
Joined: 2003-06-20 17:01

Nein

Post by marry » 2003-12-05 11:31

Das ist es ja ... es wurde im phpMyAdmin bzw. sonstigen Scripts nicht geändert, Alle User haben ein Passwort, keine Ahnung wieso da ein "NO" bei Passwort steht.

Ich hab echt keine Ahnung, was da schief gegangen ist.

darkspirit
Posts: 553
Joined: 2002-10-05 16:39
Location: D'dorf

Re: MySQL connecten nicht mehr ...

Post by darkspirit » 2003-12-05 11:41

Erstmal einen Fehler bei MySQL ausschließen, indem du versuchst, über die Shell zu connecten. Wenn das geht, schreib dir ein kurzes Testscript mit einer Datenbankverbindung und schau mal, was passiert.

marry
Posts: 27
Joined: 2003-06-20 17:01

Bin n00b

Post by marry » 2003-12-05 11:43

wie gesagt, bin ein voll-n00b ;))
ka, wie ich über shell connecte

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: MySQL connecten nicht mehr ...

Post by gamecrash » 2003-12-05 11:52

Das Problem musst Du in Deinen PHP-Scripten suchen, weil die sich ganz offensichtlich mit dem Server ohne Passwort verbinden wollen... werden da vielleicht irgendwelche Variablen per Sessions übergeben und jetzt ist register_globals aus?

marry
Posts: 27
Joined: 2003-06-20 17:01

Is an

Post by marry » 2003-12-05 11:55

Hi,

ne, register_globals ist "on", zumindest habe ich das so in der php.ini stehen. oder gehört das noch woanders hin?

aber sessions werden verwendet ..

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: MySQL connecten nicht mehr ...

Post by gamecrash » 2003-12-05 12:02

Kannst Du mal Deinen mysql_connect()-Befehl (mit *** als Passwort natürlich) posten?

php.ini ist schon richtig, vorrausgesetzt, es ist auch die, die PHP verwendet ;)

marry
Posts: 27
Joined: 2003-06-20 17:01

hm

Post by marry » 2003-12-05 12:04

welchen connect befehl?

tritt überall auf
phpbb forum
confixx login
phpmyadmin login

einfach übreall

marry
Posts: 27
Joined: 2003-06-20 17:01

man

Post by marry » 2003-12-05 12:06

jetzt startet nach einem reboot auch der apache nimmer +boaaah+

Code: Select all

Cannot load /usr/lib/apache/lib.php4.so into server: libmysqlclient.so.10:cannot open shared object file: No such file or directory

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: MySQL connecten nicht mehr ...

Post by gamecrash » 2003-12-05 12:07

Hm, dann liegt's am Befehl schonmal sicher nicht...

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: man

Post by gamecrash » 2003-12-05 12:09

Marry wrote:jetzt startet nach einem reboot auch der apache nimmer +boaaah+

Code: Select all

Cannot load /usr/lib/apache/lib.php4.so into server: libmysqlclient.so.10:cannot open shared object file: No such file or directory
Hm, hast Du zufällig irgendwelche Probleme mit den Abhängigkeiten gehabt? mach mal

updatedb && locate libmysqlclient.so

und poste hier die Ausgabe...

marry
Posts: 27
Joined: 2003-06-20 17:01

äh?

Post by marry » 2003-12-05 12:10

ich steig nimmer durch

apache läuft wieder, nachdem ich mod_perl deinstalliert habe

marry
Posts: 27
Joined: 2003-06-20 17:01

Ausgabe

Post by marry » 2003-12-05 12:13

Ausgabe:

Code: Select all

/usr/libmysaqclient.so
/usr/libmysaqclient.so.10
/usr/libmysaqclient.so.10.0.0
/usr/libmysaqclient.so.12
/usr/libmysaqclient.so.12.0.0
/usr/lib/mysql/libmysaqclient.so.10
/usr/lib/mysql/libmysaqclient.so.10.0.0
d.h. nun?

gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: MySQL connecten nicht mehr ...

Post by gamecrash » 2003-12-05 12:21

Ã?h, libmysaqclient? Du solltest nach libmysqlclient suchen ;)

marry
Posts: 27
Joined: 2003-06-20 17:01

tippfehler

Post by marry » 2003-12-05 12:24

is nur n tippfehler von mir
die heißt schon so die datei
ausm putty rauszukopieren is halt so ne sache ;)

marry
Posts: 27
Joined: 2003-06-20 17:01

Geht wiedert

Post by marry » 2003-12-05 12:31

Hi,

es geht wieder alles. Hatte PHP zunmächst mit den SuSe RPMs installiert. Habs jetzt nochmalk drüber installiert, aber dieses mal selbst kompiliert. Jetzt gehts ...

Maaaaaaaaaan .. trotzdem deine für deine Bemühungen :)