Panne beim Kernel-Update

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
roland_h
Posts: 6
Joined: 2003-12-03 14:39

Panne beim Kernel-Update

Post by roland_h »

Hallo Rooties,
ich habe gerade einen neuen Kernel in meinen alten Rootserver 900 (noch unter SuSE 7.2) einspielen wollen und trotz einiger Tests irgendwie Pech gehabt :-( Der Server läßt sich nicht mal mehr über das Rescue-System erreichen!

Was habe ich getan?
Kernelquellen von ftp.de.kernel.org besorgt
mit make oldconfig die bisherige Konfiguration eingespielt
mit make menuconfig die Einstellungen kontrolliert und einige Einträge geändert (speziell die VIA82CXXX-Unterstützung aktiviert, die der Server braucht.
Kernel kompiliert und nach /boot kopiert
LILO (ist auf dem Server noch Bootmanager) aufgerufen
Neustart
Anmeldung klappt, uname -a zeigt den neuen Kernel, Dienste laufen

Wo ist das Problem?
In der /var/log/messages stand, dass er die System.map nicht fände. Das wäre zwar egal gewesen, denn alle wesentlichen Treiber waren statisch eingebunden (das war u.a. der Zweck des Updates), hat mich aber geärgert. Also habe ich den vorhandenen Link umbenannt und die System.map vom neuen Kernel unter dem Namen /boot/System.map gespeichert (ich habe keine EXTRAVERSION angegeben).
Neustart und PENG - weg war er!

Ok - also wollte ich das Rescue-System starten und den Fehler beheben (LILO nötig bei Ã?nderung an System.map?) oder eben den Link wieder restaurieren, aber nix is! Auch mit Reset in das Rescue-System gehen lassen klappt nicht mehr - kein ping - keine Antwort!

Die Fragen:
Kann man da noch was retten? Wenn ja wie?
Was habe ich falsch gemacht? Auf meinem anderen Server hat's geklappt! Der Server hat beim ersten Neustart ja sogar noch gelebt...
Warum läßt er sich nicht mal mehr im Rescue-System ansprechen?

Vielleicht hat ja jemand eine Idee und kann mir helfen - Danke

Roland

PS.: Vermutung meinerseits: irgendwie hängt der Server beim Plattencheck fest - nur warum? Ich habe ihn mit reboot gestartet, d.h. er müsste seine Platten ordentlich umountet haben.

dopefish
Posts: 142
Joined: 2003-02-06 12:57
Location: Karlsruhe

Re: Panne beim Kernel-Update

Post by dopefish »

ich denke das problem ist weniger an dir, sondern an dein provider, wenn der server nicht mal mehr im rescue modus hochläuft dann stimmt irgendwas grundlegendes daran nicht. am besten anrufen und die sollen dannach schauen.

[Nachtrag]
Du wirst lachen, ich habe heute ebenfalls mein kernel upgedatet und gerade neu gebootet weil jetzt erst der server einiegrmassen leer war. siehe da es komtm weder hoch, noch passiert irgendwas beim rescue modus.


Ah, kam doch wieder hoch, hat aber SEHR lange gedauert .......

roland_h
Posts: 6
Joined: 2003-12-03 14:39

Die Lösung: Hardware-Defekt

Post by roland_h »

Hallo Rooties,
nach einem Anruf bei der Hotline war der Rechner zwar schnell wieder im Rescue-System erreichbar, verweigerte sich allerdings wiederum beim Reboot.

Der Supporter musste wohl einen Techniker im Rechenzentrum bitten, den Server manuell zu resetten. Er sagte noch was von "die Reset-Logik sei wohl defekt und müsse daher wohl ausgetauscht werden" - was der Laden denn auch prompt und sehr gründlich besorgt hat: Eine halbe Stunde später war der Rechner wieder online! Allerdings mit SuSE 8.1 und einer komplett anderen Hardware... Zum Glück war nix wichtiges mehr drauf ;-)

Fazit: Pluspunkte für schnellen, unkomplizierten und durchaus kompetenten Ablauf des Supportfalls - allerdings auch einen Minuspunkt für den Austausch der Hardware (vor allem Festplatte) ohne jegliche Vorwarnung, obwohl die Chance zum Retten der Daten noch bestanden hätte! Um's noch mal klar zu formulieren: die Reinitialisierung erfolgte OHNE Fax-Auftrag und ohne mündlichen Hinweis!

Frohen 2. Advent noch

Roland