Seltsame meldung im syslog? NIC defekt?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
KriS
Posts: 37
Joined: 2003-03-14 14:39

Seltsame meldung im syslog? NIC defekt?

Post by KriS »

Hi

folgende meldungen habe ich in meinem syslog meiner Debian maschine gefunden, bevor sie ohne grund rebootet hat :(
Das sind die letzen Einträge vor dem reboot.
Kann mir da wer erklären was da los war?
Ist evtl. die NIC defekt?
Dec 1 19:38:01 p15124663 /USR/SBIN/CRON[6594]: (root) CMD (/root/confixx/confixx_counterscript.pl)
Dec 1 19:39:01 p15124663 /USR/SBIN/CRON[6602]: (root) CMD (/root/confixx/confixx_counterscript.pl)
Dec 1 19:39:11 p15124663 kernel: eth0: Setting half-duplex based on MII #1 link partner capability of 0000.
Dec 1 19:39:51 p15124663 kernel: eth0: Setting full-duplex based on MII #1 link partner capability of 41e1.
Dec 1 19:40:01 p15124663 /USR/SBIN/CRON[6606]: (root) CMD (/root/confixx/confixx_counterscript.pl)
Dec 1 19:40:24 p15124663 init: Switching to runlevel: 6
Dec 1 19:40:26 p15124663 postfix/postfix-script: stopping the Postfix mail system
Dec 1 19:40:26 p15124663 postfix/master[16869]: terminating on signal 15
der Fehler tritt nun ca. seit einer Woche auf immer mal wieder keine festen Zeiten. evtl weiss ja jemand was sie bedeutet und kann sie mit erklären?

Danke
So long
KriS

dodolin
Posts: 3840
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Seltsame meldung im syslog? NIC defekt?

Post by dodolin »

Ja, das "könnte" z.B. eine defekte NIC sein. Ich würde das dem Support schreiben (auch, dass es immer wieder auftritt) und darum bitten, die NIC zu prüfen oder gleich zu tauschen.

KriS
Posts: 37
Joined: 2003-03-14 14:39

Re: Seltsame meldung im syslog? NIC defekt?

Post by KriS »

Hi,

dem SUpport habe ich es mittlerweile auch gemeldet....
Die meinten es wären Probs mit debian bekannt, wenn in der KErnel config die option CONFIG_IP_MULTICAST=y gesetzt ist.
Das ist bei mir leider der Fall :(
Ich meine ich habe den 2.4.21-grsec Kernel hier vom RootForum.

Ich traue mich allerdings nicht einen neuen Kernel zu kompilen :(
Ich habs grad mal hier local auf nem Testserver versucht, bin leider gescheitert. Konnte den Testserver mit mühe und Not wieder retten. (jetzt läuft er wieder*g*).

Naja mal schaun...
Der 1und1 Support meinte das sollte ich nochmal testen. Was sie aber stutzig macht, ist das der Server schon unter SuSE dieses verhalten gezeigt hat, und da war solch ein Prob bisher unbekannt.
Also wenn das mitm Kernel nicht hilft wollen se nen Techniker zum Server schicken der den dann mal auseinander nimmt.

Danke für die antwort...
So long
KriS

dodolin
Posts: 3840
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Seltsame meldung im syslog? NIC defekt?

Post by dodolin »

Die meinten es wären Probs mit debian bekannt, wenn in der KErnel config die option CONFIG_IP_MULTICAST=y gesetzt ist.
Das war der First-Level-Support. Die werfen mal wieder unreflektiert mit ihren Textbausteinen um sich.

Das mit dem Multicast kann wohl dazu führen, dass der Kernel komische Pakete rausbläst, was die Switches dazu veranlasst, die Kisten sicherheitshalber runterzufahren. Das ist doch was komplett anderes als bei dir! Sage ihnen das nochmal!

Ich glaube kaum, dass dein Problem mit dem Multicast-Support im Kernel zu tun hat.
Was sie aber stutzig macht, ist das der Server schon unter SuSE dieses verhalten gezeigt hat, und da war solch ein Prob bisher unbekannt.
Was doch sehr den Schluß auf fehlerhafte Hardware nahelegt, oder nicht? Nach erneutem Nachdenken, könnte es vielleicht auch ein leicht beschädigtes Netzwerkkabel sein, oder ein Wackelkontakt irgendwo an einem Kabelende. Aber vermutlich ist einfach die NIC defekt.

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Seltsame meldung im syslog? NIC defekt?

Post by captaincrunch »

Ich muss langsam echt mal mit jemandem halbwegs fähigen bei der 1&1 Hotline reden. Das Multicast-"Problem" scheint ja mittlerweile als Standardtemplate für alles genommen zu werden, und selbst daran glaube ich nicht. Wie auch immer, die nächsten DebianHowto-Kernel werden keinen Multicast-Support mehr enthalten, mal schauen, mit was die sich dann rausreden. ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc