qmail startet nicht

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
at120
Posts: 31
Joined: 2003-05-24 21:18

qmail startet nicht

Post by at120 » 2003-12-01 20:20

Hallo Leute!

Also, ich habe einmal die Anleitung:http://www.debianhowto.de/howtos/de/qma ... index.html
durchgearbeitet und die einzelnen Programme/Packet so wie beschrieben installiert. Allerdings habe ich das Problem, dass qmail nicht starten will und mir mit folgender Fehlermeldung stirbt:
##### anfang ####
/etc/init.d/qmail start
Starting mail-transfer agent: qmail/etc/init.d/qmail: Uncomment: command not found
.
##### ende ####

Jetzt habe ich die /etc/init.d/qmail durchgeschaut ob ich mich vielleicht irgendwo vertippt habe bei den Ã?nderungen die zu machen waren. Nein, habe ich nicht.
Wer weiß weiter wo ich noch suchen könnte bzw. weiß jemand genaues?

Danke für jede Hilfe/Tip!

MfG Alex

blackdrum23
Posts: 85
Joined: 2003-09-30 21:24
Location: Aying

Re: qmail startet nicht

Post by blackdrum23 » 2003-12-02 17:55

Wie wärs mit dem QMail startscript

at120
Posts: 31
Joined: 2003-05-24 21:18

Re: qmail startet nicht

Post by at120 » 2003-12-03 15:10

naja, aber dieses startscript ist doch in /etc/init.d/qmail gespeichert. oder habe ich jetzt was nicht ganz verstanden? lt. anleitung sollte es dort sein.
oder meinst du ein anderes script?

mfg alex

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail startet nicht

Post by kenzo » 2003-12-03 15:41

oder habe ich jetzt was nicht ganz verstanden?
Sieht fast so aus - "zeig uns das Skript" verstehe ich.

at120
Posts: 31
Joined: 2003-05-24 21:18

Re: qmail startet nicht

Post by at120 » 2003-12-03 16:19

ahhh, trott.. wieder mal voll auf der leitung gestanden, aber voll. sorry :-) (dabei wollte ich noch fragen ob ich es posten soll, tsss)
ok, hier mal der inhalt:

#### anfang ####

#!/bin/bash
#
# /etc/init.d/qmail : start or stop the qmail mail subsystem.
#
# Written by Christian Hudon <chrish@debian.org>
# Currently maintained by Jon Marler <jmarler@debian.org>
#
# Configuration
#


# set default delivery method

alias_empty="|/usr/sbin/qmail-procmail" # procmail delivery to /var/spool/mail
#alias_empty="./Maildir/" # This uses qmail prefered ~/Maildir/ directory
# You may want to maildirmake /etc/skel/Maildir
#alias_empty="./Mailbox" # This uses Mailbox file in users $HOME

logger="splogger qmail"
#logger="|accustamp >>/var/log/qmail.log" # If you have accustamp installed.
#logger=">>/var/log/qmail.log" # Does not give timing info.

# If you uncommented one of the lines that appends to /var/log/qmail.log, you
# need to uncomment the following two lines.
#touch /var/log/qmail.log
#chown qmaill /var/log/qmail.log

#
# End of configuration
#

test -x /usr/sbin/qmail-start || exit 0
test -x /usr/sbin/qmail-send || exit 0

case "$1" in
start)
echo -n "Starting mail-transfer agent: qmail"
sh -c "start-stop-daemon --start --quiet --user qmails
--exec /usr/sbin/qmail-send
--startas /usr/sbin/qmail-start -- "$alias_empty" $logger &"
# prevent denial-of-service attacks, with ulimit
ulimit -v 8192
sh -c "start-stop-daemon --start --quiet --user qmaild
--exec /usr/bin/tcpserver -- -R -H
-u `id -u qmaild` -g `id -g nobody` -x /etc/tcp.smtp.cdb 0 smtp
/usr/sbin/qmail-smtpd mein_domain.at
/var/vpopmail/bin/vchkpw /bin/true 2>&1 | $logger -t qmail -p mail.notice &"

Uncomment the following lines to automatically start the pop3 server
sh -c "start-stop-daemon --start --quiet --user root
--exec /usr/bin/tcpserver --
-H -R 0 pop-3 /usr/sbin/qmail-popup `hostname`.`dnsdomainname`
/var/vpopmail/bin/vchkpw /usr/sbin/qmail-pop3d Maildir &"

echo "."
;;
stop)
echo -n "Stopping mail-transfer agent: qmail"
if [ "`pidof /usr/sbin/qmail-send`" ] ; then
start-stop-daemon --user qmails --stop --quiet --oknodo --exec /usr/sbin/qmail-send
start-stop-daemon --user qmaild --stop --quiet --oknodo --exec /usr/bin/tcpserver
# Uncomment the following line if you have enabled the pop3 server
start-stop-daemon --user root --stop --quiet --oknodo --exec /usr/bin/tcpserver

# Wait until the timeout for qmail processes to die.
count=120
numdots=0
while ([ $count != 0 ]) do
let count=$count-1
if [ "`pidof /usr/sbin/qmail-send`" ] ; then
echo -n .
let numdots=$numdots+1
sleep 1
else
count=0
fi
done

# If it's not dead yet, kill it.
# if [ "`pidof /usr/sbin/qmail-send`" ] ; then
# echo -n " TIMEOUT!"
# kill -KILL `pidof /usr/sbin/qmail-send`
# else
case $numdots in
0) echo "." ;;
1) echo ;;
*) echo " done." ;;
esac
# fi
else
echo " not running.";
fi

;;
restart)
$0 stop
$0 start
;;
reload|force-reload)
echo "Reloading 'locals' and 'virtualdomains' control files."
start-stop-daemon --stop --quiet --oknodo --signal HUP --exec /usr/sbin/qmail-send
;;
*)
echo 'Usage: /etc/init.d/qmail {start|stop|restart|reload}'
exit 1
esac

exit 0

#### ende #####

mein_domain.at da steht die domain drinnen.

Vielen dank!

MfG Alex

blackdrum23
Posts: 85
Joined: 2003-09-30 21:24
Location: Aying

Re: qmail startet nicht

Post by blackdrum23 » 2003-12-03 16:45

Nach meinem Vergleich hast du eine Zeile zuviel auskommentiert
und zwar

Code: Select all

Uncomment the following lines to automatically start the pop3 server 
sh -c "start-stop-daemon --start --quiet --user root  
--exec /usr/bin/tcpserver --  
-H -R 0 pop-3 /usr/sbin/qmail-popup `hostname`.`dnsdomainname`  
/var/vpopmail/bin/vchkpw /usr/sbin/qmail-pop3d Maildir &" 
Die erste Zeile ist ein Kommentar, sollte so aussehen

Code: Select all

#Uncomment the following lines to automatically start the pop3 server 
sh -c "start-stop-daemon --start --quiet --user root  
--exec /usr/bin/tcpserver --  
-H -R 0 pop-3 /usr/sbin/qmail-popup `hostname`.`dnsdomainname`  
/var/vpopmail/bin/vchkpw /usr/sbin/qmail-pop3d Maildir &" 
Ich glaube das sollte der Fehler sein, sonst sehe ich keinen Unterschied

Sers Oli

at120
Posts: 31
Joined: 2003-05-24 21:18

Re: qmail startet nicht

Post by at120 » 2003-12-03 16:53

bingo!

danke, habe ich voll übersehen!
danke dir funktioniert!

mfg alex