Debian - strato Rootserver - lilo bootproblem

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
thesurf
Posts: 6
Joined: 2003-11-20 23:28

Debian - strato Rootserver - lilo bootproblem

Post by thesurf »

Hi,

habe das system mit dem debian-installer.sh aufgesetzt.
Wurde auch alles installiert und so. Nach einem reboot blieb die rescue-console einfach schwarz. Es kommt einfach garnix.

Code: Select all

lilo -v -v -b /dev/hda -D Debian
brachte garnix.

/etc/lilo.conf:

Code: Select all

boot=/dev/hda1
root=/dev/hda3
map=/boot/map
default=Debian
delay=5
install=/boot/boot-menu.b
lba32

image=/boot/vmlinuz-2.4.18-bf2.4
label=Debian
Read-only
Ich habe keine ahnung warum das teil einfach nicht booten will
habe:
/dev/hda1 als 45mb bootpartion
und
/dev/hda3 also systemroot

das teil will einfach nicht booten. Es ist ein Std. Debian Woody mit bf.2.4.18 er kernel.

hal9000
Posts: 15
Joined: 2003-11-21 00:22

Re: Debian - strato Rootserver - lilo bootproblem

Post by hal9000 »

na ja.. um die remote console zu betreiben brauchst di in lilo.conf folgende einträge:

Code: Select all

boot=/dev/hda1 
root=/dev/hda3 
map=/boot/map 
default=Debian 
delay=5 
install=/boot/boot-menu.b 
lba32 
serial = 0,57600n8

image=/boot/vmlinuz-2.4.18-bf2.4 
label=Debian 
Read-only
append ="console=tty0 console=ttyS0,57600"
jetzt habe ich eine frage an dich, da ich auch einen server bei strato habe und debian installiert habe.
was ist dieser "debian-installer.sh", wo hast du das her? wie hast du debian installiert?
ich habe alles irgendwie per hand gemacht, hda3 partition auf 2 gb verkleinert und debian per debootstrap auf hda4 installiert.
vielleicht nicht die eleganteste methode.
würde mich interessieren, wie du's gemacht hast ;)

gruss
sebastian

hal9000
Posts: 15
Joined: 2003-11-21 00:22

Re: Debian - strato Rootserver - lilo bootproblem

Post by hal9000 »

ok, hab's weiter unten im forum gefunden ;)
scheisse, da hätte ich mir etwas recherche und arbeit ersparen können!
bin ja kein linux profi... scheisse... na ja.. ehhehe

thesurf
Posts: 6
Joined: 2003-11-20 23:28

Re: Debian - strato Rootserver - lilo bootproblem

Post by thesurf »

ok
hatte es erst selbt mit debootstap von der rettungsconsole versucht aber da paßt die libc nicht so ganz und so weiter. Ich habe alles Platt gemacht was vorher drauf war. Partionen von hand angelegt und dann die ensprechenden Zeilen aus dem script gekillt. *lol* wie klein es da auf einmal war ;-)

Das teil ist jetzt auch gebotet.

hal9000
Posts: 15
Joined: 2003-11-21 00:22

Re: Debian - strato Rootserver - lilo bootproblem

Post by hal9000 »

gut so... dann viel spass!
ich habe viel mühe gehabt, confixx zu installieren. die benötigte pakete haben meist andere namen, hab dann auch selbst fehler gemacht... momentan funkt bei mir alles ausser dns mit confixx.... darüber habe ich aber schon in ein anderes post geschrieben unter nameserver.
gruss!

thesurf
Posts: 6
Joined: 2003-11-20 23:28

Re: Debian - strato Rootserver - lilo bootproblem

Post by thesurf »

Hast du auch ICQ?

Nunja das mit deinen 2 Zeilen zu meiner lilo.conf hat es nicht gebracht die console ist nach wie vor schwarz. Liegt vielleicht am server. Ich habe in der Console von dem Rettungssystem gesehen da Hyperthrading abgeschaltet ist. Vielleicht bekommt man da ja per ACPI wieder an. Mein ICQ steht ja in meinem Profil.

hal9000
Posts: 15
Joined: 2003-11-21 00:22

Re: Debian - strato Rootserver - lilo bootproblem

Post by hal9000 »

sorry, hab da noch was vergessen
in /etc/inittab soll eine S0 Zeile hinzugefügt werden:

Code: Select all

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100
S0:12345:respawn:/sbin/getty -L 57600 ttyS0 vt102
so, jetzt sollte es klappen ;)

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Debian - strato Rootserver - lilo bootproblem

Post by captaincrunch »

Ups ... gut dass ihr's sagt, denn die Ã?nderungen an der lilo.conf sind noch nicht mit drin. Ich sehe mal zu, dass ich die heute noch mit einpflege.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

thesurf
Posts: 6
Joined: 2003-11-20 23:28

Re: Debian - strato Rootserver - lilo bootproblem

Post by thesurf »

Jo stimmt wohl!

trag auch noch mit ein das in die inittab eine Zeile rein muß

inittab:

Code: Select all

S0:12345:respawn:/sbin/getty -L 57600 ttyS0 vt102
lilo.conf:
vor den kernelimages,

Code: Select all

serial = 0,57600n8
und bei dem kernelimage informationen das anhängen

Code: Select all

append ="console=tty0 console=ttyS0,57600"
Damit bekommt man den output dann auch auf der Recoveryconsole.

mikespi
Posts: 95
Joined: 2002-12-28 17:47
Location: Muenchen

Re: Debian - strato Rootserver - lilo bootproblem

Post by mikespi »

Super KLAPPT!

Danke
Mike

mixus
Posts: 39
Joined: 2002-10-14 09:26

Re: Debian - strato Rootserver - lilo bootproblem

Post by mixus »

Hi,

ich habe heute das zweite mal debian auf einem ded. Server installiert.

Leider ging einmal die RemoteConsole und jetzt gehts nicht mehr....

Vielleicht hat ja jemand ne Idee?!

lilo.conf
boot=/dev/hda
root=/dev/hda3
install=/boot/boot-menu.b
lba32
serial = 0,57600n8

image=/vmlinuz
label=debian
read-only
append ="console=tty0 console=ttyS0,57600"
inittab
[...]
# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100
S0:12345:respawn:/sbin/getty -L 57600 ttyS0 vt102
[...]
MFG und Danke
mixus

fraglor
Posts: 4
Joined: 2004-02-09 22:41

Re: Debian - strato Rootserver - lilo bootproblem

Post by fraglor »

Ich habe die Zeilen eingefügt, aber in der Konsole tut sich trotzdem irgendwie nichts.

hal9000
Posts: 15
Joined: 2003-11-21 00:22

Re: Debian - strato Rootserver - lilo bootproblem

Post by hal9000 »

vielleicht hat sich da was geändert bei neueren servers.
einfch von den suse config files abgucken, was da in lilo.conf und inittab steht

fraglor
Posts: 4
Joined: 2004-02-09 22:41

Re: Debian - strato Rootserver - lilo bootproblem

Post by fraglor »

Leider komme ich an eine original lili.conf nicht dran.
Könnte wer seine posten?

squize
Userprojekt
Userprojekt
Posts: 729
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Debian - strato Rootserver - lilo bootproblem

Post by squize »

lilo.conf
boot=/dev/hda
root=/dev/hda3
install=/boot/boot-menu.b
lba32
serial=0,57600n8
image=/vmlinuz
initrd=/initrd.img
label=debian
read-only
append="console=tty0 console=ttyS0,57600"


inittab
# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:2:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
# <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
S0:12345:respawn:/sbin/getty -L 57600 ttyS0 vt102
Die Console funktioniert einwandfrei. :)

Gruss

Marc

fraglor
Posts: 4
Joined: 2004-02-09 22:41

Re: Debian - strato Rootserver - lilo bootproblem

Post by fraglor »

also ich bekomme die bei mir nicht zum laufen

meine files
lilo

Code: Select all

boot=/dev/hda
root=/dev/hda3
install=/boot/boot-menu.b
lba32
serial=0,57600n8
image=/vmlinuz
initrd=/initrd.img
label=debian
read-only
append="console=tty0 console=ttyS0,57600"
inittab

Code: Select all

# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:2:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let this work."

# What to do when the power fails/returns.
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
#  <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window System,
# so if you want to add more getty's go ahead but skip tty7 if you run X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS3
S0:12345:respawn:/sbin/getty -L 57600 ttyS0 vt102

squize
Userprojekt
Userprojekt
Posts: 729
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Debian - strato Rootserver - lilo bootproblem

Post by squize »

Hast du schon mal geschaut, wie es im rescuesystem aussieht, da sollte es ja gehen.

Gruss

Marc

fraglor
Posts: 4
Joined: 2004-02-09 22:41

Re: Debian - strato Rootserver - lilo bootproblem

Post by fraglor »

ah ok,
werde ich morgen machen... hätte mir auch einfallen können. ;)