Spamassissin Fehler

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
ego
Posts: 87
Joined: 2003-07-21 10:18

Spamassissin Fehler

Post by ego » 2003-11-13 16:48

Ich habe Spamassissin im Yast installiert und SPAMD im Runlevel-Editor eingetragen und gestartet.
In /var/log/mail.log wird mir gesagt, das kein Transport zu Spamassassin durchgeführt werden konnte.

"...postfix/qmgr[508]: warning: connect to transport spamassissin: No such file or directory"

Was kann ich tun, um diesen Fehler abzuschalten?

ego
Posts: 87
Joined: 2003-07-21 10:18

Re: Spamassissin Fehler

Post by ego » 2003-11-15 21:01

Keiner eine Idee? Das wundert mich aber sehr :(

chris76
Moderator
Moderator
Posts: 2015
Joined: 2003-06-27 14:37
Location: Germering

Re: Spamassissin Fehler

Post by chris76 » 2003-11-16 13:35

Wie hast du den Trabsport zu SA denn Konfiguriert?

Gruß Christian

ego
Posts: 87
Joined: 2003-07-21 10:18

Re: Spamassissin Fehler

Post by ego » 2003-11-16 14:06

Gar nicht, weil ich nicht mal weiß ob man dies unbedingt muß.
Das einzigste was ich gemacht habe war die /etc/procmail anzulegen
und darin steht:

Code: Select all

:0fw
| /usr/bin/spamassassin -P
Spamassassion filtert zwar die Mails, aber die Meldung möchte ich aus der Mail.log weg haben, da diese Meldung jede Minute hineingeschrieben wird und somit das Logfile zumüllt.

ego
Posts: 87
Joined: 2003-07-21 10:18

Re: Spamassissin Fehler

Post by ego » 2003-11-24 16:22

Auflösung des Rätsels:

Nachdem ich mich mit dem Buchautor des Postfixbuches in Verbindung gesetzt habe, hat sich alles nach kurzer Zeit aufgeklärt.

Der Fehler bestand darin, daß noch eine Mail im MailQueue festhing und somit von SA nicht verarbeitet werden konnte.

Ich ließ es mir also mit "mailq" anzeigen und siehe da, eine Mail hing seit 2 Monaten im Queue fest.
Mit "postsuper -r ALL" wurden die Queues neuaufgebaut und mit einem Restart von "spamd" und Postfix war die Meldung weg.

So einfach kann mailen sein :D