qpopper will nicht...

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
bluelupo
Posts: 9
Joined: 2003-10-09 12:07
Location: ...nahe der bayerischen Alpen

qpopper will nicht...

Post by bluelupo » 2003-11-02 19:06

Hallo zusammen,

ich bekomme beim Abholen von Emails (kmail) vom Server folgende Fehlermeldung in /var/log/mail:

Nov 2 18:59:40 pXXXXXXX qpopper[4823]: apop "web1p2" [pop_apop.c:214]
Nov 2 18:59:40 pXXXXXXX qpopper[4823]: web1p2 at 127.0.0.1 (127.0.0.1): -ERR [SYS/TEMP] POP authentication DB not available (user web1p2): No such file or directory (2) [pop_apop.c:249]

Versand klappt, ist auch postfix Sache :-)
Wo kann ich die "authentication DB" starten bzw. konfigurieren. Am besten via Commandline und nicht unter Confixx.

Die manpages zu popper geben dazu leider keinen Hinweis. Hat jemand von euch einen Tip wo ich suchen muss um den Fehler einzukreisen.

Ciao
bluelupo

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: qpopper will nicht...

Post by lufthansen » 2003-11-02 19:42


bluelupo
Posts: 9
Joined: 2003-10-09 12:07
Location: ...nahe der bayerischen Alpen

Re: qpopper will nicht...

Post by bluelupo » 2003-11-02 20:10

LuftHansen wrote:http://lists.hostsharing.net/archiv/sup ... 02797.html

hilft dir das weiter ?
...nein leider nicht. Es ist egal pb ich pop3 (Port 110) oder pop3s (Port 995) verwende. Die Fehlermeldungen sind ähnlich.

Hier pop3 (keine Verschlüsselung, Anmeldemethode "einfacher Text" in kmail)

Nov 2 20:06:02 pXXXXXXX popper[5426]: web1p2 at pD9E8CBA7.dip0.t-ipconnect.de (217.xxx.xxx.xxx): -ERR [AUTH] Password supplied for "web1p2" is incorrect. [pop_pass.c:479]
Nov 2 20:06:02 pXXXXXXX popper[5426]: [AUTH] Failed attempted login to web1p2 from host (pD9E8CBA7.dip0.t-ipconnect.de) 217.xxx.xxx.xxx [pop_pass.c:1379]

Hast du eine Ahnung wo das Configfile von qpopper ist ?

Ciao
bluelupo

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: qpopper will nicht...

Post by lufthansen » 2003-11-02 20:17

loggt der nicht mit in mail.log rein wenn nicht müsste er in syslog mit rein schriben ..

bluelupo
Posts: 9
Joined: 2003-10-09 12:07
Location: ...nahe der bayerischen Alpen

Re: qpopper will nicht...

Post by bluelupo » 2003-11-02 20:38

LuftHansen wrote:loggt der nicht mit in mail.log rein wenn nicht müsste er in syslog mit rein schriben ..
Hallo,

das steht in /var/log/messages drin:

Nov 2 20:24:22 pXXXXXXX stunnel[5587]: Using 'qpopper' as tcpwrapper service name
Nov 2 20:24:22 p15139717 stunnel[5587]: stunnel 3.14 on i586-suse-linux PTHREAD
Nov 2 20:24:22 pXXXXXXXX stunnel[5587]: qpopper connected from 217.xxx.xxx.xxx:38903
Nov 2 20:24:22 pXXXXXXXX stunnel[5587]: Connection closed: 212 bytes sent to SSL, 46 bytes sent to socket

Schaut eigentlich nicht schlecht aus :-)

Aber qpopper scheint ja eine Authentication-DB zu haben wo die User und Paswörter definiert sind. Oder irre ich mich da ??

Nov 2 20:24:22 pXXXXXXX qpopper[5588]: apop "web1p2" [pop_apop.c:214]
Nov 2 20:24:22 pXXXXXXX qpopper[5588]: web1p2 at 127.0.0.1 (127.0.0.1): -ERR [SYS/TEMP] POP authentication DB not available (user web1p2): No such file or directory (2) [pop_apop.c:249]

Bin etwas ratlos ?

Ciao
bluelupo

arachon
Posts: 44
Joined: 2003-03-26 19:22

Re: qpopper will nicht...

Post by arachon » 2003-11-03 12:11

Hallo,

für APOP (und das scheint im Mail Client (Eudora ?!?) eingestellt zu sein) benötigst Du eine weitere Datenbank, die z.B. Confixx nicht automatisch erstellt. Wenn Du die Authentifizierung in Deinem EMail-Programm auf PLAIN umstellst, sollte es funktionieren.

Wenn Du weiterhin APOP verwenden willst, hilft vielleicht dieser Link weiter: http://www.freebsddiary.org/apop.php

-> oder: man popauth



Grüsse
Christoph

bluelupo
Posts: 9
Joined: 2003-10-09 12:07
Location: ...nahe der bayerischen Alpen

Re: qpopper will nicht...

Post by bluelupo » 2003-11-03 19:47

Arachon wrote:Hallo,

für APOP (und das scheint im Mail Client (Eudora ?!?) eingestellt zu sein) benötigst Du eine weitere Datenbank, die z.B. Confixx nicht automatisch erstellt. Wenn Du die Authentifizierung in Deinem EMail-Programm auf PLAIN umstellst, sollte es funktionieren.

Wenn Du weiterhin APOP verwenden willst, hilft vielleicht dieser Link weiter: http://www.freebsddiary.org/apop.php

-> oder: man popauth



Grüsse
Christoph
Hallo Cristoph,

ich bin mittlerweile auch fündig geworden qpopper war's. Es war kein APOP-User angelegt.

popauth -user <username> <passwort>

war des Rätsels Lösung. Mich hatte nur die Meldung in /var/log/mail irgendwie verunsichert obwohl sie im nachhinein gesehen völlig richtig ist. Du hast aber auch in die richtige Ecke "gezielt" mit deinen Hinweis.

Irgendwie habe ich die manpage wohl nicht so richtig interpretiert ;-)

Ciao
bluelupo

lufthansen
Posts: 390
Joined: 2002-09-24 17:31
Location: NRW

Re: qpopper will nicht...

Post by lufthansen » 2003-11-03 19:52

ätsch also hatte ich doch recht :p