Probleme beim Versand von HTML Mails

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
edufl13
Posts: 7
Joined: 2003-10-13 10:31

Probleme beim Versand von HTML Mails

Post by edufl13 » 2003-10-16 19:09

Hi Leute,

Ich hab ein kleines Problem und weiß nicht wie ichs beheben soll....

Also Ich nutze ein Newsletter Script, das mit Hilfe der PHP-Mail Funktion HTML Mails verschickt. Dabei habe ich das Problem, dass die Mails auf manchen Systemen irgendwie zerhackt ankommen...Probleme gibt es zum Beispiel bei Outlook 2000....Hier ein kleiner Auszug:
Content-Type: MULTIPART/ALTERNATIVE; BOUNDARY="00-=m1.de-0012368" X-Mailer: m1.newsletter PHP/4.3.1 X-Sender-IP: 123.456.789.000 Message-Id: <20031016095559.359141EB171@mail.kundenserver.org>
Date: Thu, 16 Oct 2003 11:55:59 +0200 (CEST)

--00-=m1.de-0012368
Content-Type: text/plain; charset="ISO-8859-1"
Content-Transfer-Encoding: 7BIT
Nach diesem Abschnitt folgt direkt der Text des Newsletters ohne HTML Formatierungen.
Netscape/Mozilla empfängt die Mails aber anstandslos, genauso wie die webmail oberfläche von web.de!
Die Obefläche von gmx und Outlook 2000 zeigen die Nachrichten aber zerhackt an!

Wo könnte der Fehler liegen?
PHP Config? Postfix oder sendmail config?

hier der link zu phpinfo: http://81.2.185.120/phpinfo.php

Benötigt Ihr noch weitere Infos?

Ein Tip wäre sehr nett, da Ich echt ratlos bin!

Vielen Dank schonmal

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Probleme beim Versand von HTML Mails

Post by captaincrunch » 2003-10-16 19:53

Wo könnte der Fehler liegen?
An einem besch... MUA ? ;)

Mal ernsthaft : HTML-Mails sind ohnehin bäh, und Outlook zerstückelt sogar Nur-TExt-Mails.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

edufl13
Posts: 7
Joined: 2003-10-13 10:31

Re: Probleme beim Versand von HTML Mails

Post by edufl13 » 2003-10-16 20:15

naja es sollte halt schon funktionieren.......

in der demo auf nem anderen server hat das ding funktioniert.....


für die einen ists halt hui, für die anderen Pfui ist mir schon klar...

keine konstruktive Idee?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11578
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Probleme beim Versand von HTML Mails

Post by Joe User » 2003-10-17 00:52

mach' erstmal die Zeilenumbrüche RFC-konform, danach kann man Dir besser helfen...