qmail-toaster versendet keine mails

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
gw丨breaki
Posts: 6
Joined: 2002-08-05 10:57

qmail-toaster versendet keine mails

Post by gw丨breaki » 2003-10-14 14:56

alos ich hab den qmail toaster genauso wie in der faq beschrieben installiert, doch er versendet irgendwie keine mails. die mails die er versenden sollte liegen dann einfach in /var/qmail/queue/mess/ in einem der verzeichnisse und werden nicht zugestellt.

alles ander tut soweit laufen

Code: Select all

p1234567:/var/qmail/queue # /etc/rc.d/init.d/qmail stat
/etc/service/qmail-send: up (pid 2184) 0 seconds
/etc/service/qmail-send/log: up (pid 13673) 50007 seconds
/etc/service/qmail-smtpd: up (pid 2185) 0 seconds
/etc/service/qmail-smtpd/log: up (pid 13679) 50007 seconds
messages in queue: 4
messages in queue but not yet preprocessed: 4
und hier noch von vpopmail

Code: Select all

p1234567:/var/qmail/queue # /etc/rc.d/init.d/vpopmail stat      
/etc/service/qmail-pop3d: up (pid 2848) 0 seconds
/etc/service/qmail-pop3d/log: up (pid 13773) 50065 seconds
/etc/service/qmail-pop3ds: up (pid 2849) 0 seconds
/etc/service/qmail-pop3ds/log: up (pid 13779) 50065 seconds
liegt es vielleicht daran, das qmail-send nur seit 0 sec ausgeführt wird? wenn man schnell ist erscheint dort, wo die 0 ist auch ab und zu mal eine 1. aber wie schon gesagt, nur ab und zu...

ich hoffe hier kann mir jemand weiter helfen

danke schonmal im vorraus

ps -aux ergibt folgendes

Code: Select all

root     31804  0.0  0.3  2244  916 ?        S    Oct11   0:00 /bin/sh /usr/sbin/svscanboot
root     31806  0.0  0.1  1280  288 ?        S    Oct11   0:14 svscan /etc/service
root     31807  0.0  0.0  1240  204 ?        S    Oct11   4:02 readproctitle service errors: ...tlimit: usage: softlimit [-a allbytes] [-c corebytes] [-d databy
root      6853  0.0  0.1  1244  260 ?        S    Oct11   0:00 supervise log
root      6861  0.0  0.1  1244  260 ?        S    Oct11   2:58 supervise qmail-smtpd
root      6862  0.0  0.1  1244  260 ?        S    Oct11   0:00 supervise log
root      6915  0.0  0.1  1244  260 ?        S    Oct11   3:18 supervise qmail-pop3d
root      6916  0.0  0.1  1244  260 ?        S    Oct11   0:00 supervise log
root      6979  0.0  0.1  1244  260 ?        S    Oct11   2:57 supervise qmail-pop3ds
root      6980  0.0  0.1  1244  260 ?        S    Oct11   0:00 supervise log

qmaill   13673  0.0  0.1  1260  284 ?        S    00:59   0:07 multilog t s10000000 /var/log/qmail/send
qmaill   13679  0.0  0.1  1260  280 ?        S    00:59   0:00 multilog t s10000000 /var/log/qmail/smtpd
vpopmail 13732  0.0  4.8 13296 11948 ?       S    00:59   0:00 /usr/local/bin/spamd -d -v -u vpopmail
qmaill   13773  0.0  0.1  1260  280 ?        S    00:59   0:00 multilog t s10000000 /var/log/qmail/pop3d
qmaill   13779  0.0  0.1  1260  280 ?        S    00:59   0:00 multilog t s10000000 /var/log/qmail/pop3ds
root     16627  0.0  0.1  1244  280 ?        S    01:04   0:33 supervise qmail-send
root      4513  1.0  0.0     0    0 ?        Z    14:57   0:00 [supervise <defunct>]
root      4514  1.0  0.0     0    0 ?        Z    14:57   0:00 [softlimit <defunct>]
root      4517  2.0  0.0     0    0 ?        Z    14:57   0:00 [env <defunct>]
root      4518  1.0  0.0     0    0 ?        Z    14:57   0:00 [softlimit <defunct>]

gw丨breaki
Posts: 6
Joined: 2002-08-05 10:57

Re: qmail-toaster versendet keine mails

Post by gw丨breaki » 2003-10-14 18:26

also was ich bis jetzt gemerkt hab, is das mit netstat -a kein smtp oder pop port offen ist...

der tcpserver läuft auch irgendwie nicht, weil er da 'n problem mit dem softlimit meldet...

kenzo
RSAC
Posts: 530
Joined: 2003-07-15 20:30

Re: qmail-toaster versendet keine mails

Post by kenzo » 2003-10-14 19:31

/etc/service/qmail-send: up (pid 2184) 0 seconds
/etc/service/qmail-smtpd: up (pid 2185) 0 seconds
0/1 bedeutet, dass der Service nicht läuft. Wir brauchen mehr Info:

less +F /var/log/qmail/current
less +F /var/log/qmail/smtpd/current
less +F /var/log/qmail/pop3d/current

cat /service/qmail-smtpd/run
cat /service/qmail-send/run
cat /service/qmail-pop3d/run

scythe42
RSAC
Posts: 154
Joined: 2002-10-14 18:30
Location: Internet

Re: qmail-toaster versendet keine mails

Post by scythe42 » 2003-10-14 20:19

Fehler in den supervise scripts bei dir, deswegen laufen die qmail dienste nicht alle. siehst du an dem "defunct supervise"
Ich rate mal: Leerzeichen hinter den zeilenverbindenden Backslashes?