Nach Upgrade von Postfix (FAQ) Probleme beim Mailversand ...

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
adagio
Posts: 96
Joined: 2003-09-22 12:51

Nach Upgrade von Postfix (FAQ) Probleme beim Mailversand ...

Post by adagio » 2003-10-07 03:32

Hi,

ich habe Postfix erfolgreich aktualisiert mit Hilfe Eurer FAQ:
http://www.rootforum.org/faq/index.php ... 41&lang=de

Allerdings habe ich jetzt das Problem, das ich Emails zwar empfangen kann, aber keine Senden. Ich erhalte diese Fehlermeldung (erscheint auch in den logs):

Oct 7 03:25:30 p15131386 postfix/smtpd[11965]: 10B151180AB: reject:
RCPT from dsl-213-023-140-046.arcor-ip.net[213.23.140.46]: 504
<devshack-r4il80>: Helo command rejected: need fully-qualified hostname;
from=<adagio@adagio2.de> to=<bkabak@adagio2.de> proto=ESMTP helo=<devshack-r4il80>

Uhm, was passt ihm denn jetzt nicht? Oder muss ich einige der Regeln "lockern"?

Ich hab dies eingetragen:
smtpd_recipient_restrictions = permit_sasl_authenticated,
permit_mynetworks,
reject_non_fqdn_sender,
reject_non_fqdn_recipient,
reject_non_fqdn_hostname,
reject_unknown_recipient_domain,
reject_invalid_hostname,
reject_unknown_hostname,
reject_unknown_sender_domain,
reject_rbl_client,
permit_mx_backup,
reject_unauth_destination
Oder hat das damit nichts zu tun?

adagio
Posts: 96
Joined: 2003-09-22 12:51

Re: Nach Upgrade von Postfix (FAQ) Probleme beim Mailversand ...

Post by adagio » 2003-10-07 03:45

Ok, ich hab jetzt eine Kleinigekeit herausgefunden - er scheint den Hostnamen adagio2.de nicht zu mögen!

Schicke ich Emails an eine andere Adresse (z.B. ich@devshack.biz oder adagio@gmx.net), geht alles ohne Probleme. Schicke ich eine Email an blabla@adagio2.de, gibt es den oben genannten Fehler.

Woran liegt es, dass er adagio2.de nicht mag? Das ist doch eine 100% korrekte Domain?

adagio
Posts: 96
Joined: 2003-09-22 12:51

Re: Nach Upgrade von Postfix (FAQ) Probleme beim Mailversand ...

Post by adagio » 2003-10-07 15:15

Ich weiss zwar nicht warum, aber jetzt geht alles ganz normal ...

KriS
Posts: 37
Joined: 2003-03-14 14:39

Re: Nach Upgrade von Postfix (FAQ) Probleme beim Mailversand ...

Post by KriS » 2003-10-15 12:09

Hi,

ich habe auch ein Update gemacht genau nach dem gleichem HowTo,..
allerdings ohne AVGuard...
Nun kann ich mails empfangen, aber keine mehr versenden :(
Fehlermeldung:
Die Nachricht konnte nicht gesendet werden, da einer der Empfänger vom Server nicht akzeptiert wurde. Die nicht akzeptierte E-Mail-Adresse ist "thomas@kniselies.de". Betreff 'huhu test', Konto: 'kwm-web.info', Server: 'kwm-web.info', Protokoll: SMTP, Serverantwort: '404 <w4>: Helo command rejected: need fully-qualified hostname', Port: 25, Secure (SSL): Nein, Serverfehler: 404, Fehlernummer: 0x800CCC79
Die Domain liegt sogar auf dem gleichen Server.. :-/
Was läuft da falsch?
Was brauch ihr noch an Info?

So long
KriS

P.S: Was muss in der main.cf von Postfix eigentlich jetzt als "myhostname" eingetragen werden? Habe es schon versucht mit:
pxxxxx.pureserver.info mit pxxxxx.kwm-web.info

Hilfe? *g*