Fehler bei ausführung

Bash, Shell, PHP, Python, Perl, CGI
ccb100
Posts: 32
Joined: 2002-04-23 18:10

Fehler bei ausführung

Post by ccb100 »

Ich habe ein script laufemn das in eine Html Seite etwas einfügt.
Ich bekomme plötzlich den Fehler:
Warning: Cannot add header information - headers already sent by (output started at /home/www/web4/html/board/ltoh_page.php:1) in /home/www/web4/html/board/acp/lib/functions.php on line 72


Finde an besagtem Ort aber nichts auffälliges. Evtl. hat ja jemand einen Hinweis.

Gruss,

ccb
darkspirit
Posts: 553
Joined: 2002-10-05 16:39
Location: D'dorf

Re: Fehler bei ausführung

Post by darkspirit »

PHP meckert, dass du den Header verändern willst, aber bereits Text ausgegeben hast. Hast du irgendwelche Zeichen vor dem <?php Tag? Wenn ja, lösch die raus..
ccb100
Posts: 32
Joined: 2002-04-23 18:10

Re: Fehler bei ausführung

Post by ccb100 »

Hallo,

kein Zeichen davor. Das ist es ja. Ich such mir noch einen Wolf.
Die Datei lief ja vor dem Umzug ohne Probleme.

Gruss,

ccb
darkspirit
Posts: 553
Joined: 2002-10-05 16:39
Location: D'dorf

Re: Fehler bei ausführung

Post by darkspirit »

"Zeichen" heißt hier auch Spaces etc.
Es gibt ASCII-Zeichen, die nicht darstellbar sind ;)
hossa
Posts: 7
Joined: 2003-09-30 09:05

Re: Fehler bei ausführung

Post by hossa »

poste doch mal den relevanten teil des scripts. "lib/functions.php" lässt ja darauf schließen, dass davor schon etwas passiert. evtl. wird schon zuvor etwas ausgegeben und die zeile in functions.php haut irgendwas raus, was dann probleme mit dem doppelten header macht.