meldung bei backupscript

Bash, Shell, PHP, Python, Perl, CGI
chris76
Posts: 1878
Joined: 2003-06-27 14:37
Location: Germering

meldung bei backupscript

Post by chris76 »

Tach, ich habe mir ein scripte geschrieben welches mir einzelne Verzeichnis per tar wegsichert.
Manuell aufgerufen klappt alles einwandfrei. Mit dem cron aufgerufen kommt folgende Meldung

Code: Select all

tar: Removing leading `/' from member names
tar: /var/lib/mysql/mysql.sock: socket ignored
der cron läuft als root .

Danke schon mal für tipps woran das liegen könnte.

Ciao Christian
jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: meldung bei backupscript

Post by jtb »

kein Problem..
Ignoriere die Meldungen!
chris76
Posts: 1878
Joined: 2003-06-27 14:37
Location: Germering

Re: meldung bei backupscript

Post by chris76 »

Gut das mag kein problem sein das zu ignorieren, aber mich nervt es jeden morgen ne mail vom Cron deswegen zu bekommen!

Ciao Christian
stefanpropehan
Posts: 335
Joined: 2002-12-17 22:25
Location: Berlin

Re: meldung bei backupscript

Post by stefanpropehan »

chris76 wrote: tar: Removing leading `/' from member names
du must in deinem Script die letzten / entfernen... sonst macht das tar für dich und die meldung entsteht...
chris76 wrote: tar: /var/lib/mysql/mysql.sock: socket ignored
socket files must du ausschliessen - es gibt einen parameter bei tar um bestimmte dateien nicht mit zu packen... weiß ihn aber im moment nicht aus dem Kopf.... schaue mal in der manpage
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: meldung bei backupscript

Post by captaincrunch »

du must in deinem Script die letzten / entfernen... sonst macht das tar für dich und die meldung entsteht...
Nicht wirklich. Die Meldung sagt klipp und klar, dass es um den "leading", also folglich den Slash ganz vorne geht. ;)
es gibt einen parameter bei tar um bestimmte dateien nicht mit zu packen... weiß ihn aber im moment nicht aus dem Kopf...
--exclude
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
stefanpropehan
Posts: 335
Joined: 2002-12-17 22:25
Location: Berlin

Re: meldung bei backupscript

Post by stefanpropehan »

CaptainCrunch wrote:Nicht wirklich. Die Meldung sagt klipp und klar, dass es um den "leading", also folglich den Slash ganz vorne geht. ;)
mhh da habe ich mich wohl nicht ganz verständlich ausgedrückt... :oops:

also leading ist meiner meinung nach Inseldeutsch und heißt soviel wie führend...

also jetzt nochmal

bei /var/www/

muss der letzte (führende) slash weg
also

/var/www


oder????????
jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: meldung bei backupscript

Post by jtb »

nein, leading slashes führen dazu, dass beim Entpacken dein System gefährdet ist.. Tar schützt dich davor, so dass du auch in ein anderes Verzeichnis entpacken kannst.
stefanpropehan
Posts: 335
Joined: 2002-12-17 22:25
Location: Berlin

Re: meldung bei backupscript

Post by stefanpropehan »

alles klar - kleiner denkfehler bei mir... aber najanu habs probiert und ist ja auch schon spät.... :cry: