popper -> "invalid option --" nach Update tcpd

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
niemo
Posts: 5
Joined: 2002-06-10 10:39

popper -> "invalid option --" nach Update tcpd

Post by niemo » 2003-09-27 22:35

Hallo !

Ich habe heute wg. der Verzögerung beim eMails abholen probiert, gemäß FAQ den tcp wrapper zu installieren und hab mir dabei wohl den popper beschädigt. Mittlerweile laufen zumindest sendmail und ftp wieder, ftp habe ich jetzt als daemon laufen, nicht mehr über inetd. Ich habe wirklich alles ausprobiert, ein Backup der "tcpd" sowie das Neuinstallieren über rpm aber ich denke, es liegt jetzt an etwas anderem.

Diese Infos habe ich jetzt zusammengestellt:


/var/log/messages: (Service läuft, auch gemäß netstat auf Port 110)
Sep 27 22:11:33 www popper[838]: connect from 62.220.xx.yy (62.220.xx.yy)

telnet <server>.de 110: (Das ist die Fehlermeldung beim POP3-Connect)
popper: invalid option --Usage: popper [-b bulldir] [-c] [-d] [-e login_delay=nn,expire=nn] [-f config-fi
le] [-L lock refresh] [-p 0-3][-R] [-s] [-S] [-t trace-file] [-T timeout]
Verbindung zu Host verloren.

/var/log/warn: (Hat nichts damit zu tun, aber ihr wollt ja immer alles sehen :-) )
Sep 28 00:05:50 www /usr/sbin/named[317]: the default for the 'auth-nxdomain' option is now 'no'


Also dieses "popper: invalid option --" gabs schon einmal hier im Forum, aber da hat sich das Problem von selbst gelöst.

Was kann ich noch tun um dem hier auf die Schliche zu kommen und wieder per Pop an meine Mails zu kommen ?

Thx im Vorraus !
Last edited by niemo on 2003-09-27 22:43, edited 1 time in total.

niemo
Posts: 5
Joined: 2002-06-10 10:39

Neue Fehlermeldung

Post by niemo » 2003-09-27 22:41

In /var/log/mail habe ich eben noch eine neue Fehlermeldung gefunden:

Sep 27 22:25:19 www popper[1652]: Unable to obtain socket and address of client: Socket operation on non-socket (88) [pop_init.c:774]

Vielleicht hilft das weiter.

niemo
Posts: 5
Joined: 2002-06-10 10:39

Re: popper -> "invalid option --" nach Update tcpd

Post by niemo » 2003-09-28 13:04

Okay, sorry. Das Problem hat sich gerade nach einem dos2unix convert der /etc/inetd.conf erledigt ;)