ClamAV installieren auf 1&1 Rootserver

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
plumps22
Posts: 48
Joined: 2003-06-12 21:39

ClamAV installieren auf 1&1 Rootserver

Post by plumps22 » 2003-09-17 12:12

ich benötige eure hilfe. ich habe 1&1 Rootserver mit Postfix. Spamassassin habe ich bereits erfolgreich installiert. Nun möchte ich zum Virenscanner ClamAV installieren, die installation habe ich nach Anleitung gemacht, alles lief ohne Fehler, aber die Mails werden nicht gescannt. Muss ich beim Postfix in der main.cf auch etwas eintragen ?? Hat jemand einen Tip ?

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: ClamAV installieren auf 1&1 Rootserver

Post by dodolin » 2003-09-17 12:37

Kurze Googel-Suche lieferte z.b. http://kolab.kroupware.org/howtos/amavi ... n_clam.pdf

Ich nehme an, man muss das auch dem Postfix oder zumindest dem Amavis sagen, falls du den hast. Aber ich bin kein Postfix-Experte.

plumps22
Posts: 48
Joined: 2003-06-12 21:39

Re: ClamAV installieren auf 1&1 Rootserver

Post by plumps22 » 2003-09-20 20:41

jetzt in ich schonmal einen schritt weiter. allerding funktioniert es noch nicht. siehe auszug vom log

Code: Select all

Sep 20 20:33:39 meinserver postfix/smtpd[21591]: connect from pop.gmx.de[213.165.64.20]
Sep 20 20:33:39 meinserver postfix/smtpd[21591]: CE37034C037: client=pop.gmx.de[213.165.64.20]
Sep 20 20:33:39 meinserver postfix/cleanup[21592]: CE37034C037: message-id=<006801c37fa5$d1b690c0$2400a8c0@laptop>
Sep 20 20:33:39 meinserver postfix/qmgr[21426]: CE37034C037: from=<schreibmirmal@gmx.de>, size=1544, nrcpt=1 (queue active)
Sep 20 20:33:39 meinserver postfix/smtpd[21591]: disconnect from pop.gmx.de[213.165.64.20]
Sep 20 20:33:40 meinserver spamd[12250]: connection from localhost.localdomain [127.0.0.1] at port 35134 
Sep 20 20:33:40 meinserver spamd[21598]: info: setuid to filter succeeded 
Sep 20 20:33:40 meinserver spamd[21598]: processing message <006801c37fa5$d1b690c0$2400a8c0@laptop> for filter:501. 
Sep 20 20:33:40 meinserver spamd[21598]: clean message (0.6/5.0) for filter:501 in 0.1 seconds, 1498 bytes. 
Sep 20 20:33:40 meinserver postfix/pickup[21425]: 6C59734C038: uid=501 from=<schreibmirmal@gmx.de>
Sep 20 20:33:40 meinserver postfix/cleanup[21592]: 6C59734C038: message-id=<006801c37fa5$d1b690c0$2400a8c0@laptop>
Sep 20 20:33:40 meinserver postfix/qmgr[21426]: 6C59734C038: from=<schreibmirmal@gmx.de>, size=1832, nrcpt=1 (queue active)
Sep 20 20:33:40 meinserver postfix/pipe[21594]: CE37034C037: to=<web1p1@meinserver.de>, relay=filter, delay=1, status=sent (dummy)
Sep 20 20:33:40 meinserver amavisd[21604]: starting.  amavis 0.3.12 Fri Sep 19 21:51:16 CEST 2003
Sep 20 20:33:41 meinserver amavisd[21604]: Virus scanner failure: Clamd - can't connect to daemon
Sep 20 20:33:41 meinserver postfix/smtpd[21608]: connect from localhost.localdomain[127.0.0.1]
Sep 20 20:33:41 meinserver postfix/smtpd[21608]: 40F8C34C037: client=localhost.localdomain[127.0.0.1]
Sep 20 20:33:41 meinserver postfix/smtpd[21608]: reject: RCPT from localhost.localdomain[127.0.0.1]: 550 <web1p1@meinserver.de>: User unknown; from=<schreibmirmal@gmx.de> to=<web1p1@meinserver.de>
Sep 20 20:33:46 meinserver postfix/smtpd[21608]: disconnect from localhost.localdomain[127.0.0.1]
Sep 20 20:33:46 meinserver amavisd[21604]: Rejected by MTA: 550 <web1p1@meinserver.de>: User unknown 
Sep 20 20:33:46 meinserver amavisd[21604]: do_exit:593 - ending execution with 1
Sep 20 20:33:46 meinserver postfix/pipe[21602]: 6C59734C038: to=<web1p1@meinserver.de>, relay=amavis, delay=6, status=bounced (Command died with status 1: "/usr/sbin/amavis")
Sep 20 20:33:46 meinserver postfix/cleanup[21592]: 5E6DC34C037: message-id=<20030920183346.5E6DC34C037@meinserver.de>
Sep 20 20:33:46 meinserver postfix/qmgr[21426]: 5E6DC34C037: from=<>, size=3415, nrcpt=1 (queue active)
Irgendwie kann er den Virenscanner nicht starten. Hat jemand einen Tip ??

plumps22
Posts: 48
Joined: 2003-06-12 21:39

Re: ClamAV installieren auf 1&1 Rootserver

Post by plumps22 » 2003-09-21 13:43

Ich finde den fehler einfach nicht, ständig bekomme ich folgende Fehlermeldung im logfile.

Code: Select all

amavisd[18836]: Virus scanner failure: Clamd - can't connect to daemon
Kann mir dabei jemand helfen, bin am verzweifeln ...

wirsing
RSAC
Posts: 611
Joined: 2002-11-20 21:32
Location: Vaihingen und Karlsruhe

Re: ClamAV installieren auf 1&1 Rootserver

Post by wirsing » 2003-09-22 17:37

Läuft ein Prozess namens clamd? Wenn nicht, wirst du sicher fündig, wie du ihn zu starten hast.

plumps22
Posts: 48
Joined: 2003-06-12 21:39

Re: ClamAV installieren auf 1&1 Rootserver

Post by plumps22 » 2003-09-22 20:40

clamd läuft 3x. Unter welchem besitzer muss clamd laufen ??