Sendmail nicht mehr aktivierbar - Hilfe!

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
toledow
Posts: 8
Joined: 2003-05-07 10:06

Sendmail nicht mehr aktivierbar - Hilfe!

Post by toledow » 2003-08-28 15:25

Hallo,
Bisher habe ich meinen Rootserver (Hetzner) mailtechnisch nur dazu verwendet, im Falle von Bestellugen über einen bei mir liege3nden shop und und php-mailinterfaces mails an Adressen zu verschicken, die nicht auf meinem Server liegen (sprich @gmx, @t-online usw).
Das lief über sendmail und funktionierte auch, bis ich über yast postfix installierte und damit sendmail rausschmiss. Ich habe es danach nicht hinbekommen, die Funktion wieder herzustellen ud daraufhin wieder sendmail installiert, das nun aber auch nicht mehr zum Versenden zu bewegen ist.
Das schlimme dabei ist, das ich gerade für einen Kunden einen shop eingerichtet hatte und bei dem nun die Kunden am Telefon hängen, und fragen, warum sie keine Antwort auf ihre Bestellugen bekommen :(

Deshalb dieser Hiferuf.

Folgendes stet in der mail-Datei:
Aug 28 14:47:54 linux sendmail[13922]: h7SClsPx013922: from=<wwwrun@linux.local>, size=1172, class=0, nrcpts=0, proto=ESMTP, daemon=Daemon0, relay=localhost [127.0.0.1]
Aug 28 14:47:54 linux sendmail[13924]: h7SClseu013924: from=wwwrun, size=1097, class=0, nrcpts=1, msgid=<200308281247.h7SClseu013924@linux.local>, relay=wwwrun@localhost
Aug 28 14:47:55 linux sendmail[13925]: h7SClsPx013925: Milter: from=<wwwrun@linux.local>, reject=451 4.7.1 Please try again later
Aug 28 14:47:55 linux sendmail[13924]: h7SClseu013924: to=ffddf@ghg.de, ctladdr=wwwrun (30/65534), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30141, relay=localhost.local. [127.0.0.1], dsn=4.0.0, stat=Deferred: 451 4.7.1 Please try again later
Aug 28 14:47:55 linux sendmail[13925]: h7SClsPx013925: from=<wwwrun@linux.local>, size=1097, class=0, nrcpts=0, proto=ESMTP, daemon=Daemon0, relay=localhost [127.0.0.1]

Vielen DAnk für jeden Hinweis im Vorraus !!!

Grüße,
Thorsten

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Sendmail nicht mehr aktivierbar - Hilfe!

Post by squize » 2003-08-28 19:21

Du solltest mit yast auch die Config von sendmail richtig einrichten, damit es geht.
So wie es aussieht stimmen die hostname nicht.

Gruss

Marc

toledow
Posts: 8
Joined: 2003-05-07 10:06

Re: Sendmail nicht mehr aktivierbar - Hilfe!

Post by toledow » 2003-08-29 00:22

Vielen Dank schon mal!
Probleme sind leider immer noch da. Ich habe jetzt sendmail deinstalliert und postfix installiert. Da habe ich dann versucht die Sache mit den Hostnamen einzurichten.
Das Problem ist nun, das wenn ich postfix über webmin bzw. yast starte, es zwar als gestartet angezeigt wird, jedoch bei einem Refresh folgendes ausgibt:
-------------------------------------------------------------------------------------

/etc/init.d/postfix status returned 1 (Program is dead and &#9474;&#9474; File Systems (NFS) &#9474; &#9474;
&#9474;&#9474; &#9474;&#9474;/var/run pid file exists.) &#9474;&#9474; he Daemon &#9474; &#9474;
&#9474;&#9474; &#9474;&#9474;Checking for service Postfix: ..dead

---------------------------------------------------------------------------------
ich habe auch schon ein komplett unverändertes postfix installiert und einige andere Sachen hin und her probiert - es klappt einfach nicht.
Es geht mir jetzt einfach nur noch darum, mails über den/die shops an fremde Adressen zu verschicken, mehr will ich gar nicht mehr :cry:

Habe auch festgestellt, das die über php geschickten mails im maildrop-Ordner aufgefangen werden. Aber dort ist dann halt Schluss.

Hier moch mal ein aktueller mail-Log Auszug:
------------------------------------------------------------------------------------
Aug 28 22:42:43 linux sendmail-client[19900]: h7S9RJpv009744: to=stechow@foni.net, ctladdr=wwwrun (30/65534), delay=11:15:24, xdelay=00:00:00, mailer=relay, pri=2190161, relay=localhost.local., dsn=4.0.0, stat=Deferred: 451 4.7.1 Please try again later
Aug 28 22:42:43 linux sendmail[19901]: h7SKghQQ019901: from=<wwwrun@linux.local>, size=1410, class=0, nrcpts=0, proto=ESMTP, daemon=Daemon0, relay=localhost [127.0.0.1]
--------------------------------------------------------------------------------------
Was ist da bloß los :?

Grüße,
Thorsten

squize
Userprojekt
Userprojekt
Posts: 741
Joined: 2003-05-19 16:46
Location: Karlsruhe

Re: Sendmail nicht mehr aktivierbar - Hilfe!

Post by squize » 2003-08-30 15:57

Als erstes würde ich mal das pid file löschen und es dann nocheinmal probieren mit

/etc/init.d/postfix start

Gruss

Marc

toledow
Posts: 8
Joined: 2003-05-07 10:06

Re: Sendmail nicht mehr aktivierbar - Hilfe!

Post by toledow » 2003-09-02 13:25

yo - Danke hab es nun endlich hingebogen bekommen...

Gruß,
Thorsten