Courier-IMAP über Telnet -> nichts Toyota

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
krispin
Posts: 216
Joined: 2003-04-14 16:30

Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 01:19

Tag allerseits...

mal Vorab.... ich hasse ab nun Courier-Imap, so auf dieser Grundlage können wir weiter arbeiten! :)

Ich habe eigendlich an dem Courier-Imoep nicht viel konfiguriert.
Auth über authmysql. Home-Dir Statisch, da /var/mail, und einfach nur das Maildir dynamisch aus SQL-DB auslesen. Klappt auch soweit alles, man kann sich ein loggen, bzw..
JAIN..

wenn ich mich mit Telnet einlogge,
kann ich ein geben, wie ich will, und was ich will,
daher "nicht Toyota" -> "nichts is Möglich" anstatt "Nichts ist Unmöglich"

immer kommt sowas hier:

Code: Select all

LOGIN user passwd
LOGIN NO Error in IMAP command received by server.
dem entsprechend Verhalten sich dann auch die MUAs... alle haben Fehler... nichts geht...

Bei "Aussichten Schnell" legt er zwar Automatisch die gebrauchten Folder an, aber wenn man auf sie Zugreifen will, "Sever jat die Verbindung unerwartet unterbrochen"

Mozzi macht mozzi mit "Invalid Mailbox name"...

und das schlimme ist, ich habe 'root' keine Erklärung, warum...

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by dodolin » 2003-08-20 11:03

mal Vorab.... ich hasse ab nun Courier-Imap, so auf dieser Grundlage können wir weiter arbeiten!
mal Vorab... ich muss schon sagen, dass ich es für sehr vermessen halte, Software oder gar die Entwickler einer solchen für die eigene Unfähigkeit verantwortlich zu machen.

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 11:32

mal vorab....

kann es sein, dass du in letzter zeit nur noch irgendwas zu nörgeln hast,
aber nicht mal mehr fähig bist darauf dann auch irgendwie ne Problemlösung parat zu haben!?

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by dodolin » 2003-08-20 11:39

kann es sein, dass du in letzter zeit nur noch irgendwas zu nörgeln hast,
aber nicht mal mehr fähig bist darauf dann auch irgendwie ne Problemlösung parat zu haben!?
mal Vorab... kann es sein, dass das auch seinen Grund hat? Kann es sein, dass in letzter Zeit das Forum hier von solchen (leider nicht mehr) lustigen Vögeln wie dir heimgesucht wird?

Mein Vorschlag war schon korrekt und hat die Problemlösung enthalten:
dodolin wrote:für die eigene Unfähigkeit verantwortlich zu machen.
Eben.

Ich kann das aber auch näher ausführen (solange ich noch Lust dazu habe):

Code: Select all

LOGIN user passwd
LOGIN NO Error in IMAP command received by server. 
Das ist klar, dass das nicht funktioniert, du hälst dich ja nichtmal an die IMAP-Spezifikationen. Wäre ich ein IMAP-Server, würde ich mich auch weigern, mit nicht-konformen Clients zu reden...

Daher würde ich vorschlagen, du ziehst dir mal den RFC zu IMAP rein und lernst erstmal IMAP zu reden, wenn du schon unbedingt mit telnet rumspielen willst.

:evil:

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 11:49

http://www.faqs.org/rfcs/rfc2060.html


Syntax ist ganz unten zu finden!

nun sage mir, was an diesem Command Falsch ist! laut der RFC wäre ich als Mail-Server wohl schon bereit, zu "reden". Somal es ja schonmal geklapt hat.

---

Selbst wenn das des Rätsels Lösung ist, ist deine Antwort genau so arm wie

"Warum geht mein Server nicht mehr"? ohne Jegliche Angaben zu machen.
Wenn du keine lust mehr hast, mir zu helfen, dann lass es einfach.... lass aber auch deine schei*s Kommentare weg, das ist das wenigste, was ich Brauche....

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by captaincrunch » 2003-08-20 11:51

Du hättest besser alles, und eben nicht nur die Ã?berschriften lesen sollen. Ich zitiere mal Punkt 6.2.2 "Login" :
6.2.2. LOGIN Command

Arguments: user name
password

Responses: no specific responses for this command

Result: OK - login completed, now in authenticated state
NO - login failure: user name or password rejected
BAD - command unknown or arguments invalid

The LOGIN command identifies the client to the server and carries
the plaintext password authenticating this user.

Example: C: a001 LOGIN SMITH SESAME
S: a001 OK LOGIN completed
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 11:54

Das hilft mir nun auch nicht wirklich weiter....

Auch wenn ich als Antwort von dem "No Error in Command LOGIN.." erhalte bin ich nicht eingeloggt.

Als es mal geklappt hat, hieß es auch,
"Ok, Login completet"

MfG
Krispin

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by captaincrunch » 2003-08-20 11:56

Dann solltest du dir das Example, wie ein korrekter IMAP-Login auszusehen hat noch einmal ganz genau ansehen.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

dodolin
RSAC
Posts: 4009
Joined: 2003-01-21 01:59
Location: Sinsheim/Karlsruhe

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by dodolin » 2003-08-20 12:00

Dazu fällt mir jetzt nur noch eines ein: Hier mit dem Courier-IMAP und meinen telnet-Kommandos tut's. Aber wenn sogar Vorlesen nix hilft, was soll man da noch helfen können?

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 12:01

hmm,
bin ich jetzt blöd, oder was? (Ja, Dodolin, ich weiß...)

mit dem a001 hat es aber nich wirklich was auf sich, oder?
kommt genau der SElbe kram, wenn ja, was hat es zu bedeuten?

Krispin

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by captaincrunch » 2003-08-20 12:04

mit dem a001 hat es aber nich wirklich was auf sich, oder?
Dämmert's langsam ? RFCs sind im Normalfall sehr genau verfasst.
kommt genau der SElbe kram, wenn ja, was hat es zu bedeuten?
In dem Fall helfen wohl nur Logs statt dubioser Login-Versuche ...
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 12:07

Naja, daja Courier gut bekannt dafür ist, so wenig Logs zu machen ,wie möglich:

Code: Select all

Aug 20 11:59:39 krispin-dedicated imaplogin: Connection, ip=[::ffff:80.135.184.78]
Aug 20 12:01:04 krispin-dedicated courierpop3login: Connection, ip=[::ffff:80.135.184.78]
Aug 20 12:01:04 krispin-dedicated courierpop3login: LOGIN, user=karsten, ip=[::ffff:80.135.184.78]
Aug 20 12:01:04 krispin-dedicated courierpop3login: LOGOUT, user=karsten, ip=[::ffff:80.135.184.78], top=0, retr=0
Aug 20 12:03:30 krispin-dedicated imaplogin: Connection, ip=[::ffff:80.135.184.78]
über den courier-pop - daemon und gleichem Auth-Modul funzt es...

und mehr als "imaplogin: Connection "zu ip" kommt da nicht.
mal Vorab... ich muss schon sagen, dass ich es für sehr vermessen halte, Software oder gar die Entwickler einer solchen für die eigene Unfähigkeit verantwortlich zu machen.
dann kommt vielleicht meine Blödheit noch dazu... aber es liegrt nicht nur an mir, den Fehler nicht heraus zu finden...

alexander newald
Posts: 1117
Joined: 2002-09-27 00:54
Location: Hannover

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by alexander newald » 2003-08-20 13:10

Selber gebaut? --enable-workarounds-for-imap-client-bugs bei ./configure angegeben?

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 13:45

ne, ich will mich da vol lund ganz auf die Debian-Packete beziehen!
selber bauen tu ich das ding deswegen nun nicht.... aber ärgerlich ist ers schon.,.

alexander newald
Posts: 1117
Joined: 2002-09-27 00:54
Location: Hannover

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by alexander newald » 2003-08-20 15:55

;-) Es hat schon Sinn, dass ich das Frage, denn ohne die Configure Oprion funktioniert Courier IMAP zB. mit Outlook einfach nicht...! Dabei ist es egal, ob du ein deb Packet nimmst oder selber baust. Wenn die Option nicht verwendet wird bleiben Outlook IMAP Leute eben draussen. Ende

krispin
Posts: 216
Joined: 2003-04-14 16:30

Re: Courier-IMAP über Telnet -> nichts Toyota

Post by krispin » 2003-08-20 23:05

ich nix Outlook-User bin! :)

hmm, aber mein Mozzi macht ja auch Probleme...