Problem beim Senden von eMails nach Systemupdate

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
acepilot
Posts: 86
Joined: 2003-07-30 17:42

Problem beim Senden von eMails nach Systemupdate

Post by acepilot » 2003-08-05 17:40

Hallo zusammen,

Ich habe gestern mein Rootie upgedatete, alle neuen patches drauf etc. Leider funzt jetzt das verschicken der eMails nicht mehr. Habe schon hier im Forum danach geschaut aber nichts wirklich brauchbares gefunden, vielleicht habe ich auch was übersehen.

Wenn ich in die var log messages schaue steht folgendes drin.

Code: Select all

Aug  5 17:34:59 p15139179 postfix/smtpd[20606]: connect from p508EDACD.dip.t-dialin.net[80.142.218.205]
Aug  5 17:35:00 p15139179 postfix/smtpd[20606]: 2642A20405E: client=p508EDACD.dip.t-dialin.net[80.142.218.205]
Aug  5 17:35:00 p15139179 postfix/smtpd[20606]: reject: RCPT from p508EDACD.dip.t-dialin.net[80.142.218.205]: 554 <support@schlundtechnologies.com>: Relay access denied; from=<webmaster@creative-web-agency.info> to=<support@schlundtechnologies.com>
Aug  5 17:35:05 p15139179 postfix/smtpd[20606]: disconnect from p508EDACD.dip.t-dialin.net[80.142.218.205]
Klar sagt mir auch das der Relay access verboten ist, aber warum da komme ich im moment nicht ganz hinter. Kann sein das das Update von Suse irgendetwas wichtiges überschrieben hat ?

Gruß
Markus

acepilot
Posts: 86
Joined: 2003-07-30 17:42

Re: Problem beim Senden von eMails nach Systemupdate

Post by acepilot » 2003-08-05 18:11

Mmh, habe mal die ganzen Konfigurationsdateien durchgeschaut, ich denke das es ganz stark was mit den Dateien confixx_localDomains und confixx_virtualUsers zu tun hat.

Weil da stehen ja alle Domains un KOnten drinn, könnte doch sein das sich Postfix bis dato dort die Informationen geholt hat wer darf und wer nicht. Wenn ich falsch liege, möge mich man berichtigen, falls ich richtig liege wäre ein kleine ANstoss wie Postfix dazu bewege die Datein wieder zu verwenden ganz nett. :?

acepilot
Posts: 86
Joined: 2003-07-30 17:42

Re: Problem beim Senden von eMails nach Systemupdate

Post by acepilot » 2003-08-06 15:54

Habe jetzt rausgefunden, das wenn ich bei Outlook das Häckchen anklicke "Server erfordert Authentifizierung" funktioniert das eMail Versenden. Ich weiß auch das es auf jeden Fall auf diese Art und weise die sicherere Methode ist, trotzdem würde mich interressieren durch welche einstellung das geregelt wird. Ging ja vorher auch ohne.

sternenjaeger
Posts: 40
Joined: 2003-06-13 19:03

Re: Problem beim Senden von eMails nach Systemupdate

Post by sternenjaeger » 2003-08-07 00:47

Hört sich für mich nach SMTP_Auth an, was auch das mit dem Relay access denied erklärt...und natürlich geht es dann nur, wenn du dich vorher am Server anmeldest....daher mit "Server erfordert Authentifizierung", denn dafür ist das Ganze ja gedacht.

acepilot
Posts: 86
Joined: 2003-07-30 17:42

Re: Problem beim Senden von eMails nach Systemupdate

Post by acepilot » 2003-08-07 19:43

Ja klar, habe mich auch mal soweit rein gearbeitet das ich weiß, das vorher pop-before-SMTP gelaufen sein muß. Dafür gibt es ja anscheinend ein paar Tools, habe schon eins ausprobiert was leider nicht funktioniert hat (pop-before-smtp.pl).
Naja ich werde mal weitersuchen