DNS eingerichtet und es lief eigentlich auch gut ....

Bind, PowerDNS
Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

DNS eingerichtet und es lief eigentlich auch gut ....

Post by Outlaw » 2003-08-01 01:34

Hallo Leute,

[EDIT] Problem gelöst / Punkt hinter Domain vergessen ....

Aber trotzdem noch die Frage: Kann man hier noch was verbessern ?? [/EDIT]

named.conf:

Code: Select all

options {

        directory "/var/lib/named";
        # forwarders { 195.20.224.2343; 195.20.224.99; };
        # forward first;
        # listen-on port 53 { 127.0.0.1; };
        # listen-on-v6 { none; };
        # query-source address * port 53;
        # transfer-source * port 53;
        # notify-source * port 53;
        # transfer-source * port 53;
        # notify-source * port 53;
        # allow-query { 127.0.0.1; };
        notify no;
        auth-nxdomain no;
        allow-transfer { 195.20.224.97; 195.20.225.34; };
};

zone "localhost" in {
        type master;
        file "localhost.zone";
};

zone "0.0.127.in-addr.arpa" in {
        type master;
        file "127.0.0.zone";
};

zone "xxx.160.217.in-addr.arpa" in {
        type master;
        file "217.160.xxx.zone";
};

zone "Domain1.tld" in {
        type master;
        file "Domain1.zone";
};

zone "Domain2.tld" in {
        type master;
        file "Domain2.zone";
};

zone "." in {
        type hint;
        file "root.hint";
};
217.260.xxx.zone:

Code: Select all

$TTL 1W
@               IN SOA  ns.Domain1.tld.    root.Domain1.tld. (
                                2003073002      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                12H)            ; minimum

                IN NS   ns
                IN NS   ns.schlund.de.
xxx             IN PTR  Domain1.tld.
Domain1.zone:

Code: Select all

$TTL 1W
@               IN SOA  ns.Domain1.tld.    root.Domain1.tld. (
                                2003073002      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                12H)            ; minimum

                IN NS   ns
                IN NS   ns.schlund.de.
                IN A    217.160.xxx.xxx
mail            IN A    217.160.xxx.xxx
ns              IN A    217.160.xxx.xxx
*               IN A    217.160.xxx.xxx
Domain2.zone:

Code: Select all

$TTL 1W
@               IN SOA  ns.Domain2.tld.    root.Domain2.tld. (
                                2003073002      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                12H)            ; minimum

                IN NS   ns.Domain1.tld.
                IN NS   ns.schlund.de.
                IN A    217.160.xxx.xxx
*               IN A    217.160.xxx.xxx
www             IN A    217.160.xxx.xxx
Gruß Outi
:D Gruß Outi :D

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: DNS eingerichtet und es lief eigentlich auch gut ....

Post by magnum2 » 2003-08-01 07:56

So ad hoc siehts imho ganz gut aus.
217.260.xxx.zone
Das reverse zonefile für die 217.260...... (260 ??) kannste eigentlich knicken, da wir darauf eh keinen Zugriff haben. Also nicht nötig.
Solltest du dann irgendwann deine eigenen secondary betreiben, nicht vergessen den dann auch bei allow-transfer mit einzutragen.........

Outlaw
Posts: 1500
Joined: 2002-12-04 10:22
Location: 4. Server von rechts, 2. Reihe von oben

Re: DNS eingerichtet und es lief eigentlich auch gut ....

Post by Outlaw » 2003-08-01 10:46

Sorry, Schreibfehler, natürlich heisst es 160 ....

;):D

Danke für die Infos.
:D Gruß Outi :D