[sqwebmail] Fehler bei ./configure

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
psychoviper
Posts: 5
Joined: 2002-07-14 20:29

[sqwebmail] Fehler bei ./configure

Post by psychoviper » 2002-08-09 19:25

Hi zusammen,

wollte auf meiner lokalen Maschine etwas mit qmail rumspielen (um zu sehen, ob das ganze dann später mal auf den server kommt). Bin nach dem HowTo von Rene Schleicher vorgegangen...

bekomme beim ./configure von sqwebmail jedoch einen Abbruch:

Code: Select all

root@linux:/.../sqwebmail-3.3.7 > ./configure --enable-cgibindir=/usr/local/apache/cgi-bin --with-authvchkpw --with-db=gdbm --with-userdb=/etc/userdb --enable-imagedir=/usr/local/apache/htdocs/webmail --without-authdaemon
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... found
checking whether make sets ${MAKE}... (cached) yes
checking whether ln -s works... yes
checking for perl5... no
checking for perl... /usr/bin/perl
checking for sysconftool...... ././sysconftool
checking for gdbm_open in -lgdbm... no
checking for gdbm_open... no
configure: error: Cannot find either the gdbm or the db library.
root@linux:/.../sqwebmail-3.3.7 >
gdbm ist auf meinem (noch) ziemlich minimalen Suse 7.2 System drauf...

Nachtrag: ein rpm -q db ergibt ein "db-3.1.17-56"
Last edited by psychoviper on 2002-08-09 19:37, edited 1 time in total.

harley
Posts: 31
Joined: 2002-08-03 04:06

Re: [sqwebmail] Fehler bei ./configure

Post by harley » 2002-08-09 19:33

Hallo,

Dir fehlen diese Dinge "gdbm or the db" einfach mal bei rpmfind.net suchen und installieren, dann sollte das gehen.

psychoviper
Posts: 5
Joined: 2002-07-14 20:29

Re: [sqwebmail] Fehler bei ./configure

Post by psychoviper » 2002-08-09 21:32

Harley wrote:Dir fehlen diese Dinge "gdbm or the db" einfach mal bei rpmfind.net suchen und installieren, dann sollte das gehen.
gdbm ist wie vorhin schon gesagt drauf und db (hab ich jetzt nachgeschaut) ist auch vorhanden :?

harley
Posts: 31
Joined: 2002-08-03 04:06

Re: [sqwebmail] Fehler bei ./configure

Post by harley » 2002-08-09 21:48

Hm,

schau mal hier http://www.courier-mta.org/FAQ.html, da steht auch was dazu.

Hast Du mal versucht den Pfad anzugeben beim configure?

psychoviper
Posts: 5
Joined: 2002-07-14 20:29

Re: [sqwebmail] Fehler bei ./configure

Post by psychoviper » 2002-08-10 19:38

hm, für die gdbm und / oder die db gibt's keinen Pfad bei ./configure ... ich frag mich nur, warum er die einfach nicht finden will... :(

Nachtrag: Also ich hab immernoch das selbe Problem wie im Ausgangsthred und auch qinstaller scheitert am selben problem...

harley
Posts: 31
Joined: 2002-08-03 04:06

Re: [sqwebmail] Fehler bei ./configure

Post by harley » 2002-08-10 20:12

Haste das schon mal so verscht? ka obs geht, aber sollte.

--with-db=/pfad --with-gdbm=/pfad

psychoviper
Posts: 5
Joined: 2002-07-14 20:29

Re: [sqwebmail] Fehler bei ./configure

Post by psychoviper » 2002-08-12 16:06

hm, hab jetzt einfach mal ein bißchen rumprobiert und aufeinmal ging die Installation - kA an was es lag :roll:

kikman
Posts: 14
Joined: 2002-12-18 09:32

auch ich bekomme .........

Post by kikman » 2003-01-02 17:36

Hi,

Auch ich bekomme eine solche Fehlermeldung :cry:
Aber gdbm wie db ist installiert.

Code: Select all

./configure --enable-cgibindir=/www/cgi-bin --with-authvchkpw --with-db=gdbm --with-userdb=/etc/userdb --enable-imagedir=/www/htdocs/webmail --without-authdaemon
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking whether make sets ${MAKE}... (cached) yes
checking whether ln -s works... yes
checking for perl5... no
checking for perl... /usr/bin/perl
checking for sysconftool...... ././sysconftool
checking for gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking for gdbm_open in -lgdbm... no
checking for gdbm_open... no
configure: error: Cannot find either the gdbm or the db library.
Kann mir da wer weiterhelfen ?

Gruß
Kikman

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: [sqwebmail] Fehler bei ./configure

Post by captaincrunch » 2003-01-02 17:39

Gib dem ./configure doch einfach mal die Pfade zu den benötigten Files an. Im Normalfall gibt's ein configure.log, aus dem mehr hervorgehen dürfte ...
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

kikman
Posts: 14
Joined: 2002-12-18 09:32

Re: [sqwebmail] Fehler bei ./configure

Post by kikman » 2003-01-02 18:00

Hi,
hab ich schon getan. dann bekomm ich:

Code: Select all

configure: error: Invalid --with-db option.
wenn ich dann einfach die db option weglasse meckert er wieder:

Code: Select all

configure: error: Cannot find either the gdbm or the db library
THX für die schnelle Antwort

Gruß
Kikman

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: [sqwebmail] Fehler bei ./configure

Post by floschi » 2003-01-02 20:27

Hi !

Gibt's evtl. gdbm-dev Packete, die installiert sein müssen?


Gruß

Olfi ;)

hugo
Posts: 87
Joined: 2002-06-08 21:33

Re: [sqwebmail] Fehler bei ./configure

Post by hugo » 2003-01-02 22:29

Salve!
@ olfi
Ja, gdbm-dev gibt es, als ich es installiert hatte, funktionierte auch sqwebmail! ;)

Hugo ;)

kikman
Posts: 14
Joined: 2002-12-18 09:32

Re: [sqwebmail] Fehler bei ./configure

Post by kikman » 2003-01-02 22:37

Big THX!!

gdbm-dev

Danke das wars :-D :-D

Gruß
Kikman

kikman
Posts: 14
Joined: 2002-12-18 09:32

Re: [sqwebmail] Fehler bei ./configure

Post by kikman » 2003-01-03 10:15

Ich muß leider nochmal :cry:

Jetzt bekomme ich folgende Meldung:

Code: Select all

configure: running /bin/sh './configure' --prefix=/usr/local/share/sqwebmail  '--prefix=/usr/local/share/sqwebmail' '--with-htmldir=/usr/local/share/sqwebmail/html' '--enable-cgibindir=/var/www/cgi-bin' '--with-authvchkpw' '--with-db=gdbm' '--with-userdb=/etc/userdb' '--enable-imagedir=/var/www/webmail' '--without-authdaemon' '--with-formdata' '--enable-utf7-folder-encoding' '--enable-unicode=iso-8859-1,utf-8' '--with-makedatprog=/usr/local/share/sqwebmail/libexec/sqwebmail/makedatprog' '--with-authchangepwdir=/usr/local/share/sqwebmail/libexec/authlib' '--with-authdaemonvar=/usr/local/share/sqwebmail/var/authdaemon' '--sysconfdir=/usr/local/share/sqwebmail' '--with-package=sqwebmail' '--with-version=3.4.1' '--without-socks' '--cache-file=/dev/null' '--srcdir=.' '--with-defaultlang=en' --cache-file=/dev/null --srcdir=.
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether make sets ${MAKE}... (cached) yes
configure: creating ./config.status
config.status: creating Makefile
./configure: ./mksoftlinks: /bin/sh: bad interpreter: Permission denied
configure: error: /bin/sh './configure' failed for html
configure: error: /bin/sh './configure' failed for sqwebmail
Kann mir da nochmal jemand unter die Arme greifen?

Gruß
Kikman

kikman
Posts: 14
Joined: 2002-12-18 09:32

Re: [sqwebmail] Fehler bei ./configure

Post by kikman » 2003-01-03 10:55

und wieder meine Wenigkeit :)

Habe jetzt Version 3.3.3 statt 3.4.1 genommen und alles hat wunderbar geklappt. :-D

Trozdem danke für eure Hilfe!

Gruß
Kikman