Q- Mail Probleme bei Empfang

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
xstream
Posts: 68
Joined: 2003-06-30 20:15

Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 11:12

Hallo,


ich habe leider kaum Ahnung von qmail....

Hab das wie im debian Howto installiert und mit pd-admin einen pop3- Account eingerichtet.

Ã?ber Outlook Expr. kann ich nun auch Mails versenden.

Ich habe folgendes in der DNS- Zone eingetragen:
Es ist jetzt nicht das Zone- File sondern nur der Inhalt des Formulars meines Domainrobots:

Sub1
______________________
Sub: mail
TTL:
RR- Typ: A
Pref(MX):
Wert: 213.146.181.50

Sub2
______________________
Sub:
TTL:
RR- Typ: MX
Pref(MX): 10
Wert: mail


Laut meinem Support soll das auch so gehen...

Mein Problem: Wenn ich was an meine neue Mail- Adresse schick bekomme ich immer ne Delivery zurück.

Abrufen kann ich neue Mails über Outlook auch nicht (nur senden)....


Woran könnte sowas liegen?


Danke
Philipp

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 15:14

ist die frage zu dumm?
soll ich noch genauers zur Konfiguration schreiben?


Bitte äußert doch mal ne Vermutung... ich müsste das heute noch zum laufen kriegen...

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 21:08

Paste mal die Meldung was dein Outlook sagt?
Also den Fehler mein ich natürlich :)

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Q- Mail Probleme bei Empfang

Post by captaincrunch » 2003-07-18 21:41

Outlook-Fehlermeldungen sind Schall und Rauch. Das einzige was zählt sind Serverlogs ...
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 21:46

naja vielleicht ist es nur nen RCP fehler oder so :)

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:13

wo finde ich denn üblicherweise die qmail logs?

In /var/log ist bei mir das einzige was irgendwie mit nem Mail- Log zu tun haben könnte eine mail.err, mail.log und mail.warn


Allerdings bezweifle ich dass das qmail Log- Dateien sind oder doch?

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:19

Normal sollten sie in /var/log/qmail/ liegen :)

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:20

nein, das Verzeichnis gibt es leider nicht :(

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:23

Factory-Shell:/var/log/qmail# ls
@400000003f0d7c421ee34b94.u @400000003f10803b2606cb6c.s current pop3d smtpd
@400000003f0f3ccb29d20c0c.s @400000003f172989045dce34.s lock pop3sd state
Factory-Shell:/var/log/qmail#

so shaut mein Qmail-Log dir aus, vielleicht hikt es dir ja die files via "locate" zu finden.

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Q- Mail Probleme bei Empfang

Post by floschi » 2003-07-18 22:24

Gut, dann schalten wir mal ein wenig unser Hirn an und schauen in /var/log nach Dateien, die irgendwas mit Mail zu tun haben könnten. Und wenn die dort nicht liegen, haste dich nicht ans Howto gehalten... ;)

Btw, sofern dein Outlook eine ausführliche Fehlermeldung liefert (oder die Bouncemail), kannste die auch posten...

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:28

Erst mal, muss nen dickes fettes Log an die debianhowto.de ausgesprochen werden :) Echt klaase sache das :)

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:33

Outlook:
Bei der Verbindung zum Server ist ein Fehler aufgetreten. Konto: 'webmaster@dualweb.de', Server: 'mail.dualweb.de', Protokoll: POP3, Port: 110, Secure (SSL): Nein, Socketfehler: 10061, Fehlernummer: 0x800CCC0E
Delivery:

Code: Select all

Reporting-MTA: dns;hotmail.com
Received-From-MTA: dns;mail.hotmail.com
Arrival-Date: Fri, 18 Jul 2003 01:01:16 -0700

Final-Recipient: rfc822;webmaster@dualweb.de
Action: failed
Status: 5.0.0

ich denke so sonderlich viel wird das nicht helfen oder doch?

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Q- Mail Probleme bei Empfang

Post by floschi » 2003-07-18 22:36

Läuft der POP3? Mach mal ein pstree, da müsste unten 2*tcpserver stehen... wenn nicht, mach ein /etc/init.d/qmail restart

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:39

tcpserver steht nur einmal da...

auch nach dem restart


das sind die unteren Zeilen:

Code: Select all

     |-proftpd
     |-qmail-send-+-qmail-clean
     |            |-qmail-lspawn
     |            |-qmail-rspawn
     |            `-splogger
     |-safe_mysqld---mysqld---mysqld---2*[mysqld]
     |-splogger
     |-sshd---sshd---bash---pstree
     |-syslogd
     `-tcpserver

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:43

mir ist fast klar das das nix werden kann,

Die DNS einträge passen vorn und hinten nicht.
dualweb.de MX 10 mail.dualweb.de.dualweb.de
es muesste in deiner zonefile so heißen

mail IN A xxx.xxx.xxx.xxx oder
mail.dualweb.de. IN A xxx.xxx.xxx.xxx

Das wäre dann schon mal die host mail.
Nun brauchen wir noch ein MX eintrag.

entwerder:

mail IN MX 10 mail.dualweb.de. <-- man beachte jeweils denk punkt.

oder

mail.dualweb.de. IN MX 10 mal.dualweb.de. <-- punkte beachten.

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Q- Mail Probleme bei Empfang

Post by floschi » 2003-07-18 22:44

Dann kontrollier mal, ob du alles im initskript richtig gemacht hast... /etc/init.d/qmail

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:45

ok, werd das mal ausprobieren gleich...

Die Einträge, die ich oben beschrieben hab, hat mein Support so gemacht und meinte das müsste so laufen...

komisch... naja werd das mal ändern...

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:47

Bevo hier weiter getestet wird,
es liegt an den DNS-Einträgen:
dualweb.de A 213.146.181.50
dualweb.de NS ns2.bcc.de
dualweb.de NS ns1.bcc.de
dualweb.de MX 10 mail.dualweb.de.dualweb.de
dualweb.de SOA ns1.bcc.de mail.philipp-dudda.de (
2003071600 ;serial (version)
39940 ;refresh period (11 hours, 5 minutes, 40 seconds)
7200 ;retry interval (2 hours)
604800 ;expire time (1 week)
86400 ;default ttl (1 day)
)
Da gibt es weder eine mail. oder ein gescheiten MX eintrag, logisch das es kein POP3 gibt der antworten mag

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-18 22:54

hmm jetzt richtig?

Ich hab leider nur ne Reihe Eingabefelder über ein Webinterface und kann nicht das Zonefile direkt editieren...

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-18 22:55

das zonefile muss erst mal updated werden :)

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-19 08:26

soo, problem besteht leider weiterhin....

web-shell
Posts: 10
Joined: 2003-07-14 22:26
Location: Frankfurt

re

Post by web-shell » 2003-07-19 11:18

linux-scripts@Factory-Shell:/root$ host -t any dualweb.de
dualweb.de A 213.146.181.50
dualweb.de NS ns2.bcc.de
dualweb.de NS ns1.bcc.de
dualweb.de MX 10 mail.dualweb.de.dualweb.de
dualweb.de SOA ns1.bcc.de mail.philipp-dudda.de (
Angeblich noch nicht,

xstream
Posts: 68
Joined: 2003-06-30 20:15

Re: Q- Mail Probleme bei Empfang

Post by xstream » 2003-07-20 00:26

so, jetzt habt ihr für die nächste Zeit erstmal ruhe von mir - bin ab morgen erstmal für etwa 2 Wochen im Urlaub...

Das Problem besteht aber immernoch... ;)
Werd dann wieder rumnerven wenn ich wieder da bin :)


cu

Philipp