Probs mit postfix

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
ropat
Posts: 7
Joined: 2002-10-26 15:01

Probs mit postfix

Post by ropat » 2003-07-12 16:22

Hallo,

seit einigen Tagen kann Postfix keine eMails mehr empfangen. Meldung in /var/log/mail: relaying denied.

Unser Webmaster hat hier vor einigen Tagen Ã?nderungen gemacht (weil ich einen anderen Fehler verursacht habe), ist nun aber im Urlaub und ich bin hierfür verantwortlich. Seit seinen "Fehlerbehebungen" geht Postfix nicht mehr. Ich habe nun noch nie etwas mit postfix gemacht.

Warum kommt jede eMail wieder zurück? Domains sind alle local vorhanden, MX-Einträge stimmen etc. Sie werden jedoch immer wieder mit "relaying denied" zurückgewiesen.

Hat jemand einen Ansatzpunkt?

Danke,
ropat.

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: Probs mit postfix

Post by magnum2 » 2003-07-12 16:39

Sieh doch mal nach was bei mydestination in der main.cf so drinsteht.
Gibt es mehrere domains ?

ropat
Posts: 7
Joined: 2002-10-26 15:01

Re: Probs mit postfix

Post by ropat » 2003-07-12 16:54

Hallo,

die sollte doch eigendlich unter /etc/postfix liegen, oder? Den Ordner gibt es bei mir aber leider nicht. Soweit ich weiss, läuft dieser Server ohne postfix, die Fehlermeldung werden aber trotzdem wie folgt ausgegeben:

This is the Postfix program at host XXXXX.pureserver.info.

I'm sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

<XX@XXXXX.org>: host XXXX.de[217.160.XXX.XXX] said:
550 5.7.1 <XX@XXX.org>... Relaying denied
Der Webmaster hat meines Wissens nach einige Dateien aus einer neueren Generation der Puretec-Server überspielt, da ich einen grausamen Fehler gemacht hatte.

Domains: ca. 200

mfg,
Ropat

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: Probs mit postfix

Post by magnum2 » 2003-07-12 17:06

Dann gib doch einfach mal postconf ein. Da sollte er dir sagen wo seine configs liegen (sollten).

ropat
Posts: 7
Joined: 2002-10-26 15:01

Re: Probs mit postfix

Post by ropat » 2003-07-12 17:09

"postconf" ist nicht vorhanden... Wie gesagt, ich glaube auch nicht, das Postfix installiert ist.

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: Probs mit postfix

Post by magnum2 » 2003-07-12 17:15

Naja dann sollten wir erstmal rauskriegen welcher MDA denn da lüpt.

Gib doch mal "telnet localhost 25" ein (aufm Server) und sieh mal wer sich da meldet.

bzw. gibts ne /var/log/mail ?

ropat
Posts: 7
Joined: 2002-10-26 15:01

Re: Probs mit postfix

Post by ropat » 2003-07-12 17:24

220 x.xxxx.de ESMTP Sendmail 8.11.3/8.11.3/SuSE Linux 8.11.1-0.5;
In /var/log/mail sehe ich ja auch die "relaying denied", zusätzlich zur rückkommenden eMail.

mfg,
ropat

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: Probs mit postfix

Post by magnum2 » 2003-07-12 17:30

Ah da stehts ja sendmail sorry aber da muss ich passen, vor einer sendmail.cf grausts mir zu stark :-D
Da müssen andere ran........

ropat
Posts: 7
Joined: 2002-10-26 15:01

Re: Probs mit postfix

Post by ropat » 2003-07-12 17:51

Hallo,

ok, sendmail scheint hierfür verantwortlich zu sein. Aber warum wird die Fehlermeldung von "postfix" geliefert, obwohl doch kein Postfix installiert ist?

Hat jemand einen Rat?

magnum2
Posts: 201
Joined: 2002-08-12 16:30
Location: Grünwald

Re: Probs mit postfix

Post by magnum2 » 2003-07-12 18:18

Nur weil da Postfix draufsteht muss ja noch lange nicht Postfix drin sein. :)
Ich könnte mir vorstellen das sich sowas konfigurieren lässt z. B. um nicht gleich jedem Absender mitzuteielen wer man wirklich ist und damit wo vielleicht Angriffspunkte liegen..... oder so

ropat
Posts: 7
Joined: 2002-10-26 15:01

Re: Probs mit postfix

Post by ropat » 2003-07-12 18:22

Hallo,

das glaube ich nicht. Ich vermute eben hier irgendwo den Fehler. Postfix ist nicht installiert, die Fehlermeldung wird aber mit dem Absender "Postfix" geliefert - und es funzt nicht. Darum will ich hier durchsteigen.

Ich vermute den Fehler irgendwo hier, das z.B. versucht wird, die eMail über Postfix zu empfangen, was nicht geht.