Performance von 3ware 7000-series ATA-RAID nicht so doll?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
sstadtl
Posts: 34
Joined: 2002-09-01 19:02

Performance von 3ware 7000-series ATA-RAID nicht so doll?

Post by sstadtl »

Hallo

Ich habe eine neuen Server, der ein IDE Raid 1 hat.
RAID bus controller: 3ware Inc 3ware 7000-series ATA-RAID (rev 1).

die Performance ist eher ernüchternd, Hat jemand ne Ahnung, ob ich da noch etwas Tunen kann?
Leider habe ich das mitgelieferte RedHat gleich runtergebügelt, als kann ich nicht feststellen on es am Debian(2.4.20-2-686-smp) liegt.

Performance neuer Server(p4 3000,Debian,2GB Memory) :

hdparm -tT /dev/sda

/dev/sda:
Timing buffer-cache reads: 128 MB in 1.10 seconds =116.36 MB/sec
Timing buffered disk reads: 64 MB in 3.28 seconds = 19.51 MB/sec

Vergleich alter Server 1 (Dual p3 1200, SuSE):hdparm -tT /dev/hda

/dev/hda:
Timing buffer-cache reads: 128 MB in 0.62 seconds =206.45 MB/sec
Timing buffered disk reads: 64 MB in 1.47 seconds = 43.54 MB/sec

Vergleich alter Server 2 (p4 2400, Debian):
hdparm -tT /dev/hda

/dev/hda:
Timing buffer-cache reads: 128 MB in 0.43 seconds =297.67 MB/sec
Timing buffered disk reads: 64 MB in 2.24 seconds = 28.57 MB/sec

Hat jemand Ahnung von Treibern unter Linux/debian und ob ich da noch etwas einstellen kann?
Oder hat zufällig noch jemand so einen Server wie meinen neuen auf dem aber das RedHat noch drauf ist und könnte einen Vergleichswert posten?

Danke und Grüße
Sebastian

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Performance von 3ware 7000-series ATA-RAID nicht so doll?

Post by captaincrunch »

Ich verweise mal auf folgenden Thread http://www.rootforum.org/forum/viewtopic.php?t=4365 und vershciebe ins Linux und spezielle
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

sstadtl
Posts: 34
Joined: 2002-09-01 19:02

geht den auch mit /dev/sda ?

Post by sstadtl »

CaptainCrunch wrote:Ich verweise mal auf folgenden Thread http://www.rootforum.org/forum/viewtopic.php?t=4365 und vershciebe ins Linux und spezielle
Tja den Thraed kenne ich natürlich, aber da dreht sich alles um direkt am IDE-Controller angeschlossenen IDE Platten. Aber wie ist das mit "3ware Inc 3ware 7000-series ATA-RAID ". Da wird ja /dev/sda verwendet. Kann ich da auch mit hdparm dran drehen?

Danke
Sebastian

captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Performance von 3ware 7000-series ATA-RAID nicht so doll?

Post by captaincrunch »

Oh mann, da sagst du was ... ich hatte komplett verschwitzt, dass hdparm zum größten teil auf IDE-Devices gemüntzt ist ... :oops:

Welches Modul wird denn genutzt ? Das "stinknormale" Kernelmodul ?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

sstadtl
Posts: 34
Joined: 2002-09-01 19:02

Re: Performance von 3ware 7000-series ATA-RAID nicht so doll?

Post by sstadtl »

CaptainCrunch wrote: Welches Modul wird denn genutzt ? Das "stinknormale" Kernelmodul ?
Bin was Hardware unter Linux Betrifft totaler Laie. Ich hoffe das beantwortet die Frage :
---------------
#lsmod
Module Size Used by Not tainted
soundcore 4004 0 (autoclean)
ipt_limit 1152 5 (autoclean)
ipt_state 736 121 (autoclean)
ip_conntrack 20116 1 (autoclean) [ipt_state]
iptable_filter 1824 1 (autoclean)
ip_tables 11264 3 [ipt_limit ipt_state iptable_filter]
via-rhine 12616 1
mii 2528 0 [via-rhine]
af_packet 13288 0 (unused)
rtc 6588 0 (autoclean)
sd_mod 10812 14 (autoclean)
ext3 60960 6 (autoclean)
jbd 40168 6 (autoclean) [ext3]
3w-xxxx 32032 7 (autoclean)
scsi_mod 91832 2 (autoclean) [sd_mod 3w-xxxx]
unix 16004 77 (autoclean)
sxxxxxxxx:~/software# modinfo 3w-xxxxfilename: /lib/modules/2.4.20-2-686-smp/kernel/drivers/scsi/3w-xxxx.o
description: "3ware Storage Controller Linux Driver"
author: "3ware Inc."
license: "GPL"

ich habe nix anderes geladen außer dem, was automatisch mitinstalliert wurde. Um ehrlich zu sein, ich wüsste auch nicht wie ich das anstelle :oops:

Sebastian

sstadtl
Posts: 34
Joined: 2002-09-01 19:02

Ist doch alles anders. Lag am Kernel!

Post by sstadtl »

habe jetzt den Kernel ohne SMP installiert und der alles ist so schnell wie es sein sollte.

Verstehe zwar nicht warum das der Grund ist, aber egal.

ist wohl Zeit mal selbst einen Kernel mit SMP zu compilieren :-)

Sebastian

sascha
Posts: 1325
Joined: 2002-04-22 23:08

Re: Performance von 3ware 7000-series ATA-RAID nicht so doll?

Post by sascha »

Wozu denn überhaupt einen SMP Kernel? Hast du 2 Prozessoren oder ist das ein P4 mit Hyper-Threading? (Braucht man da überhaupt SMP?).

sstadtl
Posts: 34
Joined: 2002-09-01 19:02

Ja ist ein p4 mit Hyperthreading

Post by sstadtl »

Läuft ohne SMP jetzt super.
So richtig großen Sinn macht Hyperthreading ja eh nicht, daher könnte ich es eigentlich bei dem belassen was ich jetzt installiert habe.

Warum das aber die /dev/sda Performance senkt werde ich wohl nie verstehen. Habe jetzt nochmal zwei andere Kernel probiert und dort das gleich Spiel : mit SMP deutlich Langsamer.

Die Website, die da drauf laufen soll, die ist mit SMP-Kernel 40% langsamer. Das verstehe wer will. Ich nicht :?