[debian + qmail] pop3 wird bei einem reboot nicht gestartet

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
sfeni
Posts: 341
Joined: 2002-08-15 11:35
Location: Schwabenland

[debian + qmail] pop3 wird bei einem reboot nicht gestartet

Post by sfeni » 2003-07-01 09:03

Nach einem Reboot muss ich manuell mit "/etc/init.d/qmail restart" den qmail neu starten, so dass der pop3 server gestartet wird.
kann mir jemand helfen, so dass dieser automatisch wieder gestartet wird? (Es hat komischerweise bisher immer funktioniert)

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: [debian + qmail] pop3 wird bei einem reboot nicht gestartet

Post by captaincrunch » 2003-07-01 09:25

Schau dir mal update-rc.d an, die manpage ist sehr hilfreich dabei ... ;)
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

sfeni
Posts: 341
Joined: 2002-08-15 11:35
Location: Schwabenland

Re: [debian + qmail] pop3 wird bei einem reboot nicht gestartet

Post by sfeni » 2003-07-01 09:44

das komische ist ja, dass der smtp gestartet wird nur der pop3 nicht.

nach einem restart von qmail läuft der pop3...
das hat doch nix mit dem update-rc.d zu tun...oder doch?
qmail steht ja in runlevel 3 drin...

sfeni
Posts: 341
Joined: 2002-08-15 11:35
Location: Schwabenland

Re: [debian + qmail] pop3 wird bei einem reboot nicht gestartet

Post by sfeni » 2003-07-03 09:01

Niemand da, der eine Vermutung hat?

Immer nach einem Neustart muss ich "/etc/init.d/qmail restart" ausführen, dass der POP3-Server auch anspringt!?
Das ist echt nervig...

(SMTP und POP3 sollten über das Start/Stop Skript gestartet werden, es wird aber nur der SMTP gestartet)

Das Skript:

Code: Select all

#!/bin/bash
#
# /etc/init.d/qmail : start or stop the qmail mail subsystem.
#
# Written by Christian Hudon <chrish@debian.org>
# Currently maintained by Jon Marler <jmarler@debian.org>
#
# Configuration
#


# set default delivery method

alias_empty="|/usr/sbin/qmail-procmail"  # procmail delivery to /var/spool/mail
#alias_empty="./Maildir/"       # This uses qmail prefered ~/Maildir/ directory
                                # You may want to maildirmake /etc/skel/Maildir
#alias_empty="./Mailbox"        # This uses Mailbox file in users $HOME

logger="splogger qmail"
#logger="|accustamp >>/var/log/qmail.log"   # If you have accustamp installed.
#logger=">>/var/log/qmail.log"              # Does not give timing info.

# If you uncommented one of the lines that appends to /var/log/qmail.log, you
# need to uncomment the following two lines.
#touch /var/log/qmail.log
#chown qmaill /var/log/qmail.log

#
# End of configuration
#

test -x /usr/sbin/qmail-start || exit 0
test -x /usr/sbin/qmail-send || exit 0

case "$1" in
    start)
        echo -n "Starting mail-transfer agent: qmail"
        sh -c "start-stop-daemon --start --quiet --user qmails 
                 --exec /usr/sbin/qmail-send 
                 --startas /usr/sbin/qmail-start -- "$alias_empty" $logger &"
        # prevent denial-of-service attacks, with ulimit
        ulimit -v 8192
        sh -c "start-stop-daemon --start --quiet --user qmaild 
            --exec /usr/bin/tcpserver -- -R -H 
            -u `id -u qmaild` -g `id -g nobody` -x /etc/tcp.smtp.cdb 0 smtp 
            /usr/sbin/qmail-smtpd mail.administratix.net 
            /opt/vpopmail/bin/vchkpw /bin/true 2>&1 | $logger -t qmail -p mail.notice &"

        # Uncomment the following lines to automatically start the pop3 server
        sh -c "start-stop-daemon --start --quiet --user root 
            --exec /usr/bin/tcpserver -- 
            -H -R 0 pop-3 /usr/sbin/qmail-popup `hostname`.`dnsdomainname` 
            /opt/vpopmail/bin/vchkpw /usr/sbin/qmail-pop3d Maildir &"

        echo "."
        ;;
    stop)
        echo -n "Stopping mail-transfer agent: qmail"
        if [ "`pidof /usr/sbin/qmail-send`" ] ; then
            start-stop-daemon --user qmails --stop --quiet --oknodo --exec /usr/sbin/qmail-send
            start-stop-daemon --user qmaild --stop --quiet --oknodo --exec /usr/bin/tcpserver
            # Uncomment the following line if you have enabled the pop3 server
            start-stop-daemon --user root --stop --quiet --oknodo --exec /usr/bin/tcpserver

            # Wait until the timeout for qmail processes to die.
            count=120
            numdots=0
            while ([ $count != 0 ]) do
                let count=$count-1
                if [ "`pidof /usr/sbin/qmail-send`" ] ; then
                    echo -n .
                    let numdots=$numdots+1
                    sleep 1
                else
                    count=0
                fi
            done

            # If it's not dead yet, kill it.
#           if [ "`pidof /usr/sbin/qmail-send`" ] ; then
#               echo -n " TIMEOUT!"
#               kill -KILL `pidof /usr/sbin/qmail-send`
#           else
                case $numdots in
                  0) echo "." ;;
                  1) echo ;;
                  *) echo " done." ;;
                esac
#           fi
        else
            echo " not running.";
        fi

        ;;
    restart)
        $0 stop
        $0 start
        ;;
    reload|force-reload)
        echo "Reloading 'locals' and 'virtualdomains' control files."
        start-stop-daemon --stop --quiet --oknodo --signal HUP --exec /usr/sbin/qmail-send
        ;;
    *)
        echo 'Usage: /etc/init.d/qmail {start|stop|restart|reload}'
        exit 1
esac

exit 0