Nameserver Fehler?!

Bind, PowerDNS
johnny_x
Posts: 28
Joined: 2003-04-22 00:35

Nameserver Fehler?!

Post by johnny_x » 2003-06-23 15:48

Code: Select all

Jun 23 15:33:37 srv07 /usr/sbin/named[832]: starting BIND 9.1.3 -u named
Jun 23 15:33:37 srv07 /usr/sbin/named[832]: using 1 CPU
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: loading configuration from '/etc/named.conf'
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: no IPv6 interfaces found
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: listening on IPv4 interface lo, 127.0.0.1#53
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: listening on IPv4 interface eth0, 217.160.xxx.xx#53
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: dns_zone_load: zone meine-domain.de/IN: loading master file var/named/meine-domain.de.zone: file not found
Jun 23 15:33:37 srv07 /usr/sbin/named[834]: running
Die Zone-File meine-domain.de.zone existiert im Ordner /var/named/.
Daher verstehe ich nicht, was mein Problem sein könnte.

Ich poste auch mal meine named.conf:

Code: Select all

# BIND 9 Konfigurationsdatei
# 30.12.2002

options {
        directory "/var/named";
       #forwarders { 195.20.224.234; 195.20.224.99; };
        forward first;
        listen-on port 53 { 127.0.0.1; 217.160.xxx.xx; };
       #listen-on-v6 { none; };
        allow-transfer { 195.20.224.97; 195.20.225.34; };
        allow-query { 127.0.0.1; 217.160.xxx.xx; };
        notify no;
        auth-nxdomain no;
        allow-recursion { 127.0.0.1; 217.160.xxx.xx; };
};

zone "localhost" in {
   type master;
   file "/var/named/localhost.zone";
};

zone "0.0.127.in-addr.arpa" in {
   type master;
   file "/var/named/127.0.0.zone";
};

zone "." in {
   type hint;
   file "/var/named/root.hint";
};

zone "meine-domain1.de" in {
   type master;
   file "/var/named/meine-domain1.de.zone";
   allow-query { any; };
};

zone "meine-domain2.de" in {
   type master;
   file "var/named/meine-domain2.de.zone";
   allow-query { any; };
};
Hier meine Zone-File meine-domain1.de.zone :

Code: Select all

$TTL 1W
@           IN      SOA     ns.meine-domain1.de.    root.meine-domain1.de. (
                                2003062302      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                11h )           ; minimum
;
; Zone name server records
;
                IN      NS      ns
                IN      NS      ns.schlund.de.
;
; Zone mail exchange records
;
                IN      MX      10      mx
;
;  Zone records
;
                IN      A       217.160.xxx.xx
*              IN      A       217.160.xxx.xx
Hier die Zone-File für meine-domain2.de :

Code: Select all

$TTL 1W
@           IN      SOA     ns.meine-domain1.de.    root.meine-domain2.de. (
                                2003062302      ; serial
                                8H              ; refresh
                                2H              ; retry
                                1W              ; expiry
                                11h )           ; minimum
;
; Zone name server records
;
                IN      NS      ns
                IN      NS      ns.schlund.de.
;
; Zone mail exchange records
;
                IN      MX      10      mx
;
;  Zone records
;
                IN      A       217.160.xxx.xx
*              IN      A       217.160.xxx.xx
Und hier meine letzte Zone-File 217.160.xxx.zone :

Code: Select all

$TTL 1W
@ IN SOA ns.meine-domain1.de.   root.meine-domain1.de. (
2003062302 ; serial
8H ; refresh
2H ; retry
1W ; expiry
11h) ; minimum

IN NS ns
IN NS ns.schlund.de.
xx IN PTR meine-domain1.de.
Ich hoffe ihr könnt damit etwas anfangen und mir weiterhelfen.
Ich bin mir nicht sicher ob das alles jetzt richtig ist. :?

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: Nameserver Fehler?!

Post by olaf.dietsche » 2003-06-23 16:05

JOHNNY_X wrote:

Code: Select all

Jun 23 15:33:37 srv07 /usr/sbin/named[834]: dns_zone_load: zone meine-domain.de/IN: loading master file var/named/meine-domain.de.zone: file not found
Ich poste auch mal meine named.conf:

Code: Select all

# BIND 9 Konfigurationsdatei
# 30.12.2002

...
zone "meine-domain2.de" in {
   type master;
   file "var/named/meine-domain2.de.zone";
   allow-query { any; };
};
Da du deine Angaben anonymisiert hast, kann ich nicht sicher sein, aber ich vermute mal das meine-domain.de.zone und meine-domain2.de.zone sich auf das gleiche beziehen. Der named hat übrigens Recht var/named/meine-domain2.de.zone gibt es nicht, weil er diese Datei natürlich relativ zum aktuellen Verzeichnis sucht und das ist /var/named/var/named/meine-domain2.de.zone. Wenn du vor das var noch einen / setzt, sollte dein named keine Beschwerden mehr vorbringen.

Also, wenn schon anonymisieren, dann bitte richtig, weil sonst kann man nur raten.

johnny_x
Posts: 28
Joined: 2003-04-22 00:35

Re: Nameserver Fehler?!

Post by johnny_x » 2003-06-23 16:13

Vielen Dank für den Tip. Das "/" hat wirklich gefehlt. :)
Meine-Domain1.de und Meine-Domain2.de sind zwei völlig verschieden Domains. Damit keine weiteren Missverständnisse auftauchen poste ich mal die Domains:

union-network.de (meine-domain1.de)
splash-irc.de (meine-domain2.de)

Ok. Bitte schön :wink:
Könnte jemand prüfen ob das alles richtig ist. Vielen Dank :P

Ach ja folgendes Problem noch:

Code: Select all

named-checkzone 217.160.110.zone
dns_zone_load: zone 217.160.110.zone/IN: no NS records

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: Nameserver Fehler?!

Post by olaf.dietsche » 2003-06-23 17:25

JOHNNY_X wrote:Ach ja folgendes Problem noch:

Code: Select all

named-checkzone 217.160.110.zone
dns_zone_load: zone 217.160.110.zone/IN: no NS records
Da sag' ich mal blind und ohne groß nachzudenken: http://www.rootforum.org/forum/viewtopic ... ght=#91524 ;-)

johnny_x
Posts: 28
Joined: 2003-04-22 00:35

Re: Nameserver Fehler?!

Post by johnny_x » 2003-06-23 17:33

olaf.dietsche wrote: Da sag' ich mal blind und ohne groß nachzudenken: http://www.rootforum.org/forum/viewtopic ... ght=#91524 ;-)
Und ich sag mal: SUPER - Vielen Dank Olaf !! :wink: :wink: 8) 8)

johnny_x
Posts: 28
Joined: 2003-04-22 00:35

Re: Nameserver Fehler?!

Post by johnny_x » 2003-06-23 17:35

Und sonst. Kannst du vielleicht irgendwelche Fehler entdecken in meinen Zone-Files oder in der named.conf?
Aus Fehlern lernt man.... :P

olaf.dietsche
RSAC
Posts: 409
Joined: 2002-12-19 02:06
Location: Siegburg

Re: Nameserver Fehler?!

Post by olaf.dietsche » 2003-06-23 18:54

JOHNNY_X wrote:Und sonst. Kannst du vielleicht irgendwelche Fehler entdecken in meinen Zone-Files oder in der named.conf?
Aus Fehlern lernt man.... :P
Nichts, was mir direkt in's Auge fällt. Allerdings bin ich auch kein DNS oder bind Experte.

Ich würde sagen, wenn keine Fehlermeldungen in den Logs auftauchen und wenn du alle Namen per dig auflösen kannst, dann bist du erst einmal auf der sicheren Seite. :-)