lilo fatal-Meldung bei Kernelinstallation

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

lilo fatal-Meldung bei Kernelinstallation

Post by evoluzzer »

Guten Morgen,

ich will euch ja nicht bei der interessanten Diskussion über Versionen abhalten, aber ich habe ein kleines Problem.

Neusesten Kernel (nur wege den Sicherheitslücken....) heruntergeladen, den Kernel neu konfiguriert mit einer verbesserten .config-file, kompiliert usw.
lilo editiert und lilo ausgeführt mit dem Ergebnis:

File /etc/lilo.conf not changed so no update needed.
p15xxxx:/usr/src/linux # lilo
Fatal: open /boot/boot.b: No such file or directory

Die Schritte, die hier in dem Howto angeraten werden über Teilsicherung des /boot -verzeichnissen musste ich leider überspringen, da dieses komplett leer ist.....

kann ich jetzt nun den reboot ausführen und der neue Kernel wird gebootet , oder nicht?

gruss Christoph

PS: OS ist Suse 7.2

kase
Posts: 1031
Joined: 2002-10-14 22:56

Re: lilo fatal-Meldung bei Kernelinstallation

Post by kase »

Wenn du einen Reboot machst, ist dein Server tot, ansonsten kann ich dir aber auf die Schnelle nicht weiterhelfen.

evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

Re: lilo fatal-Meldung bei Kernelinstallation

Post by evoluzzer »

jetzt habe ich mal den neuen Kernel wieder aus der Konfiguration genommen und nochmals lilo ausgeführt (falls er mal abstürzt, das wieder der alte Kernel gebootet wird), es kommt aber wieder die selbe Fehlermeldung...

Ich vermute mal das irgendein Eintrag in der /etc/lilo.conf fehlt, könnte einer mal diese posten für einen root 1200 bei 1 & 1 mit Suse 7.2?

gruss Christoph

dea
Posts: 532
Joined: 2002-08-13 12:05

Re: lilo fatal-Meldung bei Kernelinstallation

Post by dea »

Fatal: open /boot/boot.b: No such file or directory
Das fehlt - ich hätte ja erwartet, dass Du die Fehlermeldungen auch mal durchliest und nicht nur c&p-postest :roll:

:arrow: Tip: Paket lilo (oder wo auch immer lilo drin ist) neu installieren, dann hast Du die Verzeichnisinhalte wieder ...

:arrow: Tip: 'mount' machen und schauen, ob /dev/hda1 gemountet ist. Wenn nicht, auf /boot mounten :roll:

evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

Re: lilo fatal-Meldung bei Kernelinstallation

Post by evoluzzer »

der letzte Tip war hilfreich, irgendwie ja auch logisch.....

dea
Posts: 532
Joined: 2002-08-13 12:05

Re: lilo fatal-Meldung bei Kernelinstallation

Post by dea »

evoluzzer wrote:der letzte Tip war hilfreich, irgendwie ja auch logisch.....
Auf den bin ich vor längerer Zeit auch mal reingefallen. Ich frage mich, warum 1&1 in der Standardinstallation /boot nicht in die fstab schreibt (scheint ja immer noch so zu sein) ...

Aber schön, Dir geholfen haben zu können :)

evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

Re: lilo fatal-Meldung bei Kernelinstallation

Post by evoluzzer »

Danke nochmals......

Gruss Christoph