Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 01:28

Salve!

Ich habe mir einen Rootserver von 1und1 angemietet und nun dabei ihn zu konfigurieren. Probleme macht mir hier im Moment nur Postfix.

Leider ist die FAQ bei 1und1 weder besonders ausführlich noch vollständig.

Mein Problem ist folgendes:

Der SMTP-Server spielt "toter Mann". Ã?ber einen ping gibt er antwort, mit den gängigen Kontrollen erhalte ich auch überall ein "Listen" status auf Port 25.


Zu den bisher ausgeführten Schritten:

Im 1und1 Konfigurationsmenü wurde unter "Mailserver" der MX-Eintrag auf meinen Server umgestellt.

Zusätzlich zum voreingestellten Standardmailkonto des Benutzers web1pt -> *@domainname.com habe ich ein Konto webmaster@domainname.com angelegt.

Ich habe die Konfigurationsdatei von Postfix gemaess dem FAQ-Artikel unter http://server.1und1.com/root_server/mail/2.html angepasst und ein postfix -v reload ausgeführt.

Ein anschließender Test hat ergeben, das ich wunderbar Mails abholen kann, aber keine Mails versenden kann.

Mit verschiedenen Mailprogrammen (Outlook Express, PostMe 3.5) habe ich die verschiedenen Kombinationen (ohne Authentifizierung, mit, Smtp after Pop3 etc.) ausprobiert.

Beim versenden gibt es keine direkte Fehlermeldung sondern lediglich nach geraumer Zeit die Meldung, das der SMTP-Server nicht erreichbar ist.

Interessanterweise wird beim Telnetten auf Port 25 nicht sofort eine Fehlermeldung ausgelöst sondern es passiert genau garnichts.

Ergänzenderweise noch die Information, das ich an der Datei SuSEfirewall2 in "/etc/sysconfig" folgende Ã?nderungen vorgenommen habe, von denen ich aber glaube, das sie kein Problem darstellen dürfen (zumal ich SuSEfirewall2 nicht finden kann - nur die Configdatei)
FW_DEV_EXT="eth0"
FW_SERVICES_EXT_TCP="25 http https pop3s smtp ssh"
Auch ein reboot des Servers brachte keine Besserung des Problems.

Achja...Interessanterweise erhalte ich zwar keine Fehlermeldung beim connect auf pop.domainname.com - mails die ich aber testweise über verschiedene Accounts versendet habe, kommen nicht an.

Ein Auszug aus dem Logfile:
...Jun 7 01:14:53 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 954 exit status 1
Jun 7 01:14:53 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 7 01:15:53 p15120106 postfix/smtpd[980]: fatal: open database /usr/local/etc/postfix/relaydomains.db: No such file or directory
Jun 7 01:15:54 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 980 exit status 1
Jun 7 01:15:54 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 7 01:16:54 p15120106 postfix/smtpd[988]: fatal: open database /usr/local/etc/postfix/relaydomains.db: No such file or directory
Jun 7 01:16:55 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 988 exit status 1
Jun 7 01:16:55 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 7 01:17:55 p15120106 postfix/smtpd[994]: fatal: open database /usr/local/etc/postfix/relaydomains.db: No such file or directory
Jun 7 01:17:55 p15120106 popper[993]: (null) at p508019DA.dip.t-dialin.net (80.128.25.218): -ERR POP EOF or I/O Error [popper.c:820]
Jun 7 01:17:56 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 994 exit status 1
Jun 7 01:17:56 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 7 01:18:08 p15120106 popper[1002]: Stats: web1p1 0 0 0 0 p508019DA.dip.t-dialin.net 80.128.25.218 [pop_updt.c:296]
Jun 7 01:18:56 p15120106 postfix/smtpd[1003]: fatal: open database /usr/local/etc/postfix/relaydomains.db: No such file or directory
Jun 7 01:18:57 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 1003 exit status 1
Jun 7 01:18:57 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 7 01:19:57 p15120106 postfix/smtpd[1010]: fatal: open database /usr/local/etc/postfix/relaydomains.db: No such file or directory
Jun 7 01:19:58 p15120106 postfix/master[463]: warning: process /usr/lib/postfix/smtpd pid 1010 exit status 1
Jun 7 01:19:58 p15120106 postfix/master[463]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Ich steh' hier völlig auf dem Schlauch und bin vermutlich das Opfer eigener Betriebsblindheit. 8O

Wäre super, wenn mir jemand helfen könnte.

Ich habe es zwar schon mit verschiedenen Suchanfragen hier im Forum versucht - aber entweder stelle ich die falschen Fragen oder es gibt zu genau diesem Problem hier noch nichts.

Wenn zur Lösung des Problems noch Informationen notwendig sind, liefere ich sie gerne nach.

Grüße

OxnoxO

rǃppz
Posts: 127
Joined: 2003-04-02 14:14

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by rǃppz » 2003-06-07 01:39

Guck mal ob die Datei relaydomains.db in /usr/local/etc/postfix/relaydomains.db existiert?

WEnn nicht lege eine an oder nim sie aus der config

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 01:58

Hi,

die Datei hat nicht existiert. Mittels "touch relaydomains.db" habe ich eine leere Datei mit dem Namen angelegt und Postfix neu gestartet.

Da ich keine Ahnung habe, was in die .d Datei hineingehört, habe ich keine andere Möglichkeit als sie leer zu lassen.

BTW: "telnet localhost 25" geht auch in die Hose. Es passiert genau nichts. Kein HELO, keinFehler einfach nur ein hängendes Telnet.

Grüße

OxnoxO

mstuebner
RSAC
Posts: 184
Joined: 2002-06-19 00:05
Location: 84424 Isen

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by mstuebner » 2003-06-07 09:56

oxnoxo wrote:die Datei hat nicht existiert. Mittels "touch relaydomains.db" habe ich eine leere Datei mit dem Namen angelegt und Postfix neu gestartet.
Man könnte mutig vom Namen auf die Funktion schließen, dass die Datei die Domains enthalten soll für die Relay erlaubt sein soll?

Dass bei einem telnet domain 25 Du (und nicht der Server) das EHLO domain eingeben musst weist Du aber?

mstuebner
RSAC
Posts: 184
Joined: 2002-06-19 00:05
Location: 84424 Isen

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by mstuebner » 2003-06-07 10:00

oxnoxo wrote:Ich habe die Konfigurationsdatei von Postfix gemaess dem FAQ-Artikel unter http://server.1und1.com/root_server/mail/2.html angepasst und ein postfix -v reload ausgeführt.
Du hast also obig gelinkten Artikel durchgearbeitet und weist trotzdem nicht welche Funktion /usr/local/etc/postfix/relaydomains hat? Dann hilft evtl. ein mehr maliges Nochmal-Lesen.

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 11:25

Hallo Matthias,
Man könnte mutig vom Namen auf die Funktion schließen, dass die Datei die Domains enthalten soll für die Relay erlaubt sein soll?
Nun. Vielleicht hilft es Dir weiter, wenn ich Dir die Information gebe, das ich gerne von zuhause beim Versenden von Emails meinen SMTP verwenden möchte. Zuhause besitze ich nur DSL und daher ist es realitätsfern, dort irgendwelche Hosts einzutragen. Abgesehen davon ist Deine Wortwahl etwas unglücklich. Ich habe den Eindruck das da eine Portion Sarkassmus mitschwingt - wenn das so ist, frage ich mich nach dem Grund.
Dass bei einem telnet domain 25 Du (und nicht der Server) das EHLO domain eingeben musst weist Du aber?
Natürlich weiß ich das. Es ist nicht so, das ich generell keinen Plan von SMTP, POP, TELNET, SSH und Linux habe. Ich stehe nur hier konkret bei diesem Problem auf dem Schlauch. Denn für mich ist augenscheinlich alles soweit konfiguriert.

Alles in allem Dank für Deine "Hilfe".

Grüße

OxnoxO
[/quote]

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 11:51

Salvete!


Also...Das Problem war folgendes:

Die in der 1und1-FAQ gemachten Empfehlung sind sehr restriktiv - zu restriktiv. Die folgende Zeile in der Postfix-Main.cf hat das Problem verursacht:
relay_domains = $mydestination, hash:/usr/local/etc/postfix/relaydomains
1und1 hat schlicht verpennt, in der FAQ die Auswirkungen zu nennen.

Mit folgender Einstellung funktioniert es dann (ist auch der Default-Eintrag bei Auslieferung)
relay_domains = $mydestination
Das SMTP-Problem bin ich jetzt erstmal los.

Grüße

OxnoxO

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 11:57

Nachtrag:

Das POP-Problem (Mail kommen nicht an) liegt am "*"-Account. Hat man mehrere Adressen, Postfächer etc. eingerichtet und ist über Confixx noch die Defaultadresse *@domain.tld noch angegeben, kommt nix an der eigentlichen Zieladresse an.

Einfach *@domain.tld löschen und es funzt.

Grüße

OxnoxO

mstuebner
RSAC
Posts: 184
Joined: 2002-06-19 00:05
Location: 84424 Isen

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by mstuebner » 2003-06-07 12:07

oxnoxo wrote:Abgesehen davon ist Deine Wortwahl etwas unglücklich. Ich habe den Eindruck das da eine Portion Sarkassmus mitschwingt - wenn das so ist, frage ich mich nach dem Grund.
Liegt nicht an Dir, ist einfach zu warm hier. BTW: So bin ich halt. :oops:

Aber nun hast Du es ja gefixt, congrats.

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 13:16

Hallo,

;-)


Grüße

OxnoxO

cotterley
Posts: 11
Joined: 2003-06-07 12:38

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by cotterley » 2003-06-07 15:58

Genau das Problem hatte ich auch. :) Soweit bin ich nun auch wieder. Nur bekomme ich immer noch die nette Fehlermeldung:

554 <cotterley@gmx.de>: Relay access denied

Was tun?

oxnoxo
Posts: 7
Joined: 2003-06-07 01:04

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by oxnoxo » 2003-06-07 16:49

Hallo,

folgender Eintrag in der main.cf hat mir auch noch Probleme bereitet:
smtpd_recipient_restrictions = ..., reject_maps_rbl, ...
Aus einem mir noch nicht viel näher bekannten Grund blockt er bei Einsatz dieser Zeile jeglichen Versuch meinerseits, von meinem heimischen Mailclient über meinen SMTP Mails zu versenden.

Ich habe mich letztlich dazu entschlossen, die Zeile zunächst auszukommentieren.

BTW: Wie schaut die Config Deines Mailprogramms aus?

Grüße,

OxnoxO

cotterley
Posts: 11
Joined: 2003-06-07 12:38

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by cotterley » 2003-06-07 19:55

oxnoxo wrote:Hallo,
BTW: Wie schaut die Config Deines Mailprogramms aus?
OxnoxO
Wie genau meinst du das?

domain.tld - als SMTP und POP3 eingerichtet

Username und PWD stimmen lokal auf meinem Server kann ich ja versenden, nur nicht an externe Server weiterleiten.

Ob SMTP Auth im Mail Programm an ist ist auch egal. :(

cotterley
Posts: 11
Joined: 2003-06-07 12:38

Re: Daufrage: SMTP nicht erreichbar, läuft aber [Postfix]

Post by cotterley » 2003-06-10 11:19

Komisch, wenn ich als SMTP Server smtp.puretec.de Eintrage, dann geht es. Auch nur mit SMTP Auth, sprich wenn ich falsche Daten eingebe (Benutzername o. PWD), dann geht es nicht. Ist das normal oder stimmt da ein Eintrag bei mir nicht? :?: