Update Probleme von 4.2.2 auf 4.3.2

Bash, Shell, PHP, Python, Perl, CGI
Anonymous

Update Probleme von 4.2.2 auf 4.3.2

Post by Anonymous »

Ich wollte gerade meinen 1&1 Rootserver updaten, und habe dabei ein kleines Problem. PHP nach /usr/local/src entpackt, ./configure mit den Optionen aus phpinfo aufgerufen ...
Configure Command './configure' '--prefix=/usr/share' '--datadir=/usr/share/php' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-bz2' '--with-dom=/usr/include/libxml2' '--with-ftp' '--with-gdbm' '--with-gettext' '--with-gmp' '--with-imap=yes' '--with-iodbc' '--with-jpeg-dir=/usr' '--with-ldap=yes' '--with-mcal=/usr' '--with-mcrypt' '--with-mysql=/usr' '--with-ndbm' '--with-pgsql=/usr' '--with-png-dir=/usr' '--with-qtdom=/usr/lib/qt2' '--with-snmp' '--with-t1lib' '--with-tiff-dir=/usr' '--with-ttf' '--with-freetype-dir=yes' '--with-xml' '--with-xpm-dir=/usr/X11R6' '--with-zlib=yes' '--with-gd=shared' '--with-openssl' '--with-curl' '--with-swf=./dist/' '--with-imap-ssl' '--enable-xslt' '--with-xslt-sablot' '--with-mm' '--with-apxs=/usr/sbin/apxs' 'i586-suse-linux'
Und das Script meckert über eine fehlende apxs ! Tatsächlich ist davon nichts auf dem Server zu finden.

Hat jemand ein paar Tips für mich ???

Tom
gamecrash
Posts: 339
Joined: 2002-05-27 10:52

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by gamecrash »

Hast Du vielleicht mal den Apache neu kompiliert?

mach mal

Code: Select all

updatedb
locate apxs
was da rauskommt. Das setzt Du dann bei --with-apxs ein...
nomic
Posts: 18
Joined: 2003-02-03 14:14

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by nomic »

Das gleiche Problem habe ich auch.

Jedoch kommt bei

Code: Select all

locate apxs
nur

Code: Select all

/srv/www/htdocs/manual/programs/apxs.html
raus. Bei

Code: Select all

find / -name apxs
kommt gar nichts.

edit: hab im 'configuration comman' von phpinfo(); auch folgendes stehen: '--with-apxs=/usr/sbin/apxs'
evoluzzer
Posts: 90
Joined: 2002-09-08 19:33
Location: www.internetists.de/index.php?s=14

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by evoluzzer »

Guten Morgen,

installier mal die Apache-devel in der entsprechenden Version, die du hast auf dem Server. Dann sollte es gehen.....
lafarik
Posts: 31
Joined: 2003-06-17 16:38

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by lafarik »

Hallo!

Ich habe auch versucht auf 4.3.2 zu updaten.

Das bekomme ich:

---------------------------------
checking for byacc... no
configure: warning: You will need bison if you want to regenerate the PHP parsers.
checking for flex... lex
checking for yywrap in -ll... no
checking lex output file root... ./configure: line 2356: lex: command not found
configure: error: cannot find output from lex; giving up
---------------------------------

Meine Configuration:

--------------------------------
'./configure' '--prefix=/usr/share' '--datadir=/usr/share/php' '--bindir=/usr/bin' '--libdir=/usr/share' '--includedir=/usr/include' '--with-_lib=lib' '--with-config-file-path=/etc' '--with-exec-dir=/usr/lib/php/bin' '--disable-debug' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-discard-path' '--enable-exif' '--enable-filepro' '--enable-force-cgi-redirect' '--enable-ftp' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-memory-limit' '--enable-safe-mode' '--enable-shmop' '--enable-sigchild' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-versioning' '--enable-wddx' '--enable-yp' '--with-bz2' '--with-dom=/usr/include/libxml2' '--with-ftp' '--with-gdbm' '--with-gettext' '--with-gmp' '--with-imap=yes' '--with-iodbc' '--with-jpeg-dir=/usr' '--with-ldap=yes' '--with-mcal=/usr' '--with-mcrypt' '--with-mysql=/usr' '--with-ndbm' '--with-pgsql=/usr' '--with-png-dir=/usr' '--with-qtdom=/usr/lib/qt2' '--with-snmp' '--with-t1lib' '--with-tiff-dir=/usr' '--with-ttf' '--with-freetype-dir=yes' '--with-xml' '--with-xpm-dir=/usr/X11R6' '--with-zlib=yes' '--with-gd=shared' '--with-openssl' '--with-curl' '--with-swf=./dist/' '--with-imap-ssl' '--enable-xslt' '--with-xslt-sablot' '--with-mm' '--with-apxs=/usr/sbin/apxs' 'i586-suse-linux'
-------------------------------------------

Was mache ich falsch?
kahler
Posts: 130
Joined: 2003-04-18 17:42
Location: /root

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by kahler »

Lafarik wrote:Was mache ich falsch?
Der erste Fehler ist, dass du Code nicht in die dafür vorgesehenen [.code.] Blöcke setzt...

...Dein eigentliches Problem ist aber, dass kein Flex installiert ist.
Wenn du SuSE hast, dann installier es mittels Yast, bei Debian bringt ein

Code: Select all

apt-get install flex
das gewünschte Ergebnis.
lafarik
Posts: 31
Joined: 2003-06-17 16:38

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by lafarik »

Hallo!

Danke kahler!

Das hat funktioniert. Aber jetzt kommt nächtser Fehler:

--------------------------
Configuring extensions
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
configure: error: Cannot find libz
--------------------------

Ich habe auch überprüft, ich habe zlib 1.1.4 installiert.
Wie es aussieht erkennt er wohl zlib, aber nicht sein ordner...

Was kann ich machen? :?:

Gruß,
Lafarik
jamesb
Posts: 661
Joined: 2002-05-08 15:35
Location: Karlsruhe

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by jamesb »

Du brauchst für die jeweiligen Optionen auch die -devel-Packete der Libarys.

Du hast aber noch einen "Fehler": Deine Configure-Optionen sind etwas übertrieben. Normalerweise reichen knapp 20 Optionen, und dein PHP enthält alles, was du jemals in deinem Leben brauchen wirst.

JamesB

PS: Ne schöne Auswahl für PHP 4.3.2 gibt's auf http://rootmail.de/info.php. Aber Achtung: Da läuft PHP als CGI-Binary (mit suPHP).
kase
Posts: 1031
Joined: 2002-10-14 22:56

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by kase »

JamesB, wie ich sehe, hast du einen Debian-Server und benutzt ansonsten überall die Stable Versionen von apt.

Wie hast du PHP 4.3.2 erfolgreich in diese Configuration gebraucht ? hast du PHP 4.1.2 aus Stable ebenfalls installiert ? Oder hast du 4.3.2 irgendwie als Paket geschnürrt ? Wäre über ein paar Infos sehr dankbar, ich bin bisher zwar mit der PHP 4.1.2 noch einigermaßen zurechtgekommen, aber es häufen sich doch die Probleme, die ich mit 4.3.2 NICHT hätte ;)
lafarik
Posts: 31
Joined: 2003-06-17 16:38

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by lafarik »

JamesB wrote:Aber Achtung: Da läuft PHP als CGI-Binary (mit suPHP).
Ist es viel anders als Apache? Oder was ist das genau?


Ok, mit meiner Installation bin ich auch nicht mehr weitergekommen.
Ich habe immer Programme nachinstalliert wenn es zu fehlern kamm.
Aber dieses Programm finde ich nicht:

-------------------------------
configure: error: libXpm.(a|so) not found.
-------------------------------

Bitte um Hilfe...
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by arty »

Hallo Kase,

ich hab auch PHP 4.3.2 mit suPHP mit Debian. Ich habe PHP 4.3.2 selber kompiliert und mit suPHP eingebunden. Ist eigentlich kein Problem.

bye
arty
arty
Userprojekt
Userprojekt
Posts: 729
Joined: 2002-06-12 10:11

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by arty »

Hi,
Lafarik wrote:configure: error: libXpm.(a|so) not found.
installier libxpm.

bye
arty
lafarik
Posts: 31
Joined: 2003-06-17 16:38

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by lafarik »

arty wrote: installier libxpm.
arty
Im Yast habe ich das Tool nicht gefunden. Ich habe verschiedene xpm-tools installiert aber keins war das richtige. z.B.: xpm-3.4k.KSI2-2.src.rpm

Wo kriege ich den libxpm?

Danke

Bye
konni
Posts: 151
Joined: 2002-12-16 10:05

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by konni »

tja die libxpm suche ich bei suse 8.2 auch :(

ich bin mir sicher, bei Suse 8.1 gabs da noch irgendwo das ding


ok ist in x86free-devel enthalten[[/list]
florian b
Posts: 27
Joined: 2003-01-29 12:15

benötige auch hilfe

Post by florian b »

Code: Select all

./configure --prefix=/usr/share --datadir=/usr/share/php --bindir=/usr/bin --libdir=/usr/share --includedir=/usr/include --with-_lib=lib --with-config-file-path=/etc --with-exec-dir=/usr/lib/php/bin --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --enable-inline-optimization --enable-magic-quotes --enable-mbstr-enc-trans --enable-mbstring --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --with-bz2 --with-dom=/usr/include/libxml2 --with-ftp --with-gdbm --with-gettext --with-gmp --with-imap --with-jpeg-dir=/usr --with-ldap --with-mcal=/usr --with-mcrypt --enable-yp --with-mysql=/usr --with-ndbm --with-pgsql=/usr --with-png-dir=/usr --with-snmp --with-t1lib --with-tiff-dir=/usr --with-ttf --with-freetype-dir --with-xml --with-swf=/.dist/ --with-xpm-dir=/usr/X11R6 --with-zlib --with-gd --with-openssl --with-curl --with-imap-ssl --with-mm --with-apxs=/usr/sbin/apxs i586-suse-linux
hab ich gemacht und er läuft soweit durch bis zu dem folgenden Punkt:

Code: Select all

Configuring extensions
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... yes
checking for BZip2 support... yes
checking for BZip2 in default path... found in /usr
checking for BZ2_bzerror in -lbz2... yes
checking whether to enable calendar conversion support... yes
checking for cpdflib support... no
checking for CRACKlib support... no
checking whether to enable ctype functions... yes
checking for CURL support... yes
checking for CURL in default path... found in /usr
checking for cURL 7.9.8 or greater... libcurl 7.9.8
checking for curl_easy_perform in -lcurl... yes
checking for curl_version_info in -lcurl... no
checking for cyrus imap support... no
checking for xDBM support... no
checking whether to enable DBA... no
...
configure: error: cannot find necessary header file(s)

Code: Select all

...
prompt:/usr/local/src/php-4.3.2 #
hat da jemand ne idee für mich?
bravesurfer
Posts: 170
Joined: 2003-05-08 12:17
Location: Stuttgart

Re: Update Probleme von 4.2.2 auf 4.3.2

Post by bravesurfer »

genau vor dem selben Problem stehe ich im Moment auch
checking whether to enable DBA... no
configure: error: cannot find necessary header file(s)
Kann niemand helfen?

Mfg

M. Clemenz