qmail relaying denied

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
Anonymous

qmail relaying denied

Post by Anonymous » 2003-05-30 01:26

Hallöle

Ich habe heute qmail und alles bis auf den Imap Server nach dem

Qmail und vpopmail auf Debian HOWTO

auf debianhowto.de Installiert.

Jetzt bieten sich mir aber ein paar Probleme, warum auch immer :(
Als da wäre zunächst mal das vqadmin keine Domains und überhaupt eigentlich nichts machen kann, denn überall gibts denied und fehler hoch 3. Beim erstellen einer domain gibts sogar nen Internal Server Error :(

Also habe ich die Domains manuell mit vadddomain erstellt... das emails empfangen geht bei allen domains, bis auf die eigentliche die auch der hostname vom server ist (syn-x.net)

Die Konten habe ich dann mit qMailAdmin erstellt.

Naja und mein Hauptproblem ist zur Zeit, dass ich keine Mails versenden darf, bis auf die domains, die ich auch als virtuelle habe :(

!30.05.2003, 01:15:24: SEND - Nachricht wurde nicht versandt. Server Antwort - sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)


Wie gesagt ich habe alles nach dem Howto gemacht, lediglich den cgi Pfad habe ich anders.


Kann mir jemand bei dem ein oder andrem Problem helfen? Ich bin Ratlos.


mfg

Lucas Pleß

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: qmail relaying denied

Post by floschi » 2003-05-30 10:23

xleave wrote:Als da wäre zunächst mal das vqadmin keine Domains und überhaupt eigentlich nichts machen kann, denn überall gibts denied und fehler hoch 3. Beim erstellen einer domain gibts sogar nen Internal Server Error
Das sieht eher nach einem Problem mit cgis bei deinem Apache aus...
xleave wrote:Also habe ich die Domains manuell mit vadddomain erstellt... das emails empfangen geht bei allen domains, bis auf die eigentliche die auch der hostname vom server ist (syn-x.net)
Ja, klar. Diese Domain wird als lokal eingetragen und daher nicht von vpopmail behandelt. Ich habe in den Dateien locals, me, defaultdomain (alle in /etc/qmail) nur den pxxx.pureserver.info drin, die eigentliche Serverdomain ist eine virtuelle. Dann geht'S auch ;)
xleave wrote:Die Konten habe ich dann mit qMailAdmin erstellt.

Naja und mein Hauptproblem ist zur Zeit, dass ich keine Mails versenden darf, bis auf die domains, die ich auch als virtuelle habe :(
Siehe oben...
xleave wrote:!30.05.2003, 01:15:24: SEND - Nachricht wurde nicht versandt. Server Antwort - sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
Du hast aber schon SMTP AUTH auch beim Client eingestellt? Ansonsten: was steh denn in deiner /etc/qmail/rcpthosts ?


Grüßle

Olfi ;)

Anonymous

Re: qmail relaying denied

Post by Anonymous » 2003-05-30 10:51

Ok das mit der Lokalen Domain habe ich gelöst, eigene Doofheit :)
Das sieht eher nach einem Problem mit cgis bei deinem Apache aus...
Ja sicher bin ich mir nicht, aber es wird ja zum Teil richtig ausgeführt und auch ausgegeben. Ist aber auch ersteinmal nicht so wichtig.

Du hast aber schon SMTP AUTH auch beim Client eingestellt? Ansonsten: was steh denn in deiner /etc/qmail/rcpthosts ?
Ja ich habe auch SMTP Auth eingestellt. Folgendes im Syslog

May 30 10:41:03 syn-x vpopmail[9864]: vchkpw: vpopmail user not found xleave@xleave.de:80.130.69.247

Und in der rcpthosts stehen meine domains:

Code: Select all

localhost
syn-x.net
xleave.de
twins2002.net

Komisch ists ja schon.. denn :

Code: Select all

p15113686:/opt/vpopmail/bin# ./vadduser xleave@xleave.de
Please enter password for xleave@xleave.de:
enter password again:
Error: Username exists
Muss ich den user auch noch irgendwo in vchkpw eintragen oder macht der das normalerweise von selber ?

Anonymous

Re: qmail relaying denied

Post by Anonymous » 2003-05-30 20:11

arghs man ey


soweit gehts ansich jetzt .. aber nur mir Outlook und nicht mit thebat .. warum ? ey das ist doch lol .. ich habe authetifizierung doch eingaschaltet und zig mal überprüft ...

outlook:

Code: Select all

May 30 20:10:51 syn-x qmail: 1054318251.794814 new msg 3064049
May 30 20:10:51 syn-x qmail: 1054318251.795781 info msg 3064049: bytes 1305 from <xleave@xleave.de> qp 2923 uid 64011
May 30 20:10:51 syn-x qmail: 1054318251.851190 starting delivery 15: msg 3064049 to remote xleave@gmx.de
May 30 20:10:51 syn-x qmail: 1054318251.851343 status: local 0/10 remote 1/20
May 30 20:10:52 syn-x qmail: 1054318252.180986 delivery 15: success: 213.165.64.100_accepted_message./Remote_host_said:_250_{mx003}_Message_accepted/
May 30 20:10:52 syn-x qmail: 1054318252.181376 status: local 0/10 remote 0/20
May 30 20:10:52 syn-x qmail: 1054318252.181425 end msg 3064049
TheBat:

Code: Select all

May 30 20:11:27 syn-x vpopmail[2928]: vchkpw: password fail xleave@xleave.de:217.83.85.27
und folgendes in thebat

Code: Select all

*30.05.2003, 20:14:56: SEND  - Sende Nachricht(en) - 1 Nachricht(en) in der Warteschlange
+30.05.2003, 20:14:56: SEND  - verbunden mit dem SMTP Server
*30.05.2003, 20:15:01: SEND  - WARNUNG: Authentifikation fehlgeschlagen
*30.05.2003, 20:15:01: SEND  - Sende Nachricht an xleave@gmx.de
*30.05.2003, 20:15:01: SEND  - Die letzte Versandadresse war <xleave@gmx.de>
!30.05.2003, 20:15:01: SEND  - Nachricht wurde nicht versandt. Server Antwort - sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
+30.05.2003, 20:15:01: SEND  - Verbindung beendet - 0 von 1 Nachricht(en) versandt
?30.05.2003, 20:15:01: SEND  - Einige Nachrichten wurden nicht versendet - prüfen Sie die Logdatei nach Informationen
warum ist bei outlook eigentlich kein vpopmail im spiel ? *grummel*

Anonymous

Re: qmail relaying denied

Post by Anonymous » 2003-06-02 18:32

Naja es scheint ja niemand anderen mehr zu interessieren, aber der vollständigkeit halber noch eine kleine Antwort.

Ich habe noch mal die logs durchgeschaut und auch mal qmail gesprächig gestellt. Dann kam raus, dass meine Version 1.53 noch kein CRAM-MD5 kennt und wahrscheinlich bug bedingt auch nicht auf PLAIN stellt.

Die neue Version 1.63r Versucht bei mir zunächst CRAM-MD5 was dann fehlschlägt ( 02.06.2003, 18:30:28: SEND - Server meldet Fehler. Die Antwort ist: authorization failed (#5.7.0) ) aber macht dann unverschlüsselt weiter.

so far

Lucas