insallation von DBD::mysql

Bash, Shell, PHP, Python, Perl, CGI
tobias111
Posts: 78
Joined: 2002-12-02 20:19

insallation von DBD::mysql

Post by tobias111 »

hallo leute,
obiges modul brauche ich für ein mysql-backup-skript. beim installieren mit webmin kriege ich das als output für die fehlgeschlagene installation:

viel blabla, dann..

Running Mkbootstrap for DBD::mysql ()
chmod 644 mysql.bs
rm -f blib/arch/auto/DBD/mysql/mysql.so
LD_RUN_PATH="/usr/lib/mysql:/lib" /usr/bin/perl myld cc -shared dbdimp.o mysql.o -o blib/arch/auto
/DBD/mysql/mysql.so -L/usr/lib/mysql -lmysqlclient -lz -lcrypt -lnsl -lm
/usr/lib/gcc-lib/i486-suse-linux/3.2/../../../../i486-suse-linux/bin/ld: cannot find -lz
collect2: ld returned 1 exit status


An error occurred while linking the DBD::mysql driver. The error
message seems to indicate that you don't have a libz.a, libgz.a,
libz.so or libgz.so. This is typically resolved by:

1.) You may try to remove the -lz or -lgz flag from the libs list
by using the --libs switch for "perl Makefile.PL".
2.) On Red Hat Linux install libz-devel
3.) On other systems, please contact the mailing list

Msql-Mysql-modules@lists.mysql.com

For further hints, see INSTALL.html, section Linker flags.
make: *** [blib/arch/auto/DBD/mysql/mysql.so] Error 1

welche libary fehlt mir da bei suse?

dnakeschön!
to
jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: insallation von DBD::mysql

Post by jtb »

steht doch drin:
The error message seems to indicate that you don't have a libz.a, libz.so
tobias111
Posts: 78
Joined: 2002-12-02 20:19

Re: insallation von DBD::mysql

Post by tobias111 »

hallo jtb,
ja, das hab ich schon gesehen. allerdings finde ich keine libz.a und libz.so, wenn ich nach paketen (und paketbeschreibungen) im yast2 suche. das einzige vorkommen ist bei einer gnome-libary, aber das wird das wohl nicht sein. kannst du mir den paketnamen nennen, den ich installieren muss?

danke schonmal für die hilfe!
to
tobias111
Posts: 78
Joined: 2002-12-02 20:19

Re: insallation von DBD::mysql

Post by tobias111 »

stopp, das gehört zur zlib, aber die hab ich installiert..