PostFix leitet alle Mails an das gleiche Postfach

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
irnbru
Posts: 31
Joined: 2003-05-19 11:50

PostFix leitet alle Mails an das gleiche Postfach

Post by irnbru » 2003-05-19 12:04

Hallo,

ich kann mir das nicht mehr erklären. Ich benutze PostFix mit Confixx 2.0 pro. Ich kann Postfächer abrufen und Mails verschicken, alle Mails, die an eine Adresse geschickt werden für die der MTA zuständig ist landen im selben Postfach und zwar in web1p1, das erste Postfach von Confixx also.

Hier die confixx_virtualUsers:

Code: Select all

soki@xxx.de web3p1
master@xxx.de web3p1
webmaster@xxx.de web3p1
info@xxx.de web3p1
puntus@xxx.de web3p2
chosen_one@xxx.de web3p3
bru@xxx.de web3p4
Ein Eintrag wie info@hauptdomain.de web1p1 ändert nichts an der Tatsache. Mir scheint es so, als wenn PostFix den Empfänger umschreibt.
Hier ein Auszug aus dem Log:

Code: Select all

May 19 11:48:05 p15131187 postfix/smtpd[30599]: connect from p5087A841.dip0.t-ipconnect.de[80.135.168.65]
May 19 11:48:06 p15131187 smtpd[30599]: 4B48B1180AE: client=p5087A841.dip0.t-ipconnect.de[80.135.168.65], sasl_method=LOGIN, sasl_username=web3p4
May 19 11:48:06 p15131187 postfix/cleanup[30600]: 4B48B1180AE: message-id=<005201c31deb$dc9a0fb0$01000001@bru>
May 19 11:48:06 p15131187 postfix/qmgr[30597]: 4B48B1180AE: from=<web3p4@squad-clan.de>, size=1370, nrcpt=1 (queue active)
May 19 11:48:06 p15131187 smtpd[30599]: disconnect from p5087A841.dip0.t-ipconnect.de[80.135.168.65]
May 19 11:48:06 p15131187 postfix/local[30602]: 4B48B1180AE: to=<web3p1@hauptdomain.de>, relay=local, delay=0, status=sent (mailbox)
Hier sollte folgendes passiert sein: User web3p4 schickt mail an User web3p1, allerdings geht die Mail an web1p1 !??

Dann noch meine main.cf:

Code: Select all

alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
default_privs = autoresp
fast_flush_domains = $relay_domains
in_flow_delay = 0
inet_interfaces = all
local_recipient_maps = $alias_maps unix:passwd.byname
mail_owner = postfix
mail_spool_directory = /var/mail
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, $mydomain, smtp.$mydomain
mydomain = brutex.info
myhostname = p15131187.pureserver.info
mynetworks_style = host
myorigin = $mydomain
newaliases_path = /usr/sbin/sendmail
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
sample_directory = /usr/share/doc/packages/postfix/samples
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtpd_banner = $myhostname ESMTP $mail_name
smtpd_client_restrictions = 
smtpd_recipient_restrictions = permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/cert.pem
smtpd_tls_key_file = /etc/postfix/key.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = no
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
virtual_maps = hash:/etc/postfix/virtual, hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains
Mir wäre es schon recht, wenn hier mal aufgeräumt würde und "überflüssige" Parameter rausfliegen würden. Soll: SASL und sonst nix.

Ich hoffe jemand hat einen Rat.
Ich habe noch da hier gefunden:
http://www.rootforum.org/forum/viewtopic.php?t=8724 und noch zwei ähnliche Vorfälle. Zu einer konkreten Lösung ist es bisher noch nicht gekommen.

Gruß und Danke,
Bru

irnbru
Posts: 31
Joined: 2003-05-19 11:50

Re: PostFix leitet alle Mails an das gleiche Postfach

Post by irnbru » 2003-05-19 13:50

Hallo,

ich konnte den Fehler weiter eingrenzen:

Postfix "ersetzt" die virtuelle Domain beim Empfänger immer mit dem mydomain Parameter.

Also mai an web3p100@virtual.de landet bei web3p100@mydomain.
Ja ich habe die Dokumentation bezüglich Masquerading gelesen und einiges rumprobiert, leider kriege ich das Verhalten nicht abgestellt.

Wo habe ich was übersehen?

Danke,
Bru