Probleme mit IAM Installation

Bash, Shell, PHP, Python, Perl, CGI
cyberage
Posts: 20
Joined: 2003-03-21 22:39

Probleme mit IAM Installation

Post by cyberage »

Hallo,
seit kurzem habe ich einen eigenen Root Server. Nun habe ich versucht anhand der FAQ IAM zu installieren. Jedoch bekomme ich immer eine Fehlermeldung wenn ich das /etc/init.d/iptables start script ausführen möchte:
bad interpreter: no such file or directory
Ich denke, das es ein Fehler im Script ist, aber ich habe keinen entdekt... Es kann ja eigentlich nur dort ein sich ein Fehler eingeschlichen haben, wo ich Ã?nderungen vorgenommen habe. Anbei mal den part, vielleicht kann mir ja mal jemand einen tipp geben ..
#! /bin/sh
#
# chkconfig: 2345 08 92
# description: iptables ip accounting

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
NAME=iptables
DESC="iptables ip accounting"

DUMPFILE=/usr/local/iam/dump

#set -x

extif=eth0
extip=217.xxx.xxx.xx
intif=lo
intnet=195.20.224.72
Vielen Dank,
cu cy
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Probleme mit IAM Installation

Post by captaincrunch »

Hast du Copy and paste gemacht ? ansonsten schau mal, ob in der ersten Zeile ein Leerzeichen zwischen dem ! und dem / ist.

Btw. : Ich verschiebe mal ins Scripting.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc
cyberage
Posts: 20
Joined: 2003-03-21 22:39

Re: Probleme mit IAM Installation

Post by cyberage »

@CaptainCrunch
Also es war ein Leerzeichen drin .... Habe es korrigiert, nun jetzt bekomme ich eine andere Fehlermeldung:
Bad argument 'start'
Ich frage mich was das jetzt soll ....

Danke für den Tipp...

CY CY
captaincrunch
Userprojekt
Userprojekt
Posts: 7066
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Probleme mit IAM Installation

Post by captaincrunch »

An der Stelle kann ich nur vermuten, da ich mich mit IAM noch nie befasst habe. Ich rate daher mal, dass das Script gar kein "start"-Argument erwartet, was allerdings komisch wäre, wenn es ein init-Script sein soll.

Poste doch einfach mal einen Link auf das Script, da sieht man dann mehr.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc