relayprb. NUR in SquirrelM. vom Client aus gehts :(

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
quasan
Posts: 13
Joined: 2003-05-07 18:07

relayprb. NUR in SquirrelM. vom Client aus gehts :(

Post by quasan » 2003-05-11 06:23

Mein Problem steht eigentlich schon im Topic.

Ich kann von einem EmailClient aus wunderbar Mails verschicken, nur von Squirrelmail aus kommt der typische relay fehler
Server antwortete: 554 <ralf@quasan.de>: Relay access denied
da es über normale emailclients geht, muss es ja logischerweise? an Squirrel liegen.
hier mal meine conf.php (ohne den themekrams etc)

$org_name = "SchwarzeKlinge";
$org_logo = SM_PATH . 'images/sm_logo.png';
$org_logo_width = '308';
$org_logo_height = '111';
$org_title = "SquirrelMail $version";
$signout_page = '';
$frame_top = '_top';

$provider_uri = 'http://www.schwarze-klinge.de';

$provider_name = 'SchwarzeKlinge';

$motd = "";

$squirrelmail_default_language = 'en_US';

$domain = 'schwarze-klinge.de';
$imapServerAddress = 'localhost';
$imapPort = 143;
$useSendmail = false;
$smtpServerAddress = 'localhost';
$smtpPort = 25;
$sendmail_path = '/usr/sbin/sendmail';
$pop_before_smtp = false;
$imap_server_type = 'cyrus';
$invert_time = false;
$optional_delimiter = 'detect';
das interessante ist wohl dieses hier:
$smtp_auth_mech = 'none';
$imap_auth_mech = 'login';
$use_imap_tls = false;
$use_smtp_tls = false;
$session_name = 'SQMSESSID';
das problem ist wenn ich smtp_tls auf true setze passiert gar nix mehr mit squirrel. muss dann den smtpd prozess abschießen, damit überhaupt was geht

pop vor smtp hab ich auch getestet bringt nix

sendmail auf true setzen > mails kommen nicht an :(

evtl weiß ja jemand rat

User avatar
nyxus
RSAC
Posts: 697
Joined: 2002-09-13 08:41
Location: Lübeck

Re: relayprb. NUR in SquirrelM. vom Client aus gehts :(

Post by nyxus » 2003-05-11 08:17

Kann ohne weiteres auch am SMTP-Server liegen. Wenn Du Postfix hast könnte es ein falscher mynetworks-Parameter in der main.cf sein.


Gruß, Nyx

mark
Posts: 295
Joined: 2003-04-15 16:48
Location: Oldenburg

Re: relayprb. NUR in SquirrelM. vom Client aus gehts :(

Post by mark » 2003-05-11 21:37

Hi,

Füge 127.0.0.1 zu "mynetworks" hinzu und smtpd_recepient_restrictions muss permit_mynetworks beinhalten.

oder:

ändere

Code: Select all

$useSendmail = true; 
Das hattest du probiert, aber das müsste funktionieren.

Ansonsten zeig uns bitte deine Logs (/var/log/mail) und einen postconf -n (kannste ja deine ips / domains erstmal rausstrippen, wenns sein muss).

Gruß
mark