Spamassassin macht nichts

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
velo
Posts: 111
Joined: 2003-01-11 02:51

Spamassassin macht nichts

Post by velo » 2003-04-22 00:46

Hallo,

habe nun zum Kampf gegen Spam so einiges gelesen und installiert und mitlerweise geht auch procmail. Mit Spamassassin habe ich jedoch Schwierigkeiten, weil er scheinbar nichts macht.

Er kennzeichnet nie etwas (rewrite_subject 1) und im Header steht auch nie etwas drin.

Zunächst würde ich gerne global Einstellungen definieren (Ich weiss auch nicht, ob das sonst mit den Virtuellen Mailboxen durch Confixx so einfach geht, ein ~/.spamassassin file anzuwenden) ... und versuche es somit in /etc/mail/spamassassin/local.cf

In der /etc/procmailrc steht folgendes:

Code: Select all

:0fw
| spamc


:0 H:
* ^Subject.* Viagra .*
/dev/null
rcspamd wurde gestartet.
Das Beispiel mit dem "Viagra" geht, also die Mails mit diesem Subject landen im nichts. Damit würde ich davon ausgehen, dass auch spamc angesprochen wird. Jedoch bleiben die Mails unverändert.

Mir ist noch aufgefallen, dass ich durch spamc auch was pipen kann, wenn der spamd-deamon garnicht läuft. (?)

Als Beispielmail nahm ich mal die "sample-spam.txt" her und schickte mir selbst was zu.

Was muss ich denn tun, damit spamassassin was tut?

danke!

---
Nachtrag: Ein..

Code: Select all

spamassassin -t < sample-spam.txt    | less
..geht übigens! (?) .. wird richtig gekennzeichnet!

Und nun habe ich noch ein kleines selbstgemachtes Programm eingebunden, dass testweise einfach ein Wort durch ein anderes ersetzt, und das geh auch!

User avatar
nyxus
RSAC
Posts: 697
Joined: 2002-09-13 08:41
Location: Lübeck

Re: Spamassassin macht nichts

Post by nyxus » 2003-04-22 07:38

steht denn irgendwas im Logfile? Bei mir verewigt sich Spamassassin in der mail.log für jede e-mail.

Code: Select all

Apr 22 06:38:10 mail spamd[21000]: connection from localhost [ 127.0.0.1 ] at port 48238
Apr 22 06:38:10 mail spamd[29512]: clean message (3.2/5.0) for nyx:1008 in   0 seconds.

Apr 22 07:23:34 mail spamd[21000]: connection from localhost [ 127.0.0.1 ] at port 48240
Apr 22 07:23:35 mail spamd[29551]: identified spam (12.8/5.0) for nyx:1008 in   1 seconds.

Gruß, Nyx

velo
Posts: 111
Joined: 2003-01-11 02:51

Re: Spamassassin macht nichts

Post by velo » 2003-04-22 09:24

Da steht wirklich was:

Code: Select all

Apr 22 09:21:33 p15113597 spamd[21882]: connection from localhost.localdomain [ 127.0.0.1 ] at port 54707 
Apr 22 09:21:33 p15113597 spamd[1925]: info: setuid to alpha2p1 succeeded 
Apr 22 09:21:33 p15113597 spamd[1925]: Creating default_prefs [/XnirvanaX/.spamassassin/user_prefs] 
Apr 22 09:21:33 p15113597 smtpd[1844]: disconnect from pD9E93871.dip.t-dialin.net[217.233.56.113]
Wieso filtert er dann nicht. Was sendet Ihr an euch selbst, um das zu testen. Mit welchen Einstellungen MUSS er was filtern?

thx

ps: wie kann man bei den virtuellen mailboxen von confixx, eigene einstellungen pro spamassassin machen...geht das überhaupt?

velo
Posts: 111
Joined: 2003-01-11 02:51

Re: Spamassassin macht nichts

Post by velo » 2003-04-23 02:17

Unklar ist mir, warum ein

Code: Select all

cat sample-spam.txt | /usr/bin/spamc | less
nicht zu einem positiven Ergebnis führt?

velo
Posts: 111
Joined: 2003-01-11 02:51

Re: Spamassassin macht nichts

Post by velo » 2003-04-29 14:38

Jetzt habe ich das Problem endlich gefunden:

Wenn man das RPM von spamassassin installiert (SuSE), dann wird ja der Deamon mit "rcspamd start" gestartet. Und dabei werden an den eigentlichen daemon "spamd" Parameter übergeben, die in folgender Datei eingestellt sind:

Code: Select all

/etc/sysconfig/spamd
Ich weiss nocht nicht, welche Einstellungen sinnvoll sind, aber wenn man die Einstellungen einfach mal auskommentiert, dann geht der Filter.