Sendmail .. nix geht mehr

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
exberliner
Posts: 13
Joined: 2003-04-13 20:57

Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 00:33

hallo,

ich bekomme seit ca. 2 wochen immer meldungen wie z.b.

Apr 18 23:15:12 serverxxx sendmail[21122]: h3ILFCC21119: to=name@provider.net, ctladdr=wwwrun (30/65534), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=120528, relay=mx0.gmx.net. [213.165.64.100], dsn=5.1.3, stat=User unknown

der user ist aber definitiv NICHT "unknown". eigentlich kann man sagen dass sendmail gar nicht mehr korrekt arbeitet. jedenfalls ist mein varlogmail voll davon. ich habe seit wochen keine änderung gemacht.

kann mir jmd. hinweise geben ? (ich kenn mich hier leider nicht aus)
vielen dank im voraus.

ExBerliner
-Alles wird gut-

Anonymous

Re: Sendmail .. nix geht mehr

Post by Anonymous » 2003-04-19 10:19

Schau mal was sendmail -bv zu dem user sagt.

Hast Du postfix durch sendmail ersetzt?
Laeuft confixx auf der Kiste?

Karlo

exberliner
Posts: 13
Joined: 2003-04-13 20:57

Re: Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 11:01

Karlo wrote:Schau mal was sendmail -bv zu dem user sagt.

Hast Du postfix durch sendmail ersetzt?
Laeuft confixx auf der Kiste?

Karlo
hallo karlo,
unter dem user root gibt mir sendmail -bv die meldung : Recipient names must be specified

ich habe kein postfix installiert.
ja, ich habe confixx pro 1.6.5. (nicht schon wieder das confixx *g*). ich hatte mit dem confixx mal einen kunden testweise angelegt, ich weiss nicht mehr, ob damit zeitgleich mein sendmail-problem auftrat.

ich arbeite mit dem sendmail aus einem board heraus und aus einem backupcgi-script. (btw.cgi von coder-world http://www.coder-world.de/cgi-bin/cgi/i ... bdesignbtw
. demnach müsste es unter wwwrun laufen ?
es hatte bisher alles wunderbar funktioniert.

wo kann ich denn bitte was kontrollieren ?

danke und gruss ExBerliner

Anonymous

Re: Sendmail .. nix geht mehr

Post by Anonymous » 2003-04-19 11:18

sendmail -bv <mailadresse> als root

und confixx ist trotzdem an allem Schuld :-))

Wenn Du nen user neu anlegst baut confixx in /etc/mail einige files neu.

Schau mal in /var/log/mail ob da mehr steht

Karlo

exberliner
Posts: 13
Joined: 2003-04-13 20:57

Re: Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 12:57

Karlo wrote:sendmail -bv <mailadresse> als root

und confixx ist trotzdem an allem Schuld :-))

Wenn Du nen user neu anlegst baut confixx in /etc/mail einige files neu.

Schau mal in /var/log/mail ob da mehr steht

Karlo
hallo karlo,
bei sendmail -bv name@provider.net kommt die meldung :
name@provider.net... deliverable: mailer esmtp, host provider.net., user name@provider.net
(die mailaddis habe ich mal geändert)

in /var/log/mail habe ich hierzu keinen eintrag. aber schon wieder nichtgesendete aus dem board :
Apr 19 12:18:48 serverxxx sendmail[3153]: h3H70Mo25721: to=name@freenet.de, ctladdr=wwwrun (30/65534), delay=2+03:18:26, xdelay=00:00:01, mailer=esmtp, pri=9390242, relay=mx.freenet.de. [194.97.55.148], dsn=4.0.0, stat=Deferred: Name server: mx.freenet.de.: host name lookup failure
Apr 19 12:18:48 serverxxx sendmail[3153]: h3H6nHR25399: to=name@freenet.de, ctladdr=wwwrun (30/65534), delay=2+03:29:31, xdelay=00:00:00, mailer=esmtp, pri=9390479, relay=mx.freenet.de. [194.97.55.148], dsn=4.0.0, stat=Deferred: Name server: mx.freenet.de.: host name lookup failure
Apr 19 12:48:47 serverxxx sendmail[3601]: h3H70Mo25721: to=name@freenet.de, ctladdr=wwwrun (30/65534), delay=2+03:48:25, xdelay=00:00:00, mailer=esmtp, pri=9480242, relay=mx.freenet.de., dsn=4.0.0, stat=Deferred
Apr 19 12:48:47 serverxxx sendmail[3601]: h3H6nHR25399: to=name@freenet.de, ctladdr=wwwrun (30/65534), delay=2+03:59:30, xdelay=00:00:00, mailer=esmtp, pri=9480479, relay=mx.freenet.de., dsn=4.0.0, stat=Deferred

karlo, ich find das klasse, dass du geduld mit mir hast :-) merci.
geht da was zu machen ?
gruss ExBerliner

Anonymous

Re: Sendmail .. nix geht mehr

Post by Anonymous » 2003-04-19 13:21

Die sind nur Deferred, das ist noch nix boeses.
was bringt ein nslookup auf den smarthost mx.sowieso?

Warum sendest Du ueberhaupt ueber nen smarthost?

Karlo

exberliner
Posts: 13
Joined: 2003-04-13 20:57

Re: Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 15:06

Karlo wrote:Die sind nur Deferred, das ist noch nix boeses.
was bringt ein nslookup auf den smarthost mx.sowieso?
Karlo
nslookup mx.freenet.de
Note: nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead. Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
Name: mx.freenet.de
Address: 194.97.50.136
Name: mx.freenet.de
Address: 194.97.50.138
Name: mx.freenet.de
Address: 194.97.50.144
Name: mx.freenet.de
Address: 194.97.55.147
Name: mx.freenet.de
Address: 194.97.55.148
Name: mx.freenet.de
Address: 194.97.50.135
--------------
nslookup mx0.gmx.net
Note: nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead. Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server: 127.0.0.1
Address: 127.0.0.1#53

Non-authoritative answer:
Name: mx0.gmx.net
Address: 213.165.64.100

also das sieht wohl korrekt aus ?
Karlo wrote:Warum sendest Du ueberhaupt ueber nen smarthost?

Karlo
eigentlich benutze ich nur bestehende resourcen. und es hat ja sonst alles gefunzt, bis ich wohl mit confixx einen testkunden angelegt habe. ich denke mit der confixx pro 1.6.5 werden z.b. die passwd und shadow nicht mehr übergebügelt ? jedenfalls habe ich das so festgestellt und auch in anderen boards gelesen.

gruss ExBerliner
-Alles wird gut- (werd ich mir wohl bald abschminken können. lol)

Anonymous

Re: Sendmail .. nix geht mehr

Post by Anonymous » 2003-04-19 15:28

Das sieht gut aus, stimmt. Du hast nen eigenen Nameserver laufen, kann es sein, dass die Kiste manchmal sehr belastet ist und deswegen timeouts kommen?

Probier das mal:
/etc/sendmail.cf
#O Timeout.resolver.retrans=5s
aus 5s 20s machen
#O Timeout.resolver.retry=4
aus 4 8 machen

und den # weg, sorry, vergessen

Dann sendmail neu starten und beten.

Noch ein Test:

sendmail -q darf keine Fehler ausgeben.
Dauert aber einige Zeit bis er fertig ist.

Karlo

exberliner
Posts: 13
Joined: 2003-04-13 20:57

Re: Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 17:46

Karlo wrote:Das sieht gut aus, stimmt. Du hast nen eigenen Nameserver laufen, kann es sein, dass die Kiste manchmal sehr belastet ist und deswegen timeouts kommen?

Probier das mal:
/etc/sendmail.cf
#O Timeout.resolver.retrans=5s
aus 5s 20s machen
#O Timeout.resolver.retry=4
aus 4 8 machen

und den # weg, sorry, vergessen

Dann sendmail neu starten und beten.

Noch ein Test:

sendmail -q darf keine Fehler ausgeben.
Dauert aber einige Zeit bis er fertig ist.

Karlo
hallo karlo,
also meine kiste ist selten sehr belastet.
habe die sendmail.cf trotzdem modifiziert, dann einen reboot des servers durchgeführt (war eh mal wieder fällig). sendmail -q ging recht flott und hat keine fehler ausgegeben.

habe dann einen test durchgeführt. leider besteht das problem noch.
Apr 19 17:58:36 serverxxx sendmail[1398]: h3JFwYm01395: to=name@provider.net, ctladdr=wwwrun (30/65534), delay=00:00:02, xdelay=00:00:01, mailer=esmtp, pri=120527, relay=mx0.gmx.net. [213.165.64.100], dsn=5.1.3, stat=User unknown
Apr 19 17:58:36 serverxxx sendmail[1398]: h3JFwYm01395: h3JFwal01398: DSN: User unknown

hmm, ggf. noch einen hinweis ?
danke im voraus. ExBerliner

exberliner
Posts: 13
Joined: 2003-04-13 20:57

Sendmail .. nix geht mehr

Post by exberliner » 2003-04-19 17:54

vielleicht noch einen hinweis. ich bekomme vom server folgende mails wegen der nicht zugestellten:
Reporting-MTA: dns; serverxxx.server.de
Arrival-Date: Sat, 19 Apr 2003 17:58:34 +0200

Final-Recipient: RFC822; name@provider.net
Action: failed
Status: 5.1.3
Remote-MTA: DNS; mx0.gmx.net
Diagnostic-Code: SMTP; 553 {mx001-rz3} Sorry, your envelope sender has been denied
Last-Attempt-Date: Sat, 19 Apr 2003 17:58:36 +0200

sowie :
The original message was received at Sat, 19 Apr 2003 17:58:34 +0200 from wwwrun@localhost

----- The following addresses had permanent fatal errors ----- name@provider.net
(reason: 553 {mx001-rz3} Sorry, your envelope sender has been denied)

----- Transcript of session follows -----
... while talking to mx0.gmx.net.:
>>> RCPT To:<name@provider.net>
<<< 553 {mx001-rz3} Sorry, your envelope sender has been denied 550 5.1.1 name@provider.net... User unknown

eigenartigerweise bekomme ich die mails vom postmaster bzw. wwwrun an die adresse, an die er via sendmail nicht senden kann. ich raff das nicht :-(

gruss ExBerliner

Anonymous

Re: Sendmail .. nix geht mehr

Post by Anonymous » 2003-04-19 18:41

your envelope sender has been denied

die Fehlermeldung hab ich noch nie gesehen. Und ich kaempfe schon einige Jahre erfolgreich gegen Sendmail.

Hau das doch mal in google

Den envelope findest Du nur in /var/log/mail

Was koennt ich jetzt schon verdient haben wenn Du ************ gefunden haettest. :-)

Karlo

[EDIT von Fritz - Karlo noch 1 Werbung für Deine kostenpflichtigen Admin-Hilfsdienste, und Du bekommt eine Sperrung - Fritz 18.5.2003]