Nameserver geht einfach net

Bind, PowerDNS
tux
Posts: 23
Joined: 2003-04-01 08:08

Nameserver geht einfach net

Post by tux » 2003-04-01 08:15

Hmmm ....
Ich krieg es irgendwie net hin Bind9 zum laufen zu bringen .. ich mein ich hab alles gemacht.

Code: Select all

./configure
make
make install
Dann habe ich in "/etc/named" die datein

named.conf
named.ca
localhost.zone
&
die domainfiles

angepasst. Aber ich kann ihn net starten. Wenn ich in "/etc/init.d/"

Code: Select all

./named start
ausführe kommt nur :

Code: Select all

[root@DNS-Server init.d]# ./named start
Starting named:                                            [[color=red]FAILED[/color]]
[root@DNS-Server init.d]#
und wenn ich "rndc" starten will kommt bei jedem command :

Code: Select all

rndc: connect failed: connection refused
Was kann cih tun ? Wäre einer hier bereit für mich den nameserver zu instalieren so das ich imme rnur neue zonefiles und config hochladen brauch und restarten ?

Oder kann mir einer sagen was ich falsch gemacht habe ? :?:

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Nameserver geht einfach net

Post by captaincrunch » 2003-04-01 08:18

Oder kann mir einer sagen was ich falsch gemacht habe ?
Warum hast du nicht ganz simpel das Bind-Paket deiner Distri genommen ?
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 08:22

hmmm .. ich hab Red Hat LINUX 7.3 drauf.
Aber ich hab bisher immer mit SuSE gearbeitet .. weiß net wie ich den bei RedHat einrichte und starte.. es ist keine grafische oberfläche installiert. und per shell komm ich nur mit SuSE klar :(
Kannst du mir sagen wies bei RedHat aussieht ?

captaincrunch
Userprojekt
Userprojekt
Posts: 7225
Joined: 2002-10-09 14:30
Location: Dorsten

Re: Nameserver geht einfach net

Post by captaincrunch » 2003-04-01 08:41

und per shell komm ich nur mit SuSE klar
Ich wüsste nicht, was bei RedHat (großartig) anders auf der Shell sein sollte. Das Paket kannst du da genau so mit rpm -Uvh bind9.rpm installieren. Die Einrichtung hast du ja ohnehin schon hinter dir.
DebianHowTo
echo "[q]sa[ln0=aln256%Pln256/snlbx]sb729901041524823122snlbxq"|dc

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 11:34

bei Redhat gibt es kein Yast *gggg*

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 21:24

Ich krieg ihn einfach nicht zum starten .. ich bekomme immer nur :

Code: Select all

[root@DNS-Server init.d]# ./named status
rndc: connect failed: connection refused
[root@DNS-Server init.d]#

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 21:55

Wenn du ihn nicht gestartet bekommst, ist es ganz normal, dass du bei einem Status ein Connection refused bekommst.

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:00

das is mir klar ... nur wie zur hölle muss ich ihn starten ? alles was ich mache klappt net :(

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:03

vielleicht irgendwas mit

/etc/init.d/bind start
/etc/init.d/bind9 start
/etc/init.d/named start

vielleicht haste Glück, und eins von den 3en geht, bei Debian ists das 2. ;)

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:05

named start probier ich ja immer
bind gibbet da nicht in keiner kombination

Code: Select all

[root@DNS-Server init.d]# ls
anacron    httpd      killall  network     rusersd   snmptrapd  xinetd
atd        identd     kudzu    nscd        rwalld    squid      ypbind
crond      ipchains   lpd      portmap     rwhod     sshd       yppasswdd
functions  iptables   mysqld   random      sendmail  syslog     ypserv
gpm        kdcrotate  named    rawdevices  single    vzquota    ypxfrd
halt       keytable   netfs    rstatd      snmpd     xfs
[root@DNS-Server init.d]#

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:21

[root@DNS-Server init.d]# ./named status
rndc: connect failed: connection refused
[root@DNS-Server init.d]#

da steht aber named status und nicht named start.

Was sagen denn die Error Logs ?

Direkt nach einem "Start-Versuch":
tail -20 /var/log/messages

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:27

hab jetzt server neu gestartet un dplötzlich gehts .. abba eins noch : wenn ich neue zones in der /var/named/named.conf eintrage und dann "./named reload" mache und anschließend wieder "./named status", dann zeigt er immernoch die alte anzahl zones ein im status

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:30

kA, hab ehrlich gesagt noch NIE den status command verwendet...

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:34

und das aller schärfste ist ja wohl das hier .. hab neue named.conf hochgeladen... und wollte ihn neuz starten .. was passiert ????


Code: Select all

[root@DNS-Server init.d]# ./named restart
Stopping named:                                            [  OK  ]
Starting named:                                            [FAILED]
[root@DNS-Server init.d]#
Wasn nu schon wieder hin ?

tux
Posts: 23
Joined: 2003-04-01 08:08

/var/named/named.conf

Post by tux » 2003-04-01 22:35

Code: Select all

// generated by named-bootconf.pl

options {
	directory "/var/named";
	pid-file "named.pid";
	allow-query { any };
	recursion no;
};

zone "." {
	type hint;
	file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
	type master;
	file "named.local";
	allow-update { none; };
};

zone "newmediatest.de" {
	type master;
	file "newmediatest.de";
};

// include "/etc/rndc.key";

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:36

Poste doch mal deine Error Logs, wie in dem Post vor diesem von mir beschrieben :roll: :roll:

tux
Posts: 23
Joined: 2003-04-01 08:08

/var/named/newmediatest.de

Post by tux » 2003-04-01 22:36

Code: Select all

@			IN SOA	                ns1.newmediadns.de (
					2003033101		; serial (d. adams)
					3H		; refresh
					15M		; retry
					1W		; expiry
					1D )		; minimum

			IN NS	ns1.newmediadns.de.
			IN NS	ns2.newmediadns.de.
			IN A	62.75.137.30
			IN MX   10 mx01.nmgs.de.
			IN MX   10 mx02.nmgs.de.

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:38

wenn ich den befehl eingebe, zeigt er NIX an ...

Code: Select all

[root@DNS-Server init.d]# ./named start
Starting named:                                            [FAILED]
[root@DNS-Server init.d]# tail -20 /var/log/messages
[root@DNS-Server init.d]#

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:39

Diese ZoneFile ist von oben bis unten falsch, aber das sind trotzdem nicht deine Error Logs. Und die sind erstmal wichtiger.

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:42

ich sachte doch :
wenn ich den befehl eingebe, zeigt er NIX an ...

Code: Select all

[root@DNS-Server init.d]# ./named start 
Starting named:                                            [FAILED] 
[root@DNS-Server init.d]# tail -20 /var/log/messages 
[root@DNS-Server init.d]# 

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:46

und wennich mir die file mit "vi" ansehe, ist sie LEER

kase
RSAC
Posts: 1041
Joined: 2002-10-14 22:56

Re: Nameserver geht einfach net

Post by kase » 2003-04-01 22:54

Hi, habe gerade gemerkt, dass du ein VServer bei S4F hast. Da hab ich nämlich auch noch einen ^^

Das ganze müsste in etwa so aussehen:

Code: Select all

[root@xxx root]# /etc/init.d/named start
Starting named:                                            [FAILED]
[root@xxx root]# tail -10 /var/log/messages
Apr  1 22:49:12 xxx sshd(pam_unix)[9519]: session opened for user root by (uid=0)
Apr  1 22:49:43 xxx named[9617]: starting BIND 9.2.1 -u named
Apr  1 22:49:43 xxx named[9617]: using 4 CPUs
Apr  1 22:49:43 xxx named[9617]: timer.c:766: unexpected error:
Apr  1 22:49:43 xxx named[9617]: isc_thread_create() failed
Apr  1 22:49:43 xxx named[9617]: ./main.c:396: unexpected error:
Apr  1 22:49:43 xxx named[9617]: ns_timermgr_create() failed: unexpected error
Apr  1 22:49:43 xxx named[9617]: create_managers() failed: unexpected error
Apr  1 22:49:43 xxx named[9617]: exiting (due to early fatal error)
Apr  1 22:49:44 xxx named: named startup failed
Die ganzen Errors kommen bei mir, weil ich den NameServer nicht konfiguriert habe, obwohl mir die ganzen Errors sehr merkwürdig vorkommen, evtl läuft named auf den VServern nicht ?!?!

floschi
Userprojekt
Userprojekt
Posts: 3388
Joined: 2002-07-18 08:13
Location: München

Re: Nameserver geht einfach net

Post by floschi » 2003-04-01 22:56

Poste mal die Ausgabe von ls -l /var/log ;)

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:57

doch .. ich hab den ja extra bestellt damit ich net einen unserer server dafür opfern muss ... aber das komische is : bind9 soll auf denen laufen, dazu linken die ja sogarim kundenmenü.

Aber die Fehlermeldungen hab ich NICHT. der zeigt mir keine fehler an.

würdest du dir das mal angucken wenncih dir die logindaten gebe ?

tux
Posts: 23
Joined: 2003-04-01 08:08

Re: Nameserver geht einfach net

Post by tux » 2003-04-01 22:57

Code: Select all

[root@DNS-Server init.d]# ls -l /var/log
total 50
-rw-r--r--    1 root     root            0 Apr  1 21:17 dmesg
drwxr-xr-x    2 root     root         1024 Feb 26  2002 fax
drwxr-xr-x    4 root     root         1024 Apr  1 21:17 httpd
-rw-r--r--    1 root     root         1812 Apr  1 21:17 ksyms.0
-rw-r--r--    1 root     root         1822 Apr  1 18:34 ksyms.1
-rw-r--r--    1 root     root        28908 Apr  1 22:12 lastlog
-rw-------    1 root     root            0 Mar 17 22:02 maillog
-rw-------    1 root     root            0 Apr  1 22:35 messages
-rw-r-----    1 mysql    mysql        1911 Apr  1 21:17 mysqld.log
-rw-------    1 root     root            0 Mar 17 22:02 secure
-rw-------    1 root     root            0 Mar 17 22:02 spooler
drwxr-x---    2 squid    squid        1024 Jun 28  2002 squid
-rw-rw-r--    1 root     utmp         7296 Apr  1 22:12 wtmp
-rw-------    1 root     root         1442 Apr  1 22:43 xferlog
[root@DNS-Server init.d]#