Probleme bei Installation Postgresql

MySQL, PostgreSQL, SQLite
luca
Posts: 7
Joined: 2003-02-06 10:34

Probleme bei Installation Postgresql

Post by luca » 2003-03-26 14:23

Hallo Leute,

habe folgendes Problem bei der Installation von Postgresql.

Bin dabei die neuste Version zu installieren. Laut Anleitung auf:

http://lamps.efactory.de/lamps-1-3.shtml#postgresql

bin jetzt bei diesem Befehl hier:

bin/initdb -D ./data

Da bekomme ich aber folgende Fehlermeldungen:

The files belonging to this database system will be owned by user "pgsql".
This user must also own the server process.

The database cluster will be initialized with locales:
COLLATE: POSIX CTYPE: de_DE@euro MESSAGES: de_DE@euro
MONETARY: de_DE@euro NUMERIC: de_DE@euro TIME: de_DE@euro

Fixing permissions on existing directory ./data... ok
creating directory ./data/base... ok
creating directory ./data/global... ok
creating directory ./data/pg_xlog... ok
creating directory ./data/pg_clog... ok
creating template1 database in ./data/base/1... Failed to initialize lc_messages to ''
ok
creating configuration files... ok
initializing pg_shadow... Failed to initialize lc_messages to ''
ok
enabling unlimited row size for system tables... Failed to initialize lc_messages to ''
ok
initializing pg_depend... Failed to initialize lc_messages to ''
ok
creating system views... Failed to initialize lc_messages to ''
ok
loading pg_description... Failed to initialize lc_messages to ''
ok
creating conversions... Failed to initialize lc_messages to ''
ok
setting privileges on built-in objects... Failed to initialize lc_messages to ''
ok
vacuuming database template1... Failed to initialize lc_messages to ''
ok
copying template1 to template0... Failed to initialize lc_messages to ''
ok

Success. You can now start the database server using:

bin/postmaster -D ./data
or
bin/pg_ctl -D ./data -l logfile start


Kann mir jemand bitte weiterhelfen, weiß nicht was das mit den "Failed to initalize lc_messages..." sein soll.

Vielen Dank & Gruß

Luca

Anonymous

Re: Probleme bei Installation Postgresql

Post by Anonymous » 2003-03-28 15:17

sind deine umgebungsvariable richtig konfiguriert?

wenn nicht...
sollte ungefähr so aussehen

export PATH="$PATH":/usr/local/pgsql/bin
PG=/usr/local/pgsql
export PGLIB=$PG/lib
export PGDATA=/var/lib/pgsql/data
export MANPATH="$MANPATH":$PG/man
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH":"$PGLIB"

luca
Posts: 7
Joined: 2003-02-06 10:34

Re: Probleme bei Installation Postgresql

Post by luca » 2003-03-31 11:57

Habe das so mit den Variablen probiert, leider kein anderes Ergebnis.

Hat jemand noch eine andere Idee ?