GD installieren mit CPAN funzt nicht...

Bash, Shell, PHP, Python, Perl, CGI
webmassa
Posts: 34
Joined: 2003-03-03 09:52
Location: Fehmarn / Ostsee

GD installieren mit CPAN funzt nicht...

Post by webmassa »

Hallo,

hab bisher mittels Lesen hier im Forum recht gut alles gelöst bekommen, aber jetzt scheitere ich an 3 Dingen, 1 davon in diesem Thread, die anderen Probs habe ich mit postfix in Verbindung mit Spamassassin und F-Prot-Antivir. Steht in anderem Thread und am Ende dieses Postings...

Folgende Meldung erhalte ich beim installieren von GD über CPAN, vielleicht liest es hier ja zufällig einer, der die richtige Ahnung hat...

> perl -MCPAN -e 'install GD'
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
Database was generated on Sun, 02 Mar 2003 23:10:54 GMT
Running install for module GD
Running make for L/LD/LDS/GD-2.06.tar.gz
CPAN: Digest::MD5 loaded ok
CPAN: Compress::Zlib loaded ok
Checksum for /root/.cpan/sources/authors/id/L/LD/LDS/GD-2.06.tar.gz ok
Scanning cache /root/.cpan/build for sizes
GD-2.06/
GD-2.06/demos/
(.. gekürzt..)
GD-2.06/Makefile.PL
GD-2.06/qd.pl
GD-2.06/GD.xs
GD-2.06/ChangeLog
GD-2.06/typemap
Removing previously used /root/.cpan/build/GD-2.06

CPAN.pm: Going to build L/LD/LDS/GD-2.06.tar.gz

NOTICE: This module requires libgd 2.0.5 or higher.
it will NOT work with earlier versions.
For earlier versions of libgd, use GD version 1.41.

Where is libgd installed? [/usr/lib] /usr/lib

Please choose the features that match how libgd was built:
Build JPEG support? [y] y
Build FreeType support? [y] y
Build XPM support? [y] y

If you experience compile problems, please check the @INC, @LIBPATH and @LIBS
arrays defined in Makefile.PL and manually adjust, if necessary.

WARNING: CAPI is not a known parameter.
Warning: prerequisite Math::Trig 1 not found.

(Anm.: Was hat um Gottes Willen CAPI hier zu suchen? Und Math::Trig ist installiert...)

Checking if your kit is complete...
Looks good
Writing Makefile for GD
cp GD/Polyline.pm blib/lib/GD/Polyline.pm
cp qd.pl blib/lib/qd.pl
cp GD.pm blib/lib/GD.pm
AutoSplitting blib/lib/GD.pm (blib/lib/auto/GD)
/usr/bin/perl /usr/lib/perl5/5.8.0/ExtUtils/xsubpp -typemap /usr/lib/perl5/5.8.0/ExtUtils/typemap -typemap typemap GD.xs > GD.xsc && mv GD.xsc GD.c
cc -c -I/usr/local/include -I/usr/local/include/gd -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3 --pipe -DVERSION="2.06" -DXS_VERSION="2.06" -fPIC "-I/usr/lib/perl5/5.8.0/i586-linux-thread-multi/CORE" -DHAVE_JPEG -DHAVE_FT -DHAVE_XPM GD.c
cc1: warning: changing search order for system directory "/usr/local/include"
cc1: warning: as it has already been specified as a non-system directory
GD.xs:7:16: gd.h: No such file or directory
GD.xs:242: parse error before "GD__Image"
GD.xs:242: warning: data definition has no type or storage class
GD.xs:243: parse error before "GD__Font"
GD.xs:243: warning: data definition has no type or storage class
GD.xs:245: parse error before "gdFontGiant"
GD.xs:245: warning: data definition has no type or storage class
GD.xs:246: parse error before "gdFontLarge"
GD.xs:246: warning: data definition has no type or storage class
GD.xs:247: parse error before "gdFontSmall"
(... auch gekürzt, denn so geht es immer weiter, ich schätze mal so mehrere hundert Zeilen...)
GD.c:3171: `font' undeclared (first use in this function)
GD.c:3171: called object is not a function
GD.c: In function `XS_GD__Font_height':
GD.c:3192: parse error before "font"
GD.c:3198: `font' undeclared (first use in this function)
GD.c:3198: called object is not a function
make: *** [GD.o] Error 1
/usr/bin/make -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

Noch kurz wegen meiner Probleme bezgl. postfix, doppelt hält besser, auch wenns hier eigentlich nicht hingehört:

Ich habe postfix am laufen, auch Confixx 2.0 auf das ich nicht verzichten kann, weil damit bereits diverse Kunden arbeiten. Habe mir grad Spamassassin installed, läuft auch, aber ich möchte eigentlich die harte Schiene fahren und bei sicher erkanntem Spam diesen gleich versenken bzw. teils auch schon von vornherein ablehnen. Zur Zeit schreibt Spamassassin die typischen Infos in die Kopfzeilen und ersetzt den Text der Nachricht mit entsprechenden Hinweisen und hängt dann die Originalnachricht an.
Mir wäre es lieber, wenn man frei wählen könnte, nach Möglichkeit sogar je Kunde, ob die Email gelöscht bzw. abgelehnt wird, wenn z.B. 8 Punkte erreicht werden. Von 4 bis 8 Punkten soll die Mail nur im Subject als Spam gekennzeichnet werden. Das müsste doch machbar sein? Achja und wie sperre ich übrigens Emailadressen vollständig? Dafür gibt es im Spamassassin auch irgendwie ne Funktion, die mit so einer Art Autoresponder antwortet, wenn an indizierte Adressen Mail verschickt wird...
Das zweite Ding ist der interessante Beitrag "Der qmail Mail-Toaster". Nachdem ich mir den durchgelesen habe, bin ich von der Idee abgekommen, mir qmail zu installden. Dafür sind schon zuviele Kunden angelegt, als dass ich glaube es mit Confixx auf die Reihe zu bekommen, ohne alle Kunden Postfachfrei zu bekommen. Also lass ich postfix. Aber wie zum Henker kriege ich da das F-Prot Antivirenproggi rein?
Hab zwar den Source, aber keine Anleitung und zum Testen hab ich wenig Chancen, wenn ich nicht Gefahr laufen will, von den Kunden gelyncht zu werden, falls was schief geht... :(

Tja, und das war es dann. Google hat mir da nnicht wirklich helfen können, auch hier im Forum war nix zu entdecken. Vielleicht jemand ne Idee?

Best regards...
jtb
Posts: 599
Joined: 2002-08-18 16:41
Location: Darmstadt

Re: GD installieren mit CPAN funzt nicht...

Post by jtb »

Hi,

das Problem hatte ich letztens auch..

Es gab wohl Ã?nderungen an der GD-Lib, die noch nicht in das GD-Modul übernommen wurden..

Einfach auf eine neue Version warten oder deine GD-Lib downgraden..
webmassa
Posts: 34
Joined: 2003-03-03 09:52
Location: Fehmarn / Ostsee

Re: GD installieren mit CPAN funzt nicht...

Post by webmassa »

Jtb wrote: Einfach auf eine neue Version warten oder deine GD-Lib downgraden..
Hm, würd ich ja machen, weil ich die nur für ein Counterprojekt brauche, reicht mir also völlig. Aber hast Du ne Adresse mit einer Anleitung oder so? Ich hab leider keine Ahnung, wie das geht.... :(