[Gelöst] MySQL 5.7 ein Performance Problem?

User avatar
Proteus
Posts: 256
Joined: 2013-04-14 05:08
Location: Holzgerlingen

[Gelöst] MySQL 5.7 ein Performance Problem?

Post by Proteus »

Hallo,

ich weiß nicht recht, aber irgendwie scheint meine MySQL Datenbank etwas schleppend Daten zu schreiben. Ich bemerke es wenn ich etwas schreibe, dann dauert es Gefühlsmäßig etwas zu lang bis Wordpress die Daten in die DB schreibt. Aber wie gesagt, es ist nur ein Gefühl. Ich dachte erst das es mal wieder an JetPack liegt, aber daran scheint es nicht zu liegen. Ich habe JetPack kurzzeitig deaktiviert. Wenn ich zum Beispiel hier im phpBB Forum etwas abschicke, dauert es gefühlsmäßig in Wordpress 3 Mal so lang.

Ich habe bewusst die Standard-Pfad gesetzt.

Code: Select all

mysql -V
mysql  Ver 14.14 Distrib 5.7.19, for FreeBSD11.1 (amd64) using  EditLine wrapper
my.cnf

Code: Select all

[client]
port                            = 3306
socket                          = /tmp/mysql.sock

[mysql]
prompt                          = \u@\h [\d]>\_
no_auto_rehash

[mysqld]
user                            = mysql
port                            = 3306
socket                          = /tmp/mysql.sock
bind-address                    = 127.0.0.1
basedir                         = /usr/local
datadir                         = /var/db/mysql
tmpdir                          = /var/db/mysql_tmpdir
slave-load-tmpdir               = /var/db/mysql_tmpdir
secure-file-priv                = /var/db/mysql_secure
log-bin                         = mysql-bin
log-output                      = TABLE
master-info-repository          = TABLE
relay-log-info-repository       = TABLE
relay-log-recovery              = 1
slow-query-log                  = 1
server-id                       = 1
sync_binlog                     = 1
sync_relay_log                  = 1
binlog_cache_size               = 16M
expire_logs_days                = 30
default_password_lifetime       = 0
enforce-gtid-consistency        = 1
gtid-mode                       = ON
safe-user-create                = 1
lower_case_table_names          = 1
explicit-defaults-for-timestamp = 1
myisam-recover-options          = BACKUP,FORCE
open_files_limit                = 32768
table_open_cache                = 16384
table_definition_cache          = 8192
net_retry_count                 = 16384
key_buffer_size                 = 256M
max_allowed_packet              = 64M
query_cache_type                = 0
query_cache_size                = 0
long_query_time                 = 0.5
innodb_buffer_pool_size         = 1G
innodb_data_home_dir            = /var/db/mysql
innodb_log_group_home_dir       = /var/db/mysql
innodb_data_file_path           = ibdata1:128M:autoextend
innodb_temp_data_file_path      = ibtmp1:128M:autoextend
innodb_flush_method             = O_DIRECT
innodb_log_file_size            = 256M
innodb_log_buffer_size          = 16M
innodb_write_io_threads         = 8
innodb_read_io_threads          = 8
innodb_autoinc_lock_mode        = 2
skip-symbolic-links

[mysqldump]
max_allowed_packet              = 256M
quote_names
quick
rc.conf

Code: Select all

mysql_enable="YES"
mysql_limits="YES"
mysql_dbdir="/var/db/mysql"
mysql_optfile="/usr/local/etc/my.cnf"
php.ini

Code: Select all

always_populate_raw_post_data = "-1"
arg_separator.input = ";&"
arg_separator.output = "&"
assert.active = "0"
cli_server.color = "1"
curl.cainfo = "/usr/local/share/certs/ca-root-nss.crt"
date.default_latitude = "53.5500"
date.default_longitude = "10.0000"
date.timezone = "Europe/Berlin"
default_charset = "UTF-8"
display_errors = "0"
display_startup_errors = "0"
enable_dl = "0"
engine = "1"
error_log = "/var/log/php_error.log"
error_reporting = "E_ALL & ~E_DEPRECATED & ~E_STRICT"
exif.encode_jis = "UTF-8"
exif.encode_unicode = "UTF-8"
expose_php = "0"
from = "admin@phoenix-blog.de"
html_errors = "0"
iconv.input_encoding = "UTF-8"
iconv.output_encoding = "UTF-8"
iconv.internal_encoding = "UTF-8"
input_encoding = "UTF-8"
internal_encoding = "UTF-8"
log_errors = "1"
mail.add_x_header = "1"
mail.log = "/var/log/php_sendmail.log"
max_execution_time = "60"
max_input_time = "60"
mbstring.detect_order = "auto"
mbstring.encoding_translation = "0"
mbstring.http_input = "pass"
mbstring.internal_encoding = "UTF-8"
mbstring.http_output = "pass"
mbstring.strict_detection = "1"
memory_limit = "256M"
opcache.enable = "1"
opcache.enable_cli = "1"
opcache.enable_file_override = "1"
opcache.error_log = "/var/log/php_opcache.log"
opcache.fast_shutdown = "1"
opcache.interned_strings_buffer = "16"
opcache.log_verbosity_level = "2"
opcache.max_accelerated_files = "32768"
opcache.max_wasted_percentage = "5"
opcache.memory_consumption = "128"
opcache.revalidate_freq = "60"
opcache.revalidate_path = "1"
opcache.save_comments = "1"
opcache.use_cwd = "1"
opcache.validate_timestamps = "1"
openssl.cafile = "/usr/local/share/certs/ca-root-nss.crt"
output_buffering = "4096"
output_encoding = "UTF-8"
pcre.backtrack_limit = "8000000"
pdo_mysql.cache_size = "2000"
post_max_size = "16M"
realpath_cache_size = "512k"
register_argc_argv = "0"
request_order = "GP"
session.cookie_httponly = "1"
session.gc_divisor = "1000"
session.hash_bits_per_character = "5"
session.hash_function = "1"
session.save_path = "/data/tmp/php"
session.use_strict_mode = "1"
sendmail_path = "/usr/sbin/sendmail -t -i"
short_open_tag = "0"
soap.wsdl_cache_dir = "/data/tmp/php"
sys_temp_dir = "/data/tmp/php"
sysvshm.init_mem = "10000"
upload_max_filesize = "64M"
upload_tmp_dir = "/data/tmp/php"
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry,fieldset="
user_ini.filename = None
variables_order = "GPCS"
zend.assertions = "-1"
zend.enable_gc = "1"
zend.multibyte = "1"
zend.script_encoding = "UTF-8"
zlib.output_compression = "0"
LG
Proti

https://phoenix-blog.de

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"
Top

User avatar
Proteus
Posts: 256
Joined: 2013-04-14 05:08
Location: Holzgerlingen

Re: [Gelöst] MySQL 5.7 ein Performance Problem?

Post by Proteus »

Ich sollte bevor ich schreibe, erst mal den Fehler bei mir suchen, und dann wenn es wirklich nicht mehr geht hier schreiben. Sorry war mein Fehler, es war mal wieder der Nginx der Probleme machte. Es fehlte ein Party Modul, warum auch immer, ohne das hätte nginx eigentlich gar nicht starten dürfen! :grimacing:
LG
Proti

https://phoenix-blog.de

"Die Kamera wird bei hohen ISO Werten aber rauschen. Nichts ahnend hielt er sich die Kamera ans Ohr!"
Top