Suse13.1 Rewrite greift nicht

Apache, Lighttpd, nginx, Cherokee
amiga1200
Posts: 208
Joined: 2007-01-13 19:58

Suse13.1 Rewrite greift nicht

Post by amiga1200 » 2016-01-22 14:59

Ich habe gerade mit einem Suse13.1 Server Probleme,
alles frisch installieren, leider machen der Rewrite Befehle Ärger.

In der
/etc/sysconfig/apache2
ist rewrite am Ende eingetragen und apache neugestartet
aber schon unter
http://192.168.0.40/anwendung/css/default.css
wir die index.php geladen
Musst für Rewrite noch was installiert werden?
Wo könnte der Fehler noch liegen?
Hat sich zwischen Suse12.1 auf 13.1 was geändert,
denn auf 12.1 dort läuft es Super.


Code: Select all

RewriteEngine on
Options +Execcgi +FollowSymLinks +SymLinksIfOwnerMatch
 

RewriteCond %{REQUEST_URI} !^/(medien|js)
#5 er
RewriteRule ^([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)(/|\.[a-zA-Z]+)?$ index.php?a1=$1&a2=$2&a3=$3&ac=3 [L]

 RewriteCond %{REQUEST_URI} !^/(medien|js)
#4 er
RewriteRule ^([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)(/|\.[a-zA-Z]+)?$ index.php?a1=$1&a2=$2&a3=$3&ac=3 [L]

#3 er
RewriteCond %{REQUEST_URI} !^/(medien|js)
 
RewriteRule ^([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)(/|\.[a-zA-Z]+)?$ index.php?a1=$1&a2=$2&a3=$3&ac=3 [L]

#2 er
RewriteCond %{REQUEST_URI} !^/(css)
RewriteCond %{REQUEST_URI} !^/(medien|js|cms|html/suche.php)
RewriteRule ^([a-zA-Z0-9\-_]+)/([a-zA-Z0-9\-_]+)(/|\.[a-zA-Z]+)?$     index.php?a1=$1&a2=$2&ac=2 [L]

 #1 er
RewriteCond %{REQUEST_URI} !^/(medien|js|favicon.ico|default.css|cms|html)
RewriteCond %{REQUEST_URI} !^/(medien|js|favicon.ico|robots.txt)
RewriteCond %{REQUEST_URI} !^/(css)
RewriteRule ^([~\a-zA-Z0-9\-_]+)(/|\.[a-zA-Z]+)?$   index.php?a1=$1&ac=1 [L]


 

amiga1200
Posts: 208
Joined: 2007-01-13 19:58

Re: Suse13.1 Rewrite greift nicht

Post by amiga1200 » 2016-01-22 15:12

Nachtrag: phpinfo sagt mir unter Loaded Modules mod_rewrite, aber warum greift es dann nicht?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Suse13.1 Rewrite greift nicht

Post by Joe User » 2016-01-22 18:01

Die "#3 er" Regel trifft zu, sofern Du keine relevante Zeile wie etwa eine RewriteBase verschwiegen hast.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

amiga1200
Posts: 208
Joined: 2007-01-13 19:58

Re: Suse13.1 Rewrite greift nicht

Post by amiga1200 » 2016-01-23 12:00

Vielen Dank für Deine Hilfe, war von mir ein Dummer Fehler.
wenn man so im lokalen Netz http://192.168.0.40 testet greift irgendwas nicht,
als ich eine Testdomain (www.test-nur_test.de) zugefügt habe war alles gut.