FastCGI & Apache 2.4 unter jessie

Apache, Lighttpd, nginx, Cherokee
rookienoob
Posts: 10
Joined: 2015-08-04 17:36

FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-05 20:30

Hallo & Guten Abend,

ich betreibe bislang mehrere vhosts auf wheezy + Apache 2.2 mit php5/fastcgi.

Ein Update auf jessie steht nun an.

Der neue Server ist mit einer Testpräsenz unter dem Usernamen "nutzer" aufgesetzt aber irgendwas stimmt nicht so ganz.

* .html-Dateien werden problemlos angezeigt

* .php-Dateien erzeugen in der error_log:

Code: Select all

[Tue Aug 04 17:50:39.489825 2015] [mime:warn] [pid 1417:tid 2884488000] AH01599: Cannot get media type from 'php5-fastcgi'
[Tue Aug 04 17:50:39.493439 2015] [fcgid:warn] [pid 1417:tid 2884488000] (104)Connection reset by peer: [client 31.19.212.48:61086] mod_fcgid: error reading data from FastCGI server
[Tue Aug 04 17:50:39.493471 2015] [core:error] [pid 1417:tid 2884488000] [client 31.19.212.48:61086] End of script output before headers: index.php



und in der suexec.log

Code: Select all

[2015-08-04 17:43:00]: uid: (1001/nutzer) gid: (1001/nutzer) cmd: fcgi-wrapper.sh
[2015-08-04 17:43:00]: command not in docroot (/home/nutzer/public_html/php-bin/fcgi-wrapper.sh)


sowie im Firefox:

Code: Select all

500 Internal Server Error



#: cat fcgi-wrapper.sh

Code: Select all

#!/bin/sh
export PHPRC="/etc/php5/cgi"



# cat /etc/apache2/sites-enabled/000-default.conf

<VirtualHost *:80>
ServerName meinedomain.de
ServerAdmin ich@nutzer.de
DocumentRoot /home/nutzer/public_html
SuexecUserGroup nutzer nutzer
<Directory /home/nutzer/public_html/>
FCGIWrapper /home/nutzer/public_html/php-bin/fcgi-wrapper.sh
Options Indexes ExecCGI
AddHandler php5-fastcgi .php
AddType php5-fastcgi .php
<FilesMatch \.php$>
SetHandler fcgid-script
</FilesMatch>
Options +ExecCGI
Require all granted
</Directory>
<Directory /home/nutzer/public_html/php-bin>
Require all granted
</Directory>
ErrorLog /home/nutzer/nutzer_error.log
LogLevel warn
CustomLog /home/nutzer/nutzer_access.log combined
</VirtualHost>




Eigentlich hatte ich vor, von der wheezy-Maschine die Konfigurationen so zu übernehmen - aber ich bin schon an dem "hosts-allow" als erstes damit gescheitert, da unter jessie Apache 2.4 läuft und in diesem Punkt die Behandlung der hosts-Direktive nun etwas anders als unter Apache 2.2 ist.


Ich vermute nun, dass es sich hier auch um einen Unterschied zwischen 2.2 und 2.4 handelt - aber welchen?

Habt Ihr Vorschläge ?

Gruß

Sebastian
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-05 22:08

mod_fcgid ist heute nicht mehr nötig, da PHP-5.[56] mitlerweile selbst FastCGI beherscht (PHP-FPM) und Apache 2.4 mod_proxy_fcgi mitbringt. Diese Kombination läuft sehr stabil und ist schnell aufgesetzt.

Lesestoff: https://wiki.apache.org/httpd/PHP-FPM und http://php.net/manual/en/install.fpm.php

Kurzes simples Konfigurationsbeispiel auf das Nötigste reduziert:
php-fpm.conf

Code: Select all

[global]
pid = run/php-fpm.pid
process.max = 256
process.priority = -9
events.mechanism = kqueue

[www]
user = www
group = www
listen = /var/run/fpm_$pool.sock
listen.owner = www
listen.group = www
listen.mode = 0660
process.priority = -9
pm = dynamic
pm.max_children = 256
pm.start_servers = 32
pm.min_spare_servers = 8
pm.max_spare_servers = 32
pm.max_requests = 500
catch_workers_output = yes
security.limit_extensions = .php .php5 .phtml .phps


httpd.conf

Code: Select all

...
LoadModule proxy_module libexec/apache24/mod_proxy.so
LoadModule proxy_fcgi_module libexec/apache24/mod_proxy_fcgi.so
...


vhosts.conf

Code: Select all

<VirtualHost *:80>
    ServerName www.example.org
    ServerAdmin webmaster@example.org
    CustomLog "/data/www/vhosts/www.example.org/logs/access_log" combined
    ErrorLog "/data/www/vhosts/www.example.org/logs/error_log"
    DocumentRoot "/data/www/vhosts/www.example.org/data"
    <Directory "/data/www/vhosts/www.example.org/data">
        Options None +FollowSymLinks
        AllowOverride None
        Require all granted
    </Directory>
    ProxyPassMatch ^/(.*\.php(/.*)?)$ unix:/var/run/fpm_www.sock|fcgi://127.0.0.1:9000/data/www/vhosts/www.example.org/data/
</VirtualHost>


Mehr ist nicht nötig (Apache und PHP-FPM müssen natürlich per Initsystem gestartet werden), abgesehen vom Finetuning (meine Beispielwerte sind eventuell zu hoch für Deinen Einsatzzweck).

Du kannst für jeden Systembenutzer einen eigenen FPM-Pool definieren, oder einen globalen (wie mod_php), oder auch einen Mix aus Beiden.
Suexec und den ganzen anderen Kram wie fcgi-starter brauchst Du zumindest für PHP nicht mehr.

Ein weiterer Vorteil: Mit dieser Kombination lässt sich auch Apache MPM-Event problemlos nutzen und so nochmal einiges an Performance gewinnen (im Vergleich zu MPM-Prefork).
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-06 19:52

ok - danke - ich habs mal ausprobiert - komischerweise kommt nun:

Code: Select all

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.


die error.log sagt:
[Thu Aug 06 19:50:57.073463 2015] [proxy:debug] [pid 7932:tid 3074582336] proxy_util.c(1771): AH00925: initializing worker unix:/var/run/fpm_www.sock|fcgi://127.0.0.1:9000/home/nutzer/public_html/ shared
[Thu Aug 06 19:50:57.073490 2015] [proxy:debug] [pid 7932:tid 3074582336] proxy_util.c(1813): AH00927: initializing worker unix:/var/run/fpm_www.sock|fcgi://127.0.0.1:9000/home/nutzer/public_html/ local
[Thu Aug 06 19:50:57.073510 2015] [proxy:debug] [pid 7932:tid 3074582336] proxy_util.c(1848): AH00930: initialized pool in child 7932 for (127.0.0.1) min=0 max=25 smax=25
[Thu Aug 06 19:50:57.074185 2015] [proxy:debug] [pid 7933:tid 3074582336] proxy_util.c(1771): AH00925: initializing worker unix:/var/run/fpm_www.sock|fcgi://127.0.0.1:9000/home/nutzer/public_html/ shared
[Thu Aug 06 19:50:57.074202 2015] [proxy:debug] [pid 7933:tid 3074582336] proxy_util.c(1813): AH00927: initializing worker unix:/var/run/fpm_www.sock|fcgi://127.0.0.1:9000/home/nutzer/public_html/ local
[Thu Aug 06 19:50:57.074222 2015] [proxy:debug] [pid 7933:tid 3074582336] proxy_util.c(1848): AH00930: initialized pool in child 7933 for (127.0.0.1) min=0 max=25 smax=25
[Thu Aug 06 19:51:00.720310 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of Require all granted: granted
[Thu Aug 06 19:51:00.720380 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of <RequireAny>: granted
[Thu Aug 06 19:51:00.720436 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of Require all granted: granted
[Thu Aug 06 19:51:00.720448 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of <RequireAny>: granted
[Thu Aug 06 19:51:00.720480 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of Require all granted: granted
[Thu Aug 06 19:51:00.720489 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of <RequireAny>: granted
[Thu Aug 06 19:51:00.720515 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of Require all granted: granted
[Thu Aug 06 19:51:00.720524 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(809): [client 31.19.211.33:51216] AH01626: authorization result of <RequireAny>: granted
[Thu Aug 06 19:51:00.720548 2015] [authz_core:debug] [pid 7933:tid 3060792128] mod_authz_core.c(835): [client 31.19.211.33:51216] AH01628: authorization result: granted (no directives)
[Thu Aug 06 19:51:00.720566 2015] [proxy_fcgi:debug] [pid 7933:tid 3060792128] mod_proxy_fcgi.c(77): [client 31.19.211.33:51216] AH01060: set r->filename to proxy:fcgi://127.0.0.1:9000/home/nutzer/public_html//index.php
[Thu Aug 06 19:51:00.720585 2015] [proxy:debug] [pid 7933:tid 3060792128] mod_proxy.c(1155): [client 31.19.211.33:51216] AH01143: Running scheme fcgi handler (attempt 0)
[Thu Aug 06 19:51:00.720594 2015] [proxy_fcgi:debug] [pid 7933:tid 3060792128] mod_proxy_fcgi.c(786): [client 31.19.211.33:51216] AH01076: url: fcgi://127.0.0.1:9000/home/nutzer/publi ... /index.php proxyname: (null) proxyport: 0
[Thu Aug 06 19:51:00.720603 2015] [proxy_fcgi:debug] [pid 7933:tid 3060792128] mod_proxy_fcgi.c(793): [client 31.19.211.33:51216] AH01078: serving URL fcgi://127.0.0.1:9000/home/nutzer/publi ... /index.php
[Thu Aug 06 19:51:00.720624 2015] [proxy:debug] [pid 7933:tid 3060792128] proxy_util.c(2131): AH00942: FCGI: has acquired connection for (127.0.0.1)
[Thu Aug 06 19:51:00.720635 2015] [proxy:debug] [pid 7933:tid 3060792128] proxy_util.c(2184): [client 31.19.211.33:51216] AH00944: connecting fcgi://127.0.0.1:9000/home/nutzer/publi ... /index.php to 127.0.0.1:9000
[Thu Aug 06 19:51:00.720645 2015] [proxy:debug] [pid 7933:tid 3060792128] proxy_util.c(2217): [client 31.19.211.33:51216] AH02545: fcgi: has determined UDS as /var/run/fpm_www.sock
[Thu Aug 06 19:51:00.720779 2015] [proxy:debug] [pid 7933:tid 3060792128] proxy_util.c(2385): [client 31.19.211.33:51216] AH00947: connected /home/nutzer/public_html//index.php to httpd-UDS:0
[Thu Aug 06 19:51:00.720811 2015] [proxy:error] [pid 7933:tid 3060792128] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/run/fpm_www.sock (127.0.0.1) failed
[Thu Aug 06 19:51:00.720829 2015] [proxy:error] [pid 7933:tid 3060792128] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 60s
[Thu Aug 06 19:51:00.720838 2015] [proxy_fcgi:error] [pid 7933:tid 3060792128] [client 31.19.211.33:51216] AH01079: failed to make connection to backend: httpd-UDS
[Thu Aug 06 19:51:00.720847 2015] [proxy:debug] [pid 7933:tid 3060792128] proxy_util.c(2146): AH00943: FCGI: has released connection for (127.0.0.1)



die access.log sagt:

31.19.211.33 - - [06/Aug/2015:19:51:00 +0200] "GET / HTTP/1.1" 503 473 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0"
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-06 19:53

gibts keine Chance, das ganze in der bisherigen Form zum laufen zu bringen ?

Das Problem scheint ja nur der document_root zu sein
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-06 21:09

Dein Apache scheint keinen Zugriff auf den Socket /var/run/fpm_www.sock zu haben.
Stimmen die Socketangaben in der php-fpm.conf und der vhosts.conf überein?
Bei der Gelegenheit bitte in der php-fpm.conf events.mechanism auf epoll setzen.

Falls Debian noch Apache <2.4.10 mitliefert (oder auch als Alternative zur vorigen Konfiguration), musst Du leider auf UNIX-Sockets verzichten und FPM per TCP/IP ansprechen. Dazu müssen folgende Änderungen vorgenommen werden:

php-fpm.conf

Code: Select all

[global]
pid = run/php-fpm.pid
process.max = 256
events.mechanism = epoll

[www]
user = www-data
group = www-data
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1
pm = dynamic
pm.max_children = 256
pm.start_servers = 32
pm.min_spare_servers = 8
pm.max_spare_servers = 32
pm.max_requests = 500
catch_workers_output = yes
security.limit_extensions = .php .php5 .phtml .phps


vhosts.conf

Code: Select all

<VirtualHost *:80>
    ServerName www.example.org
    ServerAdmin webmaster@example.org
    CustomLog "/data/www/vhosts/www.example.org/logs/access_log" combined
    ErrorLog "/data/www/vhosts/www.example.org/logs/error_log"
    DocumentRoot "/data/www/vhosts/www.example.org/data"
    <Directory "/data/www/vhosts/www.example.org/data">
        Options None +FollowSymLinks
        AllowOverride None
        Require all granted
    </Directory>
    ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/data/www/vhosts/www.example.org/data/$1
</VirtualHost>


Die User/Group Optionen des Pools in der php-fpm.conf müssen mit den User/Group des VirtualHosts oder des Apache übereinstimmen, hatte ich im vorigen Post vergessen zu erwähnen.


Teste das Ganze der Einfachheit halber am Besten mit einer simplen phpinfo.php, damit man vergleichbarere Werte bekommt.



Mit mod_fcgid geht es natürlich auch irgendwie, allerdings habe ich damit keinerlei Erfahrung und müsste mich erst selbst einlesen :(
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-06 21:48

Er weigert sich irgendwie mit dem Port 9000 zu sprechen:
[Thu Aug 06 21:46:27.232420 2015] [proxy:debug] [pid 534:tid 2926484288] proxy_util.c(2385): [client 31.19.211.33:53842] AH00947: connected /home/nutzer/public_html/index.php to 127.0.0.1:9000
[Thu Aug 06 21:46:27.232522 2015] [proxy:error] [pid 534:tid 2926484288] (111)Connection refused: AH00957: FCGI: attempt to connect to 127.0.0.1:9000 (*) failed
[Thu Aug 06 21:46:27.232544 2015] [proxy_fcgi:error] [pid 534:tid 2926484288] [client 31.19.211.33:53842] AH01079: failed to make connection to backend: 127.0.0.1
[Thu Aug 06 21:46:27.232554 2015] [proxy:debug] [pid 534:tid 2926484288] proxy_util.c(2146): AH00943: FCGI: has released connection for (*)
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-06 21:57

OK, das sieht schon besser aus. In der php-fpm.conf bitte listen.allowed_clients entweder um alle Deine IPs erweitern, oder die Zeile entsorgen (dann aber den Zugriff auf Port 9000 per IPTables regeln, nicht dass die ganze Welt darauf zugreifen kann).
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-06 22:00

Obwohl, lösche die Zeile einfach, der Port ist ja nur auf 127.0.0.1 gebunden und damit eh nicht von extern erreichbar.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-06 22:21

Hi,

ich hatte noch 1 Fehler:

1. ich habe eine /etc/php-fpm.conf angelegt - er hat aber auf die config im /etc/php5/fpm/-Verzeichnis zurückgegriffen ;-)

er startet zwar das php-skript - aber phpinfo() wird nicht angezeigt - ich vermute mal ein Rechteproblem.

Die php-Datei muss ja Recht 750 haben und das Verzeichnis /home/nutzer/public_html sowie die index.php müssen dem User www-data gehören ?

www-data ist auch der User des apache - es ist übrigens exakt apache 2.4.10
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-06 22:27

rookienoob wrote:Die php-Datei muss ja Recht 750 haben und das Verzeichnis /home/nutzer/public_html sowie die index.php müssen dem User www-data gehören ?

Ja, wobei 640 auch reicht.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-06 22:49

geht trotzdem nicht - er gibt das php-skript nicht aus - gibts da noch ne chance irgendwelche logs auszuwerten ?
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-06 23:11

Funktioniert es wenn Du den DocumentRoot unterhalb Debians Default /var/www verlegst?
Also zum Testen temporär mal beispielsweise /var/www/testing/data als DocumentRoot anlegen.
Könnte sein, dass mod_userdir oder irgendwelche Apache-Konfigurationsoptionen für /home/*/public_html dazwischenfunken.

Code: Select all

mkdir -p /var/www/testing/{data,logs}
chmod 0750 /var/www/testing/data
chown www-data:www-data /var/www/testing/data

echo '<?php phpinfo(); ?>' > /var/www/testing/data/phpinfo.php
chmod 0640 /var/www/testing/data/phpinfo.php
chown www-data:www-data /var/www/testing/data/phpinfo.php




FPM logt standardmässig nach /var/log/php-fpm.log oder ins ErrorLog des VirtualHosts und der Loglevel lässt sich in der php-fpm.conf mittels "log_level = debug" im [global] Abschnitt erhöhen.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-07 05:06

Das gleiche Ergebnis - in der error.log steht:

[Fri Aug 07 05:03:44.313764 2015] [proxy:debug] [pid 6355:tid 3073738560] proxy_util.c(1771): AH00925: initializing worker fcgi://127.0.0.1:9000/www/var/testing/data/$1 shared
[Fri Aug 07 05:03:44.313814 2015] [proxy:debug] [pid 6355:tid 3073738560] proxy_util.c(1813): AH00927: initializing worker fcgi://127.0.0.1:9000/www/var/testing/data/$1 local
[Fri Aug 07 05:03:44.313845 2015] [proxy:debug] [pid 6355:tid 3073738560] proxy_util.c(1848): AH00930: initialized pool in child 6355 for (127.0.0.1) min=0 max=25 smax=25
[Fri Aug 07 05:03:44.314796 2015] [proxy:debug] [pid 6354:tid 3073738560] proxy_util.c(1771): AH00925: initializing worker fcgi://127.0.0.1:9000/www/var/testing/data/$1 shared
[Fri Aug 07 05:03:44.314821 2015] [proxy:debug] [pid 6354:tid 3073738560] proxy_util.c(1813): AH00927: initializing worker fcgi://127.0.0.1:9000/www/var/testing/data/$1 local
[Fri Aug 07 05:03:44.314850 2015] [proxy:debug] [pid 6354:tid 3073738560] proxy_util.c(1848): AH00930: initialized pool in child 6354 for (127.0.0.1) min=0 max=25 smax=25


in der php-fpm.log steht im debug-logging:
[07-Aug-2015 04:58:48.801584] NOTICE: pid 6137, fpm_conf_init_main(), line 1699: configuration file /etc/php5/fpm/php-fpm.conf test is successful
[07-Aug-2015 04:58:48.880735] DEBUG: pid 6140, fpm_scoreboard_init_main(), line 40: got clock tick '100'
[07-Aug-2015 04:58:48.884685] DEBUG: pid 6140, fpm_socket_af_inet_listening_socket(), line 308: Found address for 127.0.0.1, socket opened on 127.0.0.1
[07-Aug-2015 04:58:48.884758] DEBUG: pid 6140, fpm_event_init_main(), line 342: event module is epoll and 513 fds have been reserved
[07-Aug-2015 04:58:48.884884] NOTICE: pid 6140, fpm_init(), line 85: fpm is running, pid 6140
[07-Aug-2015 04:58:48.886304] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6144 started
[07-Aug-2015 04:58:48.887383] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6145 started
[07-Aug-2015 04:58:48.889519] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6146 started
[07-Aug-2015 04:58:48.941794] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6168 started
[07-Aug-2015 04:58:48.943436] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6169 started
[07-Aug-2015 04:58:48.946822] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6170 started
[07-Aug-2015 04:58:48.949646] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6171 started
[07-Aug-2015 04:58:48.951608] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6172 started
[07-Aug-2015 04:58:48.955148] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6173 started
[07-Aug-2015 04:58:48.958202] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6174 started
[07-Aug-2015 04:58:48.959834] DEBUG: pid 6140, fpm_children_make(), line 421: [pool www] child 6175 started
[07-Aug-2015 04:58:48.959880] DEBUG: pid 6140, fpm_event_loop(), line 371: 273504 bytes have been reserved in SHM
[07-Aug-2015 04:58:48.959891] NOTICE: pid 6140, fpm_event_loop(), line 372: ready to handle connections
[07-Aug-2015 04:58:48.963886] DEBUG: pid 6140, fpm_systemd_heartbeat(), line 68: have notify start to systemd
[07-Aug-2015 04:58:48.963934] NOTICE: pid 6140, fpm_systemd_heartbeat(), line 75: systemd monitor interval set to 10000ms
[07-Aug-2015 04:58:49.960435] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 04:58:50.963436] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 04:58:51.964469] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 04:58:52.965634] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1

[...und so weiter...]

[07-Aug-2015 05:05:01.513955] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:02.515163] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:03.516324] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:04.517534] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:05.518696] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:06.519883] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:07.521067] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
[07-Aug-2015 05:05:08.522235] DEBUG: pid 6140, fpm_pctl_perform_idle_server_maintenance(), line 379: [pool www] currently 0 active children, 32 spare children, 32 running children. Spawning rate 1
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-07 11:36

Schade, hätte ja sein können. Ich muss nochmal etwas überlegen woran es hapern könnte und melde mich später wieder, im Moment bin ich ratlos.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-07 12:50

Kannst Du bitte mal Deine vollständigen Kofigurationen posten?
Also php-fpm.conf und vhosts.conf beziehungsweise die entsprechenden Debian-Dateien, danke.
Und die ganzen Debian-spezifischen Befehle und Änderungen die Du zusätzlich vorgenommen hast.

Laut Google müsste eigentlich Alles passen.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-07 20:14

Heiliger Dreck (sorry - aber das ist übel).

Ich hab selbst etwas experimentiert.

Ich bin auf folgenden Beitrag gestoßen:

http://serverfault.com/questions/450628/apache-2-4-php-fpm-proxypassmatch


Der Mensch hat folgendes gemacht:
<VirtualHost *:80>
ServerName localhost
DocumentRoot "/Users/apfelbox/WebServer"

RewriteEngine on
RewriteCond /Users/apfelbox/WebServer/%{REQUEST_FILENAME} -f
RewriteRule ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/Users/apfelbox/WebServer/$1 [L,P]
</VirtualHost>







meine Apache vhost-conf ist:

<VirtualHost *:80>
ServerName testserver.ich.de
ServerAdmin webmaster@ich.de
CustomLog "/var/www/testing/logs/access_log" combined
ErrorLog "/var/www/testing/logs/error_log"
DocumentRoot "/var/www/testing/data"
<Directory "/var/www/testing/data">
Options None +FollowSymLinks
AllowOverride None
Require all granted
</Directory>
# ProxyPassMatch ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/www/var/testing/data/$1

RewriteEngine on
RewriteCond /var/www/testing/data/%{REQUEST_FILENAME} -f
RewriteRule ^/(.*\.php(/.*)?)$ fcgi://127.0.0.1:9000/var/www/testing/data/$1 [L,P]
</VirtualHost>
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-07 21:14

Funktioniert der Hack mit mod_rewrite denn wenigstens?
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-08-07 22:12

Ja :-)

Das funktioniert - Danke Dir :ymhug: :ymhug: :ymhug:
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-07 22:34

Immerhin, wenn auch nicht ganz optimal.
Hoffe Du wirst mit PHP-FPM zufrieden sein.


Ich liebe^Whasse Debian und seine Eigenheiten...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: FastCGI & Apache 2.4 unter jessie

Post by Joe User » 2015-08-07 22:50

Hier ist noch eine dritte Einbindungs-Methode beschrieben:
http://z-issue.com/wp/apache-2-4-the-ev ... th-vhosts/
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

rookienoob
Posts: 10
Joined: 2015-08-04 17:36

Re: FastCGI & Apache 2.4 unter jessie

Post by rookienoob » 2015-12-02 10:47

Die Lösung war viel einfacher - gradezu simpel.

Ich habe bislang immer im /home/user/public_html versucht die Skripte aufzurufen.

suexec-custom geht im Standard aber auf /var/www/...... - das lässt sich irgendwie auch "nicht mehr so einfach" ändern - die Konfiguration wird da nicht akzeptiert.

Als ich die Daten im /var/www hatte - auf einmal gings.

Danke für Deine Beispiele :D
Der Anwender steht immer im Mittelpunkt – und da steht er jedem im Weg.

Quelle: Entwicklerweisheit