Temporär Hoher Load - Kann Ursache nicht finden

Serverdienste ohne eigene Kategorie
Werner67
Posts: 1
Joined: 2012-08-04 11:56

Temporär Hoher Load - Kann Ursache nicht finden

Post by Werner67 »

Hallo ! Bisher bin ich seit längerer Zeit als Leser dabei gewesen, benötige jetzt aber Hilfe bei einem Problem bei dem ich nun lagsam die Segel strecken muss :(

Das System:

3x

VServer (HostEurope L5.0)
1 GB RAM
Ubuntu 10.04 LTS + Plesk 10.4.4 #40

---------------------------------------------------

Mein Problem/Frage...

Ich habe auf meinen Servern immer im gleichen Zeitfenster einen Anstieg des Load zu verzeichnen. Zuerst ist mir das nicht weiter aufgefallen bezw. war nicht so wichtig, aber auf einen der 3 Server läuft ein TS3-Server , der damit arge Probleme hat. Während bei den anderen Servern der Load auf 2-10 steigt, so hat der Server mit dem TS3 auch schon mal einen Load von 20-50. Zusätzlich wirft der Container dann auch mal eine Warnung für das Überschreiten von "dgramrcvbuf" aus. Ich habe bereits den Support in Anspruch genommen ohne das hier eine Lösung gefunden wurde. Ich wurde dann mit diesem Server auf einen neuen Host gelegt. Dort lief es dann einige Wochen wieder Problemlos, bis von Woche zu Woche der besagte Load wieder anstiegt. Das übrigens alles unabhängig von der Auslastung des TS3.

Natürlich hatte ich ein Problem mit dem TS3-Server in Verdacht, aber irgendwann habe ich die Protokolle mit den anderen Servern wo kein TS3 läuft verglichen. Jeden Abend im Zeitraum von 22 - 23 Uhr steigt der Load auf allen 3 Servern aus nicht feststellbaren Gründen an. Das für etwa 5-10 Minuten. Lediglich der VServer mit dem TS3 legt dann noch einen oben drauf.

Ich kann im Syslog nichts finden, weil ich an irgendweinen Backupprozess oä. gedacht habe. Das was auf allen 3 Servern gleich ist sind folgende Dinge..

- Plesk (inkl. der vorkonfigurierten Dienste)
- Fail2ban
- Portsentry
- Munin

Nun habe ich bei einem der Server einmal folgendes gestoppt:

-> Plesk, Apache, courier, qmail, mysql, sw-cp-server

Gestern Abend habe ich dann den Load beobachtet. Es ist etwas weniger geworden, aber immer noch ein Anstieg von (Normalbetrieb) 1 auf 3-4. Dort läuft übrigens nicht der TS3-Server.

- Es laufen keine Backups in der Zeit
- Die CPU wird lediglich zu 20-30 % ausgelastet
- SWAP wird nicht belegt und ich nutze nur ca. 500 MB RAM von 1 GB.

Mein Bauchgefühl sagt mir, dass hier irgendwas mit Plesk nicht stimmt oder irgendwelche Sachen im Hintergrund laufen. Habe auch nach unstimmigen Netzwerkverbindungen geschaut, ob sich hier jemand unerlaubt Zugriff verschafft hat.. nichts. Die SErver haben alle unterschiedliche Zugänge.. Zugang mit Konsole nur über Key , FTP und Plesk sind nur mit statischer IP erreichbar. Maildienste normalerweise deaktiviert und auf 2 Servern läuft überhaupt kein Webserver.

Evtl. hat von euch noch jemand einen Einfall ? Da einzige was nun noch zu versuchen wäre, ist alles ohne Plesk aufzusetzen. Ich tendiere zu Deb6.

lg

ddm3ve
Moderator
Moderator
Posts: 1182
Joined: 2011-07-04 10:56

Re: Temporär Hoher Load - Kann Ursache nicht finden

Post by ddm3ve »

Also ein typsicher Problem ist, dass jemand anderer der auf dem gleichen Phyisxhen Host ist, auf der Platte intensive operationen tätigt.

Klär das am besten mit dem Support Deines Anbieters.
02:32:12 21.12.2012 und dann sind Deine Probleme alle unwichtig.