SPF arbeitet wohl nicht korrekt ...?

Postfix, QMail, Sendmail, Dovecot, Cyrus, Courier, Anti-Spam
mowgly
Posts: 11
Joined: 2007-04-29 13:39

SPF arbeitet wohl nicht korrekt ...?

Post by mowgly » 2009-08-28 10:30

Hallo,
Mein System : SuSE 10.1
Plesk 9.2.2 (Rootzugriff)


Ich habe es hier: HIER schon nachgeschaut und abgeglichen aber es tat sich nicht's. Ich kannn absolut keine Mails an GMX versenden.
Mail welche ich zurück bekomme:
Hi. This is the qmail-send program at IT-Erfahrung.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<wincierz@gmx.de>:
213.165.64.102 does not like recipient.
Remote host said: 550-5.7.1 {mx030} Sorry, your helo has been denied.
550 5.7.1 ( http://portal.gmx.net/serverrules ) Giving up on 213.165.64.102.

--- Below this line is a copy of the message.

Return-Path: <support@it-erfahrung.de>
Received: (qmail 4021 invoked from network); 28 Aug 2009 09:28:53 +0200
Received: from dyndsl-080-228-215-076.ewe-ip-backbone.de (HELO frog) (80.228.215.76)
by it-erfahrung.de with SMTP; 28 Aug 2009 09:28:52 +0200
Reply-To: <support@it-erfahrung.de>
From: "Support" <support@it-erfahrung.de>
To: <wincierz@gmx.de>
Subject: test
Date: Fri, 28 Aug 2009 09:34:05 +0200
Organization: IT-Erfahrung.de
Message-ID: <!&!AAAAAAAAAAAYAAAAAAAAACh0AlrxUB9MohBIbIxLpqbCgAAAEAAAAGtrGjJdD+lBoihhRTj3okEBAAAAAA==@it-erfahrung.de>
MIME-Version: 1.0
Content-Type: multipart/related;
boundary="----=_NextPart_000_0018_01CA27C2.AF7883D0"
X-Mailer: Microsoft Office Outlook 11
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.5579
Thread-Index: Aconsee+bNLB0qnpTyqKK6TUliho4w==
Disposition-Notification-To: "Support" <support@it-erfahrung.de>

This is a multi-part message in MIME format.

------=_NextPart_000_0018_01CA27C2.AF7883D0
Content-Type: multipart/alternative;
boundary="----=_NextPart_001_0019_01CA27C2.AF846AB0"

------=_NextPart_001_0019_01CA27C2.AF846AB0
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

test.

eine Abfrage auf http://www.kitterman.com/spf/validate.html ergab:
SPF records are published in DNS as TXT records. No TXT records found for your domain.

SPF records should also be published in DNS as type SPF records. This is new and most implementations do not support it yet.
No type SPF records found.


Dazu muß ich sagen, dass ich nur bestimmten DNS vertraue... ( EVTL liegt da der Fehler).
nach dem ich mal kurzfristig meine dynamische IP als vertraute IP Abfrgae IP eingtragen habe und ich ein : nslookup ausführte bekam ich folgendes:

lserver it-erfahrung.de
ls -t TXT it-erfahrung.de => it-erfahrung.de. TXT "v=spf1 a mx ~all"

unter :
http://www.vamsoft.com/spfvalidator.asp gibt er an das der Code OK ist


mail .info sagt:
Aug 28 10:07:58 IT-Erfahrung spamd[2750]: spamd: got connection over /tmp/spamd_full.sock
Aug 28 10:07:58 IT-Erfahrung spamd[21242]: prefork: child states: II
Aug 28 10:08:07 IT-Erfahrung qmail-queue-handlers[6191]: Handlers Filter before-queue for qmail started ...
Aug 28 10:08:07 IT-Erfahrung qmail-queue-handlers[6191]: from=support@it-erfahrung.de
Aug 28 10:08:07 IT-Erfahrung qmail-queue-handlers[6191]: to=wincierz@gmx.de
Aug 28 10:08:07 IT-Erfahrung spf filter[6192]: Starting spf filter...
Aug 28 10:08:07 IT-Erfahrung qmail: 1251446887.975052 new msg 12635565
Aug 28 10:08:07 IT-Erfahrung qmail: 1251446887.975176 info msg 12635565: bytes 33083 from <support@it-erfahrung.de> qp 6193 uid 2020
Aug 28 10:08:07 IT-Erfahrung qmail: 1251446887.977017 starting delivery 204: msg 12635565 to remote wincierz@gmx.de
Aug 28 10:08:07 IT-Erfahrung qmail: 1251446887.977169 status: local 0/10 remote 1/20
Aug 28 10:08:07 IT-Erfahrung qmail-remote-handlers[6194]: Handlers Filter before-remote for qmail started ...
Aug 28 10:08:07 IT-Erfahrung qmail-remote-handlers[6194]: from=support@it-erfahrung.de
Aug 28 10:08:07 IT-Erfahrung qmail-remote-handlers[6194]: to=wincierz@gmx.de
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.232227 delivery 204: failure: 213.165.64.100_does_not_like_recipient./Remote_host_said:_55-5.7.1_{mx063}_Sorry,_your_helo_has_been_denied./550_5.7.1_(_http://portal.gmx.net/serverrules_)/Giving_up_on_213.165.64.100./
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.232871 status: local 0/10 remote 0/20
Aug 28 10:08:08 IT-Erfahrung qmail-queue-handlers[6195]: Handlers Filter before-queue for qmail started ...
Aug 28 10:08:08 IT-Erfahrung qmail-queue-handlers[6195]: from=
Aug 28 10:08:08 IT-Erfahrung qmail-queue-handlers[6195]: to=support@it-erfahrung.de
Aug 28 10:08:08 IT-Erfahrung spf filter[6196]: Starting spf filter...
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.241581 bounce msg 12635565 qp 6195
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.241677 end msg 12635565
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.242569 new msg 12635566
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.242664 info msg 12635566: bytes 33763 from <> qp 6197 uid 2522
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.243825 starting delivery 205: msg 12635566 to local 20-support@it-erfahrung.de
Aug 28 10:08:08 IT-Erfahrung qmail-local-handlers[6198]: Handlers Filter before-local for qmail started ...
Aug 28 10:08:08 IT-Erfahrung qmail-local-handlers[6198]: from=
Aug 28 10:08:08 IT-Erfahrung qmail-local-handlers[6198]: to=support@it-erfahrung.de
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.246610 status: local 1/10 remote 0/20
Aug 28 10:08:08 IT-Erfahrung spamd[2750]: spamd: got connection over /tmp/spamd_full.sock
Aug 28 10:08:08 IT-Erfahrung spamd[2750]: spamd: using default config for support@it-erfahrung.de: /var/qmail/mailnames/it-erfahrung.de/spport/.spamassassin/user_prefs
Aug 28 10:08:08 IT-Erfahrung spamd[2750]: spamd: processing message (unknown) for support@it-erfahrung.de:110
Aug 28 10:08:08 IT-Erfahrung spamd[2750]: spamd: clean message (0.6/5.0) for support@it-erfahrung.de:110 in 0.7 seconds, 33763 bytes.
Aug 28 10:08:08 IT-Erfahrung spamd[2750]: spamd: result: . 0 - AWL,NO_REAL_NAME,NO_RELAYS scantime=0.7,size=33763,user=support@it-erfahrug.de,uid=110,required_score=5.0,rhost=localhost,raddr=127.0.0.1,rport=/tmp/spamd_full.sock,mid=(unknown),autolearn=no
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.936334 delivery 205: success: did_0+0+2/
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.936585 status: local 0/10 remote 0/20
Aug 28 10:08:08 IT-Erfahrung qmail: 1251446888.936827 end msg 12635566

Wobei SPF ja zu arbeiten scheint:

Aug 28 10:17:17 IT-Erfahrung qmail-queue-handlers[6484]: Handlers Filter before-queue for qmail started ...
Aug 28 10:17:18 IT-Erfahrung qmail-queue-handlers[6484]: from=<andere Domain>
Aug 28 10:17:18 IT-Erfahrung qmail-queue-handlers[6484]: to=<andere Domain>
Aug 28 10:17:18 IT-Erfahrung spf filter[6485]: Starting spf filter...
Aug 28 10:17:18 IT-Erfahrung spf filter[6485]: SPF result: none
Aug 28 10:17:18 IT-Erfahrung spf filter[6485]: SPF status: PASS


Weiß evtl jeamand wos noch was einstellen kann, damit es ordentlich funktioniert?
Das Phänomen habe ich nur bei GMX adressen...

Danke

User avatar
Joe User
Project Manager
Project Manager
Posts: 11583
Joined: 2003-02-27 01:00
Location: Hamburg

Re: SPF arbeitet wohl nicht korrekt ...?

Post by Joe User » 2009-08-28 10:48

mowgly wrote:Remote host said: 550-5.7.1 {mx030} Sorry, your helo has been denied.

Das hat absolut nichts mit SPF zu tun...
Korrigiere Deinen Helo und gut ist es...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

mowgly
Posts: 11
Joined: 2007-04-29 13:39

Re: SPF arbeitet wohl nicht korrekt ...?

Post by mowgly » 2009-08-28 11:06

hmm wieso ist FROG falsch... das ist mein Client zu Hause....
den sollte man doch nennen dürfen wie man will?? Das Problem war ja nicht von Anfang an da...
Die von GMX sagten mir, es sei ein SPF Fehler....

gruß
Mowgly

oxygen
RSAC
Posts: 2179
Joined: 2002-12-15 00:10
Location: Bergheim

Re: SPF arbeitet wohl nicht korrekt ...?

Post by oxygen » 2009-08-28 11:11

Nicht der HELO deines Desktop (dann hätte dein Server die eMail abgelehnt, sie wurde aber korrekt received), sondern der deines Servers.

mowgly
Posts: 11
Joined: 2007-04-29 13:39

Re: SPF arbeitet wohl nicht korrekt ...?

Post by mowgly » 2009-08-28 11:25

hmm ok habe die me datei geändert ,.... nun läuft es .... Ich hatte sie schon mal geändert und dann lief es auch...Es war aber ein anderer Fehler.... Wie wird sie vom system wieder zurückgesetzt?..... Strange ...
Danke Für eure Hilfe

Gruß
Mowgly