Systemzeit Konfiguration

Alles was in keine andere Systemkategorie passt
danu
Posts: 263
Joined: 2005-02-02 11:15

Systemzeit Konfiguration

Post by danu »

In meiner SUSE 11
/etc/sysconfig/clock stehen unter anderem folgende Einträge

Code: Select all

DEFAULT_TIMEZONE=Europe/Berlin
TIMEZONE=Europe/Berlin
ZONE=Europe/Zurich
Ich habe schon eine halbe Nacht im Netz rumgesucht und trotzdem noch
offene Fragen.

1. Was bewirkt jeder einzelne Eintrag ganz genau ?
2. Warum spinnt die Systemzeit, wenn einer dieser Einträge fehlt ?
3. Was für einen Sinn machts, wenn ich hier 3 verschiedene Zeitzonen eintrage ?
(die Kiste kann ja physisch nicht gleichzeitig in Europa und Amerika stehen)

gruss, danu

Roger Wilco
Administrator
Administrator
Posts: 5923
Joined: 2004-05-23 12:53

Re: Systemzeit Konfiguration

Post by Roger Wilco »

Grundsätzlich: http://www.novell.com/documentation/opensuse111/

In der /etc/sysconfig/clock sollten auch Kommentare zur Erklärung der jeweiligen Variablen vorhanden sein.

danu
Posts: 263
Joined: 2005-02-02 11:15

Re: Systemzeit Konfiguration

Post by danu »

Ja, schönen Dank schon mal. Hatte bei Novell auch schon nach sowas gesucht, aber "es" nicht gefunden.
In der /etc/sysconfig/clock sollten auch Kommentare zur Erklärung der jeweiligen Variablen vorhanden sein.
sollte man meinen. Doch bei dieser Distri von 1&1 war das nicht der Fall. Das heisst wohl, dass schon jemand daran geschraubt hat.

Das Problem habe ich nur bei dem einen Server. Also wenn ich da die Zeitzone /Europe/Berlin eintrage und auch das korrekte Zonefile nach /etc/localtime unbenennt oder gelinkt habe, scheint nach einem Reboot auf den ersten Blick alles korrekt.

(HWCLOCK="--localtime")

Code: Select all

hxxxxxx:/ # date
Sam Aug  1 18:58:40 CEST 2009
h1424346:/ # date -u
Sam Aug  1 16:58:46 UTC 2009
hxxxxxx:/ #
Das Sytem jedoch schreibt in den Logfiles und beim Erstellen oder Ändern der Daten die UTC Zeit :roll: Das betrifft wie gesagt nur die eine Kiste. Deswegen habe ich halt jetzt alles auf GMT gesetzt (UTC = Systemzeit) und die Zeit selber von Hand eingestellt.

Nachtrag:
Die Lösung wegen der zeitverschobenen Postfix Logs habe ich hier gefunden
http://www.doomi.ch/dkb.php?dkb_id=DKB020812

Das die Dateien beim Erstellen und Ändern einen UTC Zeitstempel erhalten, scheint normal zu sein. Hardware Uhr wieder auf UTC gestellt, localtime wieder Europe/Berlin, tägliche Synchronisierung mit einem Zeitserver konfiguriert alles ist wieder gut.