[apache2] xmlTextReaderSchemaValidate

Apache, Lighttpd, nginx, Cherokee
olli2k
Posts: 10
Joined: 2005-07-01 14:28

[apache2] xmlTextReaderSchemaValidate

Post by olli2k » 2009-07-22 13:53

Hallo,

ich habe dummerweise auf meinem Web Server (Etch) ein wenig mit Lenny Packages rumprobiert. Leider ist bei dem rumprobieren auch ein apt-get upgrade dabei gewesen. War alles kein Thema, nur Spammassasin hat es mir dabei irgendwie zerschossen. Da dadurch der Spam erheblich zugenommen hat, hab ich wieder alle installierten Packages auf Etch zurück gesetzt. Spamassin läuft wieder, aber der Apache nicht mehr:

apache2: Syntax error on line 116 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: undefined symbol: xmlTextReaderSchemaValidate

Apache2, PHP5, libxml2 etc alles schon x-fach in diveresen Versionen neuinstalliert, hilft alles nichts. Google hat bisher leider auch nicht weitergeolfen, hier vlt nch einige nützliche Hinweise:

ldd libphp5.so
linux-gate.so.1 => (0xffffe000)
libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7a65000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7a50000)
libssl.so.0.9.8 => /usr/lib/i686/cmov/libssl.so.0.9.8 (0xb7a09000)
libpcre.so.3 => /usr/lib/libpcre.so.3 (0xb79e0000)
libdb-4.4.so => /usr/lib/libdb-4.4.so (0xb78e5000)
libbz2.so.1.0 => /lib/libbz2.so.1.0 (0xb78d5000)
libresolv.so.2 => /lib/libresolv.so.2 (0xb78c2000)
libm.so.6 => /lib/libm.so.6 (0xb789c000)
libdl.so.2 => /lib/libdl.so.2 (0xb7897000)
libnsl.so.1 => /lib/libnsl.so.1 (0xb7880000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0xb7856000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0xb77c2000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0xb779e000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0xb779b000)
libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0xb769f000)
libc.so.6 => /lib/libc.so.6 (0xb7561000)
libcrypto.so.0.9.8 => /usr/lib/i686/cmov/libcrypto.so.0.9.8 (0xb740e000)
/lib/ld-linux.so.2 (0x80000000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0xb7406000)
libkeyutils.so.1 => /lib/libkeyutils.so.1 (0xb7403000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb73ea000)


/usr/lib# nm libxml2.so.2
nm: libxml2.so.2: no symbols


Bin für jeden Tipp sehr dankbar.

Roger Wilco
Administrator
Administrator
Posts: 6001
Joined: 2004-05-23 12:53

Re: [apache2] xmlTextReaderSchemaValidate

Post by Roger Wilco » 2009-07-22 19:42

http://www.linuxforen.de/forums/showthread.php?t=262666
http://debianforum.de/forum/viewtopic.php?f=8&t=112540


Bringe alle relevanten Pakete auf die Version von Debian Etch zurück. Keine Backports, keine 3rd-Party Pakete. Dann sollte es wieder funktionieren.

olli2k
Posts: 10
Joined: 2005-07-01 14:28

Re: [apache2] xmlTextReaderSchemaValidate

Post by olli2k » 2009-07-23 10:10

Hallo und vielen Dank für den Tipp, allerdings dachte ich dieses bereits getan zu haben, gibt es irgend einen Befehl, wie ich mir alle noch installierten Lenny Pakete listen lassen kann?
Und zum Schluss noch eien theoretische Frage, würde ein vollständiges Dist Upgrade mein Problem auch lösen?

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: [apache2] xmlTextReaderSchemaValidate

Post by Joe User » 2009-07-23 10:33

Olli2k wrote:Und zum Schluss noch eien theoretische Frage, würde ein vollständiges Dist Upgrade mein Problem auch lösen?

Mit hoher Wahrscheinlichkeit und nicht nur dieses Problem...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

olli2k
Posts: 10
Joined: 2005-07-01 14:28

Re: [apache2] xmlTextReaderSchemaValidate

Post by olli2k » 2009-07-23 20:10

Habs, allerdings lag es nicht an den unterschiedlichen Packages. Auf meinem System waren mehrere libxml2 installationen aktiv. Nachdem ich alles deinstalliert habe (alle apache2 und php5 module die installiert waren) und dann alle noch vorhandenen libxml2.so.x Dateien gelöscht habe, hat es nach einer Neuinstallation aller benötigter Komponenten geklappt.