Invalid command 'php_flag'

Apache, Lighttpd, nginx, Cherokee
tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Invalid command 'php_flag'

Post by tsaenger » 2008-12-26 01:02

Hallo,

ich habe gerade meinen Server von sarge auf etch geupgradet.
Nun habe ich mehrere Probleme mit denen ich fertig werden muss:
Zum einen bekomme ich beim Starten des Apaches folgende Fehlermeldung:

Code: Select all

Invalid command 'php_flag'

Installiert ist php5 als cgi sowie suphp.
Als httpd läuft der apache2.2-common

Hat jemand ne Idee woran das liegen kann?

Gruß und Danke

Tobias

User avatar
cpedv
Posts: 15
Joined: 2008-12-25 15:56
Location: Köln

Re: Invalid command 'php_flag'

Post by cpedv » 2008-12-26 01:26

Gibt er nicht mehr aus wie in dieser Art?

Code: Select all

Forcing reload of web server (apache2)...Syntax error on line 22 of /etc/apache2/sites-enabled/vhcs2.conf:
Invalid command 'php_flag', perhaps misspelled or defined by a module not included in the server configuration


gruss Gero

tsaenger
Posts: 414
Joined: 2003-08-13 01:14

Re: Invalid command 'php_flag'

Post by tsaenger » 2008-12-26 01:29

doch er sagt, er könne was aus der confixx_mhosts.conf nicht verarbeiten. Dort steht halt mit dem php_flag was drin das bestimmte User was bestimmtes erlaubt bekommen.
Ich verstehe halt nur nicht wieso er sich am php_flag stört.

Gruß

Tobias

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Invalid command 'php_flag'

Post by Roger Wilco » 2008-12-26 12:08

mod_php wird nicht korrekt geladen. Installiere das Modul wieder und es sollte gehen.