Postfix Problem Smtp Auth

User avatar
groove21
Posts: 5
Joined: 2008-08-27 11:01
Location: Oberkirch/Baden

Postfix Problem Smtp Auth

Post by groove21 »

Hallo,

bin schon echt am verzweifeln. Suche schon seit Stunden für eine Lösung meines Problems, jedoch habe ich bis jetzt leider nichts gefunden. Ich hoffe Ihr könnt mir helfen. Ich will auf meinem Server SMTP-Auth aktivieren. Jedoch klappt da leider nicht wirklich was. Beim Senden kommt Relay access denied und beim Empfang kommt zwar kein Fehler, aber es kommen keine Mail rein. Erst der Fehler aus der mail.log:

Aug 27 03:24:11 fgserver postfix/smtpd[3161]: warning: SASL per-process initialization failed: generic failure
Aug 27 03:24:11 fgserver postfix/smtpd[3161]: fatal: SASL per-process initialization failed
Aug 27 03:24:12 fgserver postfix/master[3144]: warning: process /usr/lib/postfix/smtpd pid 3161 exit status 1
Aug 27 03:24:12 fgserver postfix/master[3144]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling


Hier meine Configs:

postfix/main.cf

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = fgserver.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = fgserver.de, localhost.example.com, localhost.localdomain, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

### CONFIXX POSTFIX ENTRY ###

virtual_maps = hash:/etc/postfix/confixx_virtualUsers, hash:/etc/postfix/confixx_localDomains

### /CONFIXX POSTFIX ENTRY ###
myorigin = /etc/mailname
inet_protocols = all


postfix/master.cf

#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# ==========================================================================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ==========================================================================
smtp inet n - - - - smtpd
#submission inet n - - - - smtpd
# -o smtpd_enforce_tls=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps inet n - - - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}



und die postfix/sasl/smtpd.conf:


“pwcheck_method: saslauthd”
“mech_list: PLAIN LOGIN”



Ich hoffe Ihr könnt mir helfen. Schon mal vielen Dank!

MfG
groove
Top

User avatar
daemotron
Administrator
Administrator
Posts: 2800
Joined: 2004-01-21 17:44

Re: Postfix Problem Smtp Auth

Post by daemotron »

Ist denn der saslauthd konfiguriert und gestartet? Der Dienst wird normalerweise von den MRAs bereitgestellt (Cyrus, Dovecot, ...)
Top

User avatar
Joe User
Project Manager
Project Manager
Posts: 11518
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Postfix Problem Smtp Auth

Post by Joe User »

groove21 wrote:und die postfix/sasl/smtpd.conf:


“pwcheck_method: saslauthd”
“mech_list: PLAIN LOGIN”


Die Hochkommata gehören dort nicht hin...
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.
Top

User avatar
groove21
Posts: 5
Joined: 2008-08-27 11:01
Location: Oberkirch/Baden

Re: Postfix Problem Smtp Auth

Post by groove21 »

Vielen Dank für eure Hilfe. Der POP3 Empfang klappt nun problemlos, nachdem ich die Hochkommata entfernt hatte. Nur der Versand macht Probleme. Thunderbird schätzt mein Zertifikat als unglaubwürdig ein, wenn ich das Zertifikat jedoch akzeptiere und das Passwort eingebe, wird dieses zurückgewiesen (Passwort stimmt aber).

Hier der Fehler:

Aug 27 12:32:17 fgserver postfix/smtpd[4882]: warning: 99.Red-88-25-52.staticIP.rima-tde.net[88.25.52.99]: SASL PLAIN authentication failed: authentication failure
Aug 27 12:32:17 fgserver postfix/smtpd[4882]: warning: 99.Red-88-25-52.staticIP.rima-tde.net[88.25.52.99]: SASL LOGIN authentication failed: authentication failure
Aug 27 12:32:27 fgserver postfix/smtpd[4882]: warning: SASL authentication failure: Password verification failed


Habt Ihr eine Idee, an was das liegen könnte?

Vielen Dank für eure Hilfe!

MfG
groove

EDIT: Ich benutze Confixx und will mit SMTP Auth verifizieren. Habe es nach dieser Anleitung gemacht: http://www.howtoforge.de/howto/das-perf ... etch-40/5/
Ist da irgendwas faul? Kann vielleicht jemand der Confixx in Verbindung mit SMTP Auth und Spamassassin nutzt hier mal die Configfiles main.cf/master.cf und smtpd.conf mal posten? Wäre super!
Top