Immer öfters leere Seiten

Apache, Lighttpd, nginx, Cherokee
wiedervergessen2
Posts: 22
Joined: 2008-01-07 22:09

Immer öfters leere Seiten

Post by wiedervergessen2 » 2008-05-13 14:36

Ich hab immer wieder zwischendurch den Fall, dass beim Aufruf einer PHP Seite leere Seiten entsehen.....mit einem reload wird die Seite dann geladen.

Mein Konfiguration ist diese hier:

<IfModule mpm_worker_module>
StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
</IfModule>

In den Logdateien steht auch nix dazu drin.....

Hat jemand eine Idee ?

Danke!

User avatar
Joe User
Project Manager
Project Manager
Posts: 11138
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Immer öfters leere Seiten

Post by Joe User » 2008-05-13 15:13

URL zur phpinfo() des betroffenen VHost.
PayPal.Me/JoeUserFreeBSD Remote Installation
Wings for LifeWings for Life World Run

„If there’s more than one possible outcome of a job or task, and one
of those outcomes will result in disaster or an undesirable consequence,
then somebody will do it that way.“ -- Edward Aloysius Murphy Jr.

wiedervergessen2
Posts: 22
Joined: 2008-01-07 22:09

Re: Immer öfters leere Seiten

Post by wiedervergessen2 » 2008-05-13 17:10

http://www.sendspace.com/file/acx6yh

(einfach ganz runter zum link scrollen)

Roger Wilco
Administrator
Administrator
Posts: 5924
Joined: 2004-05-23 12:53

Re: Immer öfters leere Seiten

Post by Roger Wilco » 2008-05-13 17:13

MPM worker und mod_php funktionieren je nach eingesetzten PHP-Erweiterungen nicht gut zusammen (siehe auch Hinweis in der Doku auf php.net). Stelle testweise auf MPM prefork um. Falls das dann geht, solltest du die PHP-Erweiterungen eine nach der anderen überprüfen, ob diese threadsafe sind und die, die es nicht sind, aus der Konfiguration rauswerfen.