Grub error 2 - (Raid) warum wieso?

FreeBSD, Gentoo, openSUSE, CentOS, Ubuntu, Debian
hugohorst
Posts: 17
Joined: 2007-04-20 19:28

Grub error 2 - (Raid) warum wieso?

Post by hugohorst » 2008-03-21 21:25

Hallo,
ich habe da ein kleines Problem und zwar hab ich meinen Rooty über das Kundeninterface des Anbieters rebooten lassen. Doch er kam nie wieder.
Der Bootvorgang bleibt beim Grub 1.5er stehen mit dem Error 2, was soviel bedeuetet, dass die entsprechende Platte nicht geladen werden konnte.

Das 64Bit System hat ein Raidsystem mit zwei 250 GB Platten.

Code: Select all

rescue:/ # fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       30139   242091486   fd  Linux raid autodetect
/dev/sda2           30140       30401     2104515   82  Linux swap / Solaris

Disk /dev/sdb: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1       30139   242091486   fd  Linux raid autodetect
/dev/sdb2           30140       30401     2104515   82  Linux swap / Solaris

Disk /dev/md0: 247.9 GB, 247901585408 bytes
2 heads, 4 sectors/track, 60522848 cylinders
Units = cylinders of 8 * 512 = 4096 bytes

Disk /dev/md0 doesn't contain a valid partition table

df -h:

Code: Select all

rescue:/ # df -h
Filesystem            Size  Used Avail Use% Mounted on
/dev/md0              228G   80G  137G  37% /
sysfs                 228G   80G  137G  37% /sys
debugfs               228G   80G  137G  37% /sys/kernel/debug
udev                  998M   56K  998M   1% /dev
df: `/dev/pts': No such file or directory


Die device.map sieht so aus:
(hd0) /dev/sda
(hd1) /dev/sdb


und die menu.lst:
# Modified by YaST2. Last modification on Di Nov 27 11:13:44 UTC 2007
default
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,0)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd0,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/md0 vga=0x317 resume=/dev/sda2 splash=silent reboot=BIOS insmod=forcedeth mac=0002b32a1794 showopts
initrd /boot/initrd-2.6.18.2-34-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd0,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/md0 vga=normal showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off 3
initrd /boot/initrd-2.6.18.2-34-default


Die Ausgaben stammen alle aus dem Rescue-Modus welcher erfolgreich gestartet werden kann.
Hab mich bislang noch nie am Bootloader versucht, weshalb ich erstmal Expertenratschläge einholen wollte, ob da offensichtlich etwas nicht stimmt.
Soweit ich das sehe ist auf Hardwareseite alles korrekt, doch warum sollte auf einmal der Bootloader nicht mehr funktionieren?
Ich las von der Möglichkeit den Bootloader neu anzulegen doch wie genau geht das?

Ich würde sehr gerne um eine Neuinstallation herumkommen, weshalb ich sehr dankbar wäre wenn Ihr weiterhelfen könntet.

Vielen Dank und frohe Ostern
MfG