Apache funktioniert nach PHP Update nicht mehr

Apache, Lighttpd, nginx, Cherokee
vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Apache funktioniert nach PHP Update nicht mehr

Post by vivalabam » 2007-11-15 21:49

Hi,
ich habe gerade meinen Apache Webserver von Version 2.0.54 auf die aktuelle 2.2.6 geupdatet was super funktionierte, nur bei PHP funktioniert es nicht.
Ich habe die aktuelle PHP 5.2.5-2.1 versuch zu installieren nur leider will die mein Apache nicht, und lässt sich danach nicht mehr starten, folgende Fehlermeldung kommt :

Code: Select all

httpd2-prefork: Syntax error on line 112 of /etc/apache2/httpd.conf: Syntax error on line 23 of /etc/apache2/sysconfig.d/loadmodule.conf: API module structure 'php5_module' in file /usr/lib/apache2/mod_php5.so is garbled - expected signature 41503232 but saw 41503230 - perhaps this is not an Apache module DSO, or was compiled for a different Apache version?
, woher bekomme ich den nun eine passende php5 Version für den Apache ? Ich habe diese aus den Reproarchiven installiert.

Folgende Quellen:

http://download.opensuse.org/repositories/Apache/SUSE_Linux_10.0/
http://download.opensuse.org/repositories/home:/svenwappler/SUSE_Linux_10.0/

Aktuelle Serverconfig:

Suse Linux 10.0
Plesk 8.2

Grüße

VivaLaBam

blacktiger
Posts: 239
Joined: 2003-01-15 17:02
Location: Neustadt a.d.W.

Re: Apache funktioniert nach PHP Update nicht mehr

Post by blacktiger » 2007-11-16 06:43

anscheinend gibt es in der kombi wirklich noch ein paar probleme. habe gestern auch meinen apache auf die 2.2.6 gebracht und neu gestartet. lief wunderbar. dann habe ich php von 5.1.2 auf 5.2.5 geupdatet, dann lies sich bei mir der apache auch nicht mehr starten:

http://www.rootforum.org/forum/view ... hp?t=47614

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Apache funktioniert nach PHP Update nicht mehr

Post by vivalabam » 2007-11-19 21:51

Blacktiger wrote:anscheinend gibt es in der kombi wirklich noch ein paar probleme. habe gestern auch meinen apache auf die 2.2.6 gebracht und neu gestartet. lief wunderbar. dann habe ich php von 5.1.2 auf 5.2.5 geupdatet, dann lies sich bei mir der apache auch nicht mehr starten:

http://www.rootforum.org/forum/view ... hp?t=47614


Gibt es denn in zwischenzeit RPM-Pakete die man ohne Probleme installieren kann ??


Grüße

VivaLaBam

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Apache funktioniert nach PHP Update nicht mehr

Post by vivalabam » 2007-11-20 20:32

VivaLaBam wrote:
Blacktiger wrote:anscheinend gibt es in der kombi wirklich noch ein paar probleme. habe gestern auch meinen apache auf die 2.2.6 gebracht und neu gestartet. lief wunderbar. dann habe ich php von 5.1.2 auf 5.2.5 geupdatet, dann lies sich bei mir der apache auch nicht mehr starten:

http://www.rootforum.org/forum/view ... hp?t=47614


Gibt es denn in zwischenzeit RPM-Pakete die man ohne Probleme installieren kann ??

[edit]Hat keiner irgendwelche Erfahrungen mit der neuen PHP Version unter SuseLinux 10.0 und Plesk???[edit]


Grüße

VivaLaBam

floogy
Posts: 150
Joined: 2007-10-23 22:00

Re: Apache funktioniert nach PHP Update nicht mehr

Post by floogy » 2007-11-20 22:19

SUSE_Linux_10.0

Ich denke, 10.3 ist aktuell?
Ich nehme mal an, pushen kommt hier nicht so gut an...

User avatar
Joe User
Project Manager
Project Manager
Posts: 11599
Joined: 2003-02-27 01:00
Location: Hamburg

Re: Apache funktioniert nach PHP Update nicht mehr

Post by Joe User » 2007-11-20 23:08

floogy wrote:Ich denke, 10.3 ist aktuell?

Jupp, allerdings wird 10.0 noch wenige Monate supportet.
floogy wrote:Ich nehme mal an, pushen kommt hier nicht so gut an...

ACK.

vivalabam
Posts: 22
Joined: 2007-09-08 23:46

Re: Apache funktioniert nach PHP Update nicht mehr

Post by vivalabam » 2007-11-21 07:21

Joe User wrote:
floogy wrote:Ich denke, 10.3 ist aktuell?


Jupp, allerdings wird 10.0 noch wenige Monate supportet.

floogy wrote:Ich nehme mal an, pushen kommt hier nicht so gut an...

ACK.



Ich denke der Support läuft ende November aus (http://lists.opensuse.org/opensuse-announce/2007-09/msg00004.html)
, leider ist ein Update bei mir nicht möglich da ich einen VPS bei Hosteu... habe und diese leider keine aktuelle Versionen anbieten und auch nicht supporten.

Ich pushe hier gar nichts, ich würde nur gerne eine Antwort bekommen.

Grüße VivaLaBam